FP : Les Contenus Inclus et les Bordures Partagées ne s'affichent pas correctement sur IIS

Traductions disponibles Traductions disponibles
Numéro d'article: 298827 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F298827
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
IMPORTANT : cet article contient des informations sur la modification du registre. Avant de modifier le registre, assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la procédure à suivre, consultez la rubrique d'aide " Restauration du registre " dans Regedit.exe ou la rubrique " Restauration d'une clé de registre " dans Regedt32.exe.
Agrandir tout | Réduire tout

Sommaire

Symptômes

Après la mise à niveau de votre site Web Microsoft Internet Information Services vers les extensions Microsoft FrontPage Server 2002 ou SharePoint Team Services de Microsoft, les contenus inclus et les bordures partagées ne sont pas affichées correctement. Le corps de la page principale est affiché comme faisant partie de la bordure partagée ou du contenu inclus, ce qui semble copier les données en double sur la page. En outre, après l'insertion d'une page de type PhotoGallery ou incluse, le programme affiche le chemin de la page et non son contenu. En mode Normal dans FrontPage, la page est affichée correctement mais lorsque vous l'affichez dans un navigateur Web, vous ne voyez plus que le chemin.

Cause

Ce problème est dû à la configuration des paramètres qui définissent les performances sur le serveur, en particulier le paramètre MaxCacheDocumentSize. Pour savoir comment configurer ces paramètres, consultez la section "Informations supplémentaires" plus bas dans cet article.

Contournement

Supprimez les clés de registre qui affectent les composants. Pour cela, procédez comme suit :

AVERTISSEMENT : toute mauvaise utilisation de l'Éditeur du registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.

Pour plus d'informations sur la procédure à suivre pour modifier le registre, consultez la rubrique d'aide " Modification des clés et des valeurs " dans l'Éditeur du registre (Regedit.exe) ou les rubriques d'aide " Ajout et suppression d'informations dans le registre " et " Modification des données de registre " dans Regedt32.exe. Pensez à sauvegarder le registre avant de le modifier. Si vous exécutez Windows NT ou Windows 2000, nous vous conseillons également de mettre à jour votre disquette de réparation d'urgence (ERD, Emergency Repair Disk).

Paramètres globaux

IMPORTANT : Appliquez ces étapes soigneusement car ces paramètres affectent tous les sites sur votre serveur.
  1. Dans le menu Démarrer de Windows, pointez sur Exécuter.
  2. Dans la zone Ouvrir, tapez regedit, puis cliquez sur OK.
  3. Recherchez l'emplacement de la clé de registre suivante :
    HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools\Web Server Extensions\All Ports
  4. Supprimez les entrées suivantes :
    • CacheMaxDocMeta
    • CacheMaxInclude
    • CacheMaxImage
    • CacheMaxIncludeSize
  5. Quittez l'Éditeur du registre.
  6. Recalculez les sites Web affectés sur le serveur Web.

Paramètres spécifiques au site

IMPORTANT : Appliquez ces étapes pour tous les sites sur lesquels des problèmes se posent.
  1. Dans le menu Démarrer de Windows, pointez sur Exécuter.
  2. Dans la zone Ouvrir, tapez regedit, puis cliquez sur OK.
  3. Repérez la sous-clé de registre suivante
    HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools\Web Server Extensions\Ports\Port /LM/W3SVC/#:
    où # est l'instance Microsoft Internet Information Services (IIS) du site.

  4. où # est l'instance Microsoft Internet Information Services (IIS) du site. Supprimez les entrées suivantes :
    • CacheMaxDocMeta
    • CacheMaxInclude
    • CacheMaxImage
    • CacheMaxIncludeSize
  5. où # est l'instance Microsoft Internet Information Services (IIS) du site. Quittez l'Éditeur du registre.
  6. où # est l'instance Microsoft Internet Information Services (IIS) du site. Recalculez les sites Web affectés sur ce site Web particulier.

Résolution

Pour résoudre ce problème, procurez-vous le dernier Service Pack de Microsoft Office XP. Pour plus d'informations, consultez l'article suivant dans la Base de connaissances Microsoft :
307841 OFFXP : Procédure pour obtenir le dernier Service Pack de Microsoft Office XP

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section "Liste des produits concernés par cet article". Ce problème a été corrigé dans le Service Pack 1 de Microsoft Office XP.

Plus d'informations

Pour plus d'informations sur les options de réglage des performances et les valeurs du registre utilisées par les extensions FrontPage Server 2002 et SharePoint Team Services, visitez le site Web Microsoft à l'adresse suivante :
http://www.microsoft.com/TechNet/prodtechnol/sharepnt/proddocs/admindoc/ows000.asp
Pour plus d'informations sur ce problème dans les serveurs UNIX, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
299360 FP2002 : Le composant Include et les bordures partagées ne s'affichent pas correctement sur les serveurs UNIX

Propriétés

Numéro d'article: 298827 - Dernière mise à jour: lundi 24 février 2014 - Version: 3.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft SharePoint Team Services
  • Extensions serveur Microsoft FrontPage 2002
  • Microsoft FrontPage 2002 Standard
  • Microsoft FrontPage 2000 Standard
  • Microsoft FrontPage 98 Standard
Mots-clés : 
kbnosurvey kbarchive kbbug kbfix kbofficexpsp1fix KB298827
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com