Mampu menegosiasikan otentikasi Kerberos setelah meng-upgrade ke Internet Explorer 6

Terjemahan Artikel Terjemahan Artikel
ID Artikel: 299838 - Melihat produk di mana artikel ini berlaku.
Perbesar semua | Perkecil semua

GEJALA

Setelah Anda meng-upgrade ke Internet Explorer 6 atau Internet Explorer 6 Paket Layanan 1 (SP1), Internet Explorer tidak dapat menegosiasikan otentikasi Kerberos dengan server Web yang mendukung Kerberos (misalnya, Microsoft Internet Information Services versi 5.0).

PENYEBAB

Masalah ini dapat terjadi karena Internet Explorer 6 atau yang lebih baru untuk Windows 2000 tidak menanggapi negosiasi tantangan dan default untuk otentikasi NTLM, atau Windows NT tantangan/tanggapan, secara default.

PEMECAHAN MASALAH

Untuk mengatasi masalah ini, mengaktifkan Internet Explorer 6 untuk menanggapi tantangan negosiasi dan melakukan otentikasi Kerberos:
  1. Di Internet Explorer, klik Opsi Internet pada Alat menu.
  2. Klik Lanjutan tab, klik untuk memilih Mengaktifkan Windows otentikasi Terpadu (memerlukan restart) centang kotak di Keamanan bagian, dan kemudian klik Oke.
  3. Mulai ulang Internet Explorer.
Administrator dapat mengaktifkan Windows otentikasi terpadu dengan menetapkan nilai EnableNegotiate DWORD ke 1 di dalam kunci registri berikut:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
Catatan Internet Explorer 6, ketika digunakan dengan Microsoft Windows 98, Microsoft Windows 98 Second Edition, Microsoft Windows Millennium Edition, dan Microsoft Windows NT 4.0 tidak menanggapi tantangan negosiasi dan default untuk otentikasi NTLM (atau Windows NT tantangan/tanggapan) bahkan jika Mengaktifkan Windows otentikasi Terpadu (memerlukan restart) kotak centang dipilih karena otentikasi Kerberos tidak tersedia pada sistem operasi ini.

STATUS

Perilaku ini sesuai rancangannya.

INFORMASI LEBIH LANJUT

The Mengaktifkan Windows otentikasi Terpadu (memerlukan restart) kotak centang dipilih secara default di Internet Explorer 6 untuk Windows XP dan Windows Server 2003, sehingga informasi di dalam artikel ini hanya berlaku untuk Internet Explorer 6 atau kemudian untuk Windows 2000. Perhatikan bahwa protokol otentikasi Kerberos masih protokol standar untuk bentuk-bentuk otentikasi jaringan pada komputer berbasis Windows 2000 dengan Internet Explorer versi 6 atau yang lebih baru.

Baik Internet Explorer versi 5.x atau otentikasi Kerberos 6 dan kemudian dukungan dengan proxy server, bahkan jika Windows otentikasi Terpadu diaktifkan. Untuk informasi lebih lanjut tentang masalah ini, klik nomor artikel di bawah ini untuk melihat artikel di dalam Basis Pengetahuan Microsoft:
321728Internet Explorer tidak mendukung otentikasi Kerberos dengan server proxy
Untuk informasi lebih lanjut tentang Windows otentikasi terpadu dengan 5.0 layanan informasi Internet, klik nomor artikel di bawah ini untuk melihat artikel di dalam Basis Pengetahuan Microsoft:
215383Cara mengkonfigurasi IIS untuk mendukung protokol Kerberos dan NTLM protokol jaringan otentikasi
294382 Otentikasi mungkin gagal dengan "401.3" Error jika situs Web "Host Header" berbeda dari nama NetBIOS server
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properti

ID Artikel: 299838 - Kajian Terakhir: 24 September 2011 - Revisi: 2.0
Berlaku bagi:
  • Microsoft Internet Explorer 6.0
Kata kunci: 
kbinterop kbnetwork kbprb kbmt KB299838 KbMtid
Penerjemahan Mesin
PENTING: Artikel ini diterjemahkan menggunakan perangkat lunak mesin penerjemah Microsoft dan bukan oleh seorang penerjemah. Microsoft menawarkan artikel yang diterjemahkan oleh seorang penerjemah maupun artikel yang diterjemahkan menggunakan mesin sehingga Anda akan memiliki akses ke seluruh artikel baru yang diterbitkan di Pangkalan Pengetahuan (Knowledge Base) dalam bahasa yang Anda gunakan. Namun, artikel yang diterjemahkan menggunakan mesin tidak selalu sempurna. Artikel tersebut mungkin memiliki kesalahan kosa kata, sintaksis, atau tata bahasa, hampir sama seperti orang asing yang berbicara dalam bahasa Anda. Microsoft tidak bertanggung jawab terhadap akurasi, kesalahan atau kerusakan yang disebabkan karena kesalahan penerjemahan konten atau penggunaannya oleh para pelanggan. Microsoft juga sering memperbarui perangkat lunak mesin penerjemah.
Klik disini untuk melihat versi Inggris dari artikel ini:299838

Berikan Masukan

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com