COMO: Enviar resultados de formulário para uma base de dados ou correio electrónico através do componente 'Envio de ficheiros' do FrontPage 2002

Traduções de Artigos Traduções de Artigos
Artigo: 299931 - Ver produtos para os quais este artigo se aplica.
Este artigo foi publicado anteriormente em PT299931
Expandir tudo | Reduzir tudo

Nesta página

Sumário

Este artigo passo-a-passo explica como utilizar o novo componente Envio de ficheiros do Microsoft FrontPage 2002 enquanto grava os dados de formulário numa base de dados do Access e envia os mesmos para um endereço de correio electrónico.

O componente Envio de ficheiros não pode ser utilizado com o componente Enviar para base de dados do FrontPage 2002, dado que o primeiro requer uma página com uma extensão de ficheiro .htm e o segundo requer uma extensão .asp. Especificamente, o componente Envio de ficheiros é processado no servidor pelo ficheiro Shtml.dll. Quando o utilizador solicita uma página com uma extensão de ficheiro .asp do servidor, isso indica ao servidor que a página contém código ASP do lado do servidor e tem de ser processado pelo ficheiro Asp.dll. O servidor não pode processar a página através de ambos os ficheiros DLL antes de enviar os resultados para o cliente.

Requisitos de hardware e software

  • Microsoft Windows 2000 Server, Microsoft Windows 2000 Advanced Server ou Microsoft Windows NT 4.0 Server
  • Microsoft IIS (Serviços de informações Internet - Internet Information Services) 4.0 ou 5.0
  • Microsoft FrontPage 2002
  • Extensões de servidor do Microsoft FrontPage 2002 no servidor da Web
  • Microsoft Data Access Components (MDAC), versão 2.1 ou posterior

Configurar o projecto da Web no FrontPage 2002

  1. Inicie o FrontPage 2002.
  2. No painel de tarefas, seleccione Modelos de web site.
  3. Seleccione Web vazia nos modelos, especifique um local para a Web a criar e, em seguida, clique em OK. NOTA: Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito.

  4. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Crie as seguintes páginas clicando no ícone Criar uma nova página normal na barra de ferramentas e, em seguida, clique em Guardar como no menu Ficheiro:
    confirmation.htm
    process1.asp
    process2.asp
    display.asp
  5. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Clique em Iniciar (Start), aponte para Programas (Programs), aponte para Acessórios (Accessories) e, em seguida, clique em Bloco de notas (Notepad).
  6. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Escreva o código seguinte na página do Bloco de notas (Notepad):
     [resultados_do_formulário.txt] ColNameHeader=True Format=CSVDelimited MaxScanRows=25
     CharacterSet=OEM Col1=NAME Char Width 255 Col2=EMAIL Char Width 255 Col3=COMMENTS
     Char Width 255 Col4=FILE Char Width 255 
  7. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Guarde esta página num local do disco rígido como Schema.ini. Na caixa de diálogo Guardar como (Save As) do Bloco de notas (Notepad), clique em Todos os ficheiros (All Files) na lista Guardar com o tipo (Save as type).
  8. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. No Bloco de notas (Notepad), clique em Novo (New) no menu Ficheiro (File).
  9. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Deixe esta página em branco e guarde-a no mesmo local do ficheiro Schema.ini, mas com o seguinte nome: resultados_do_formulário.txt.
  10. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Saia do Bloco de notas (Notepad).
  11. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. No FrontPage, clique na pasta _private. No menu Ficheiro, clique em Importar e, em seguida, clique em Adicionar ficheiro. Navegue para o local onde guardou os dois ficheiros que acabou de criar. Seleccione ambos os ficheiros, clique em Abrir e, em seguida, clique em OK.
  12. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Os dois ficheiros deverão estar agora na pasta _private da Web.
  13. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Com a Web aberta no FrontPage, clique em Definições da Web no menu Ferramentas e, em seguida, clique no separador Base de dados.
  14. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Seleccione Adicionar.
  15. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Na caixa Nome, escreva Texto.
  16. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Em Tipo de ligação, certifique-se de que a opção Ficheiro ou pasta na Web actual está seleccionada e, em seguida, clique em Procurar.
  17. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Na lista Ficheiros do tipo, seleccione Microsoft Text Driver.
  18. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Navegue para a pasta _private e seleccione o ficheiro de texto resultados_do_formulário.txt. Clique em OK três vezes para fechar todas as caixas de diálogo.
  19. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Na Lista de pastas, clique com o botão direito do rato na pasta de nível superior, clique em Nova e, em seguida, clique em Pasta no menu de atalho.
  20. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Atribua à pasta o nome Envio.
  21. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Clique com o botão direito do rato nesta nova pasta e, e seguida, clique em Propriedades no menu de atalho.
  22. : Se estiver a criar uma Web baseada no disco, terá de publicar a Web num servidor que corresponda aos requisitos listados no início deste artigo para executar estas páginas com êxito. Na caixa de diálogo Propriedades, desmarque a caixa de verificação Permitir a execução de scripts. Seleccione as caixas de verificação Permitir o envio anónimo para este directório e Permitir substituição de ficheiros existentes por ficheiros enviados e, em seguida, clique em OK.
O projecto da Web ficou configurado.

Configurar as páginas Web

Confirmation.htm

A página de confirmação personalizada é utilizada apenas para enviar o utilizador para a primeira página ASP. Este procedimento ocorre depois de Form.htm ser submetido. Para configurar esta página, siga estes passos:
  1. Abra Confirmation.htm e, em seguida, mude para a vista HTML.
  2. Directamente abaixo do código <HTML>, escreva o seguinte código:
    <meta http-equiv="refresh" content="0; url=../../process1.asp">
  3. Guarde esta página e, em seguida, feche-a.

Default.htm

Default.htm é a página de formulário, uma página de HTML que contém o formulário a submeter. Para configurar esta página, siga estes passos:
  1. No menu Inserir, aponte para Formulário e, em seguida, clique em Caixa de texto.
  2. Faça duplo clique na caixa de texto, escreva Nome para o nome e, em seguida, clique em OK. Também pode adicionar um rótulo, se desejar.
  3. Repita os passos 1 e 2, atribuindo à nova caixa de texto o nome Correio electrónico.
  4. Introduza um componente de formulário Área de texto.
  5. Faça duplo clique na caixa da área de texto, escreva Comentários para o nome e, em seguida, clique em OK.
  6. Introduza o componente Envio de ficheiros. No menu Inserir, clique em Formulário e, em seguida, clique em Envio de ficheiros.
  7. Faça duplo clique na caixa de texto, escreva Ficheiro para o nome e, em seguida, clique em OK.
  8. Utilize o formulário desta página para criar a base de dados do Access e a ligação à base de dados. Para tal, siga estes passos:
    1. Clique com o botão direito do rato dentro do formulário e, em seguida, clique em Propriedades do formulário no menu de atalho.
    2. Clique na opção Enviar para base de dados.
    3. Clique no botão Opções.
    4. Clique no botão Criar base de dados.
    5. Quando o FrontPage apresentar uma mensagem indicando que a base de dados foi criada, clique em OK. Na caixa de diálogo Opções para guardar resultados numa base de dados, clique em Cancelar.
    6. Na caixa de diálogo Propriedades do formulário, verifique se a opção Enviar para está seleccionada e se a caixa Nome do ficheiro (que indica o local de armazenamento dos dados do formulário) apresenta: "_private/resultados_do_formulário.txt" (sem as aspas).
  9. A caixa de diálogo Propriedades do formulário deverá ser apresentada e a opção Enviar para deverá estar seleccionada. Clique no botão Opções.
  10. O formato do ficheiro deverá ser Base de dados de texto que utiliza a vírgula como separador.
  11. No separador Resultados do ficheiro, em Nome do ficheiro, mude a extensão do ficheiro predefinido para o qual pretende enviar resultados de .csv para .txt (por exemplo, _private/resultados_do_formulário.txt).
  12. Clique no separador Resultados do correio electrónico.
  13. Escreva o endereço de correio electrónico para o qual pretende enviar os resultados do formulário.
  14. Clique no separador Página de confirmação.
  15. Clique no botão Procurar, seleccione confirmation.htm e, em seguida, clique em OK.
  16. Clique no separador Campos guardados.
  17. Seleccione B1 e, em seguida, prima DELETE para remover B1 da lista.
  18. Clique no separador Envio de ficheiros.
  19. Clique em Procurar e, em seguida, seleccione a pasta Envio criada anteriormente.
  20. Clique em OK para fechar a caixa de diálogo Guardar os resultados e, em seguida, clique em OK novamente para fechar a caixa de diálogo Propriedades do formulário.
  21. Guarde e feche a página.

Process1.asp

Process1.asp contém código personalizado que chama o último registo da página resultados_do_formulário.txt e, em seguida, copia estas informações para um formulário com caixas de entrada de texto, para que o utilizador possa verificar as respectivas informações antes de as enviar para a base de dados do Access. O URL para o ficheiro enviado encontra-se num campo oculto, dado que não pretende que seja alterado pelo utilizador. O ficheiro já foi enviado e, nesta fase, não é possível ao utilizador efectuar alterações.
  1. Abra Process1.asp no FrontPage Editor.
  2. Mude para a vista HTML e, em seguida, escreva o seguinte código directamente abaixo do código <HTML>:
    <%
    	'////////////////////////////////////////////////////////// 
    	'//  The first two lines of code are calling the connection 
    	'//  object for the text file that is stored in the 
    	'//  global.asa file.
    	'////////////////////////////////////////////////////////// 
    
    Set Conn = Server.CreateObject("ADODB.Connection")
    Conn.Open Application("text_ConnectionString") 
    	'////////////////////////////////////////////////////////// 
    	'//  Next you create a record set object, execute the  
    	'//  database connection and a SQL query.
    	'////////////////////////////////////////////////////////// 
    
    Set RS = Conn.Execute ("SELECT * From resultados_do_formulário.txt")
    
    	'////////////////////////////////////////////////////////// 
    	'//  You then use code to loop through the database and  
    	'//  select the last record entered.
    	'////////////////////////////////////////////////////////// 
    
    Dim iCnt
    Do Until RS.EOF
    iCnt = iCnt + 1
      Name = RS("Nome")
      Email = RS("Correio electrónico")
      Comments = RS("Comentários")
      File = RS("Ficheiro")
    RS.MoveNext
    Loop
    	'////////////////////////////////////////////////////////// 
    	'//  Close the record set and the connection.
    	'////////////////////////////////////////////////////////// 
    
    RS.Close
    Conn.Close
    %>
    
  3. Mude para a vista normal.
  4. No menu Inserir, aponte para Formulário e, em seguida, clique em Caixa de texto para inserir na página um formulário com uma caixa de texto.
  5. Faça duplo clique na caixa de texto e atribua-lhe o nome Nome.
  6. Na caixa Valor inicial, escreva o seguinte:
    <% = Name %>
  7. Repita os passos 4, 5 e 6 para os campos Correio electrónico e Comentários (excepto o campo Comentários que é uma área de texto) e, em seguida, defina os nomes e os valores iniciais correctamente.
  8. Clique com o botão direito do rato dentro do formulário e, em seguida, seleccione Propriedades do formulário no menu de atalho.
  9. Clique na opção Enviar para (a caixa de listagem deverá apresentar ISAPI, NSAPI, CGI, ou script ASP personalizados).
  10. Clique no botão Opções. Na caixa Acção, escreva process2.asp e, em seguida, clique em OK.
  11. Clique no botão Avançadas na caixa de diálogo Propriedades do formulário e, em seguida, clique em Adicionar.
  12. Na caixa do nome, escreva Ficheiro.
  13. Na caixa Valor, escreva o seguinte código:
    <% = File %>
  14. Clique em OK três vezes para regressar à página.
  15. Guarde esta página e feche-a.

Process2.asp

Process2.asp contém uma área de resultados da base de dados com uma instrução de SQL personalizada que introduz as informações transmitidas por Process1.asp para a base de dados do Access.
  1. Abra Process2.asp no FrontPage Editor.
  2. No menu Inserir, aponte para Base de dados e, em seguida, clique em Resultados para iniciar o Assistente de resultados de base de dados.
  3. Na página 1 do assistente, escolha a ligação predefinida e, em seguida, clique em Seguinte.
  4. Na página 2 do assistente, seleccione a opção Consulta personalizada e, em seguida, clique no botão Editar.
  5. Na caixa de diálogo Consulta personalizada, escreva o seguinte código:
     INSERT INTO Results (Nome, Correio electrónico, Comentários, Ficheiro)
     VALUES ('::Nome::', '::Correio electrónico::', '::Comentários::', '::Ficheiro::')
  6. Clique em OK e, em seguida, clique em Seguinte.
  7. Na página 3, clique em Mais opções. Em Mensagem a apresentar se não forem devolvidos registos, escreva o seguinte:
    O perfil foi aceite!
  8. Clique em OK e, em seguida, clique em Seguinte.
  9. Na página 4, clique na lista e seleccione Lista - um campo por item.
  10. Desmarque as caixas de verificação Adicionar rótulos a todos os valores de campo e Colocar separador horizontal entre registos e, em seguida, clique em Seguinte.
  11. Na página 5, desmarque a caixa de verificação Adicionar formulário de procura e, em seguida, clique em Concluir.
  12. Guarde esta página e feche-a.

Display.asp

A página final deste exemplo apresenta registos da base de dados do Access individualmente. Será apresentado um método para mostrar dinamicamente imagens de uma localização de pasta armazenada na base de dados como URL. Este método está explicado e documentado no seguinte artigo da base de dados de conhecimento da Microsoft (Microsoft Knowledge Base):
216285FP: Como mostrar uma imagem utilizando uma base de dados do Microsoft Access
  1. Abra Display.asp no FrontPage Editor.
  2. No menu Inserir, aponte para Base de dados e, em seguida, clique em Resultados para iniciar o Assistente de resultados de base de dados.
  3. Na página 1 do assistente, escolha a ligação predefinida e, em seguida, clique em Seguinte.
  4. Na página 2, seleccione os resultados como origem de registos e, em seguida, clique em Seguinte.
  5. Na página 3, pode editar a lista de registos apresentada para remover os campos que não pretende que apareçam.
  6. Clique em Seguinte.
  7. Na página 4, seleccione Lista - um campo por item e, em seguida, clique em Seguinte.
  8. Na página 5, seleccione a opção Dividir os registos por grupos e, em seguida, escreva 1 na caixa de entrada.
  9. Clique em Concluir.
  10. Localize o valor da coluna da base de dados <<Ficheiro>> e elimine-o.
  11. Na célula da tabela da qual acabou de remover o valor da coluna, insira qualquer imagem pessoal ou de ClipArt.
  12. Clique com o botão direito do rato na imagem que acabou de inserir e, em seguida, clique em Propriedades da imagem no menu de atalho.
  13. No separador Geral, clique em Parâmetros em Origem da imagem.
  14. No campo do caminho, remova o caminho actual, clique em Inserir valor do campo e, em seguida, seleccione Ficheiro.
  15. Clique em OK duas vezes para regressar à página. Será apresentado um pequeno ícone de uma imagem rasgada na coluna em Ficheiro.
  16. Guarde a página e feche-a.

Visualizar os resultados

Seleccione Default.htm e, em seguida, clique em Pré-visualizar no browser no menu Ficheiro. Escreva as informações no formulário. Quando submeter o formulário, os dados escritos são guardados no ficheiro Resultados_do_formulário.txt e a mensagem de correio electrónico é enviada. A página de confirmação personalizada apresenta a página Process1.asp, em que poderá ver as informações que acabou de submeter em caixas de entrada de texto. Clique em Submeter para guardar os dados na base de dados do Access.

Escreva o endereço para Display.asp para ver os registos submetidos.

Resolução de problemas

A utilização de um ficheiro de texto como uma base de dados não é uma solução muito escalável. Se estiver a prever um tráfego muito intenso no Web site e a possibilidade de muitos utilizadores submeterem este formulário ao mesmo tempo, deverá contemplar um solução diferente.

REFERÊNCIAS

Para obter informações adicionais, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft (Microsoft Knowledge Base):
216285FP: Como mostrar uma imagem utilizando uma base de dados do Microsoft Access

Propriedades

Artigo: 299931 - Última revisão: 22 de setembro de 2003 - Revisão: 1.1
A informação contida neste artigo aplica-se a:
  • Microsoft FrontPage 2002 Standard Edition
  • Extensões de servidor do Microsoft FrontPage 2002
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Serviços de informação Internet 5.0 da Microsoft
  • Microsoft Windows NT 4.0 Option Pack
  • Microsoft Access 2000 Standard Edition
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbhowto kbhowtomaster KB299931

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com