Errores que busca la utilidad RegClean después de instalar Microsoft Office

Seleccione idioma Seleccione idioma
Id. de artículo: 299958 - Ver los productos a los que se aplica este artículo
Este artículo se publicó anteriormente con el número E299958
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando se intenta ejecutar la utilidad RegClean después de instalar uno de los productos enumerados en la sección "La información de este artículo se refiere a:", es posible que se produzca alguno de los síntomas siguientes:
  • La utilidad RegClean encuentra errores en el Registro del sistema y se muestra la opción para corregir errores en la utilidad RegClean.
  • Cuando se instala un programa de Microsoft Office cuyo estado de instalación es Instalar al utilizar por primera vez y, a continuación, se hace doble clic en un documento asociado a ese programa, es posible que el programa de Office no se inicie. En su lugar, aparece el cuadro de diálogo Abrir con y no se muestra el programa de Office.

Causa

Este problema se debe a que la utilidad RegClean no es compatible con los productos mostrados en la sección "La información de este artículo se refiere a:". Este problema se produce en cualquier producto de Microsoft Windows Installer en el que el estado de instalación del programa esté establecido en Instalar al utilizar por primera vez.

Solución

Para resolver este problema, pruebe los métodos siguientes en el orden en que aparecen.

Método 1: deshacer los cambios del Registro desde RegClean

Para deshacer los cambios realizados por la utilidad RegClean, busque el archivo Undo.reg y, a continuación, haga doble clic en él. De este modo se restauran las entradas de Registro eliminadas.

La utilidad RegClean crea un archivo con el formato siguiente:
Undo equipoaaaammddhhmmss.reg
En este ejemplo, equipo es el nombre del equipo, aaaammdd es la fecha en que la utilidad RegClean hizo los cambios en el Registro y hhmmss es la hora.

Método 2: exigir la instalación del programa de Office

Si se produce este problema al hacer doble clic en un documento desde el Explorador de Microsoft Windows y el documento debería estar asociado a un programa de Office cuyo estado de instalación es Instalar al utilizar por primera vez, siga estos pasos:
  1. Haga clic en Inicio y, a continuación, en Programas.
  2. En el menú Programas, haga clic en el acceso directo correspondiente al programa de Office que desea iniciar (por ejemplo, Microsoft Word).
El programa de Office se instalará y entonces puede hacer doble clic en el documento asociado desde el Explorador de Windows.

Método 3: quitar y reinstalar Office

Puede que tenga que quitar y reinstalar Office para resolver el problema. Para ello, siga estos pasos:
  1. En el Panel de control, haga doble clic en Agregar o quitar programas.
  2. En el cuadro de diálogo Propiedades de Agregar o quitar programas, seleccione la entrada de Office (por ejemplo, haga clic en Microsoft Office XP Professional).

    Si el sistema operativo es Microsoft Windows 2000 o Microsoft Windows XP, haga clic en Quitar.

    Si el sistema operativo es Microsoft Windows 98, Microsoft Windows NT 4.0 o Microsoft Windows Millennium Edition (ME), siga estos pasos:
    1. Haga clic en Agregar o quitar.
    2. En el cuadro de diálogo Opciones del modo Mantenimiento, haga clic en Desinstalar Office.
    3. Haga clic en Siguiente.
  3. Haga clic en para confirmar la eliminación.
  4. Una vez desinstalado Office, inserte el CD-ROM de Office y, a continuación, ejecute el programa de instalación para instalar Office de nuevo.

Más información

La utilidad RegClean ya no se admite y ha sido eliminada de todos los sitios de descarga de Microsoft.

Propiedades

Id. de artículo: 299958 - Última revisión: viernes, 23 de marzo de 2007 - Versión: 4.4
La información de este artículo se refiere a:
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Access 2007
  • Microsoft Office Excel 2007
  • Microsoft Office InfoPath 2007
  • Microsoft Office OneNote 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Project Professional 2007
  • Microsoft Office Project Standard 2007
  • Microsoft Office Publisher 2007
  • Microsoft Office SharePoint Designer 2007
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Outlook 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Word 2007
  • Microsoft Office XP (Setup)
  • Microsoft Office Standard Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Access 2003
  • Microsoft Office FrontPage 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Word 2003
  • Microsoft Office Professional Edition 2003
  • Microsoft Office Student and Teachers Edition 2003
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Excel 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office 2000 Premium Edition
  • Microsoft Office 2000 Professional Edition
  • Microsoft Office 2000 Standard Edition
  • Microsoft Office 2000 Small Business Edition
  • Microsoft Office 2000 Developer Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2000 Standard
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Word 2000 Standard Edition
Palabras clave: 
kbprb KB299958

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com