メッセージ:不一致な Setupx.dll が読み込まれるのはセットアップは続行できません。

文書翻訳 文書翻訳
文書番号: 299961 - 対象製品
すべて展開する | すべて折りたたむ

現象

Microsoft Windows Millennium Edition(Me)にコンピュータをアップグレードしようとすると、次の 1 ようなエラー メッセージを表示することがあります。
SUWIN で、 General Protection Fault が モジュール SUWIN.EXE に発生しました。
-Or-
不一致な Setupx.dll は、読み込まれます。
セットアップを続行できません。 Windows をすべて終了し、再度 MS-DOS がプログラムと try を行いました。
Windows を終了し、 MS-DOS コマンド プロンプトから実行します。
SU0349

原因

この問題が次のオペレーティング システムのいずれかの内の Windows Me をアップグレードしようとし、そして Setupx.dll または Suwin.exe ファイルが破損すると、発生することがあります。
  • Microsoft Windows 98
  • Microsoft Windows 98 Second Edition の場
  • Microsoft Windows 95

解決方法

この問題を回避するために、コマンド プロンプトから Windows Me セットアップを実行します。
  1. ハード・ディスク上のフォルダに Windows Me のインストール ファイルをコピーします。
    1. エクスプローラを起動し、 Windows Me CD-ROM(CD)を含むドライブを次に展開します。
    2. Win9x フォルダを開きます。
    3. 編集メニューで、ファイルとフォルダを選択するために、 すべて選択をクリックします。
    4. 編集メニュー オプションをクリックし、 コピーを選択します。
    5. (C がデフォルトでである)ローカル ハード ドライブを右クリックし、その後、 Windows フォルダをオープンします。
    6. オプション フォルダを開きます。 フォルダが存在しない場合、「オプション」と呼ばれる新しいフォルダを作成し、その後、このフォルダをオープンします。
    7. Install フォルダを右クリック。 フォルダが存在しない場合、「インストール」されることが呼ばれる新しいフォルダを作成します。 表示されるショートカット メニューで、ローカル ドライブの WIN9X フォルダの内容を貼り付けるために、 付けをクリックします。
    8. CD からハード・ディスクにファイルをコピーする方法、サポート技術情報(Microsoft Knowledge Base)の資料を表示するために、次の文書番号をクリックすることについて、 so.For 追加情報を行うよう要求されたら、既存のすべてのファイルを置き換えるのか選択します。
      Q259252 CD-ROM からハード ディスクにファイルとプログラムをコピーする方
  2. Windows 起動ディスクを挿入し、コマンド プロンプトのコンピュータを再起動します。
  3. コマンド プロンプトで、入力します。 c:Enter キーが次に押す、。
  4. データ CD\Windows\Options\InstallEnter キーが次に押す、。
  5. データ SetupEnter キーが次に押す、。 Windows Me セットアップは、起動します。
  6. Windows Millennium Edition のセットアップを開始するために、プロンプトに従います。

プロパティ

文書番号: 299961 - 最終更新日: 2007年8月6日 - リビジョン: 1.4
この資料は以下の製品について記述したものです。
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98 Standard Edition
キーワード:?
kberrmsg kbprb kbsetup KB299961 KbMtja kbmt
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。もし誤訳を発見された場合には、この KB 下部よりフィードバックをお寄せください。
英語版 KB:299961
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com