No puede enviar o recibir mensajes SMTP desde algunos dominios de Internet en Exchange 2000 Server, en Exchange Server 2003 y en Small Business Server 2003

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Síntomas

Este artículo es un compendio de los siguientes artículos disponibles previamente: 322358, 840468 y 924235

Cuando intenta enviar o recibir mensajes en un equipo que ejecuta Microsoft Exchange Server 2003, Microsoft Exchange 2000 Server o Microsoft Windows Small Business Server 2003, experimenta alguno de los síntomas siguientes:
  • El servidor de Exchange no acepta mensajes SMTP (Protocolo simple de transferencia de correo) de algunos dominios de Internet.
  • El servidor de Exchange no puede enviar mensajes SMTP a algunos dominios de Internet.
Si realiza una consulta DNS (Sistema de nombres de dominio) inversa, tal vez observe que el servidor de Exchange que envía el mensaje SMTP no se puede resolver. Si realiza un seguimiento con el Monitor de red, tal vez observe que hay consultas NBT antes de que el servidor de Exchange se desconecte.

El emisor puede recibir el siguiente informe de no entrega (NDR) con el código de error 5.5.0. Este código indica un error de SMTP genérico.
> Algunos de los destinatarios no recibieron su mensaje.
> 
>       Asunto:	
>       Enviado:	24/5/01 6:41 p.m.
> 
> No se puede localizar a los destinatarios siguientes:
> 
> usuario@destino.com el 24/5/01 6:41 p.m.
> El sistema de correo no encontró un método para poder comunicarse con el sistema de destino. Avise al administrador. <Servidor.origen.com> #5.5.0
					
Nota: es posible que aparezca también el código de error siguiente: #5.5.4 Error en la transacción.

Además, el Visor de sucesos de Windows del servidor de Exchange que envía el mensaje puede contener un suceso 4000 o 4001 similar al siguiente:

Tipo de suceso: advertencia
Origen del suceso: MSExchangeTransport
Id. del suceso: 4000
Descripción: Error al entregar un mensaje al dominio remoto 'destino.com'. El mensaje de error es : Error del protocolo SMTP

Causa

Este problema se suele producir si el servidor SMTP de destino realiza una búsqueda inversa y se cumple alguna de las condiciones siguientes:
  • La dirección IP no coincide con el nombre de dominio utilizado en el remite del mensaje de correo electrónico.
  • No existe un registro de puntero (PTR) o no es válido para la dirección IP de servidor SMTP de origen.
Por ejemplo, imagine la situación siguiente. El nombre de dominio que se utiliza en el remite del mensaje es origen.com. Envía el mensaje a un dominio diferente. El servidor SMTP de destino realiza entonces una búsqueda inversa en el mensaje entrante. Si el registro PTR del dominio origen.com no existe o es incorrecto, el servidor SMTP de destino no entrega el mensaje.

Nota: si el adaptador de red conectado a Internet utiliza una dirección IP dinámica, es posible que tenga que configurar el servidor de Exchange para que distribuya el correo desde el dominio origen.com a través de un conector SMTP a un host inteligente.

Nota: puede configurar el servidor de Exchange para que rechace las conexiones entrantes especificando un nombre de dominio en el servidor virtual SMTP. Si realiza esta operación, se efectúan búsquedas inversas en todos los intentos de conexión. Esta configuración está disponible en Control de conexión en la ficha Acceso haciendo clic con el botón secundario del mouse (ratón) en el servidor virtual SMTP y haciendo clic en Propiedades.

Solución

Para resolver este problema, siga estos pasos:
  1. Asegúrese de que los registros DNS públicos alojados en el servidor DNS son correctos. En el servidor DNS, examine lo siguiente:
    • Debe haber un registro MX del dominio que señale a un registro de host (A). Por ejemplo, el registro MX de origen.com señala a mail.origen.com. mail.origen.com es un servidor de correo electrónico válido.
    • Asegúrese de que el registro de host (A) señala a una dirección IP válida. Por ejemplo, asegúrese de que mail.origen.com señala a 209.54.61.76. Ésta es la dirección IP pública del servidor de correo electrónico.
  2. Para cada servidor SMTP o servidor de Exchange que envíe correo electrónico por Internet, asegúrese de que hay un registro PTR válido para la dirección IP pública de dicho servidor. Puede ser un firewall, un enrutador u otro dispositivo que se utilice para publicar la información de dominio en una dirección IP que puedan ver los hosts de Internet.

    Suponga, por ejemplo, que el servidor de Exchange está detrás de un firewall que tiene una IP interna de 10.10.10.1 y que el firewall tiene una IP externa de 4.3.2.1.

    Cuando el servidor de Exchange envía correo electrónico al dominio origen.com a través del firewall, el servidor de correo receptor comprueba que la dirección IP 4.3.2.1 está conectada para las comunicaciones SMTP. El servidor de correo electrónico receptor realiza una búsqueda DNS inversa en esta dirección IP y no necesariamente en el registro MX. El servidor de correo electrónico debe encontrar un registro PTR para 4.3.2.1 que señale a un registro de host válido en el dominio origen.com.

Más información

Las búsquedas inversas producen una carga adicional en los servidores, pero se utilizan habitualmente para impedir que los entornos reciban mensajes de correo electrónico no solicitado (spam). Puede configurar el servidor SMTP para que realice búsquedas inversas en los mensajes de correo electrónico entrantes. Con ello se asegurará de que la dirección IP y el nombre de dominio completo (FQDN) del servidor de mensajes de correo electrónico del emisor coinciden con el nombre de dominio del emisor.

Los servidores de correo de algunos dominios de Internet requieren que se cree un registro PTR válido que dirija la dirección IP del servidor de envío al espacio de nombres del dominio SMTP local. Algunas veces, estos servidores de correo requieren que el registro PTR coincida con el FQDN real de su servidor virtual SMTP en Exchange. Normalmente, se trata del registro MX. Algunos de estos dominios de Internet son AOL.com, Qwest.net, Mindspring, Earthlink y Hotmail. Para enviar correo a estos dominios, cree un registro PTR válido o un registro de búsqueda inversa en el servidor DNS de Internet o externo de su organización.

Si realiza una conexión Telnet con el puerto SMTP del servidor de destino y después intenta mantener una conversión SMTP, la conversación será similar a la siguiente:
C:\telnet servidor.destino.com 25 
220 mail.destino.com ESMTP Postfix 
helo origen.com 
250 mail.destino.com 
mail from:usuario@origen.com 
250 Ok 
rcpt to:usuario@dominioDestino.com 
554 <usuario@origen.com>: Sender address rejected: Domain not found
Asimismo, si realiza una conexión Telnet al puerto 25 en uno de los registros MX de AOL, aparece lo siguiente:
220-rly-ya06.mx.aol.com ESMTP mail_relay_in-ya6.3; Fri, 20 Jan 2006 22:15:42 -05 00 
220-America Online (AOL) and its affiliated companies do not 
220- authorize the use of its proprietary computers and computer 
220- networks to accept, transmit, or distribute unsolicited bulk 
220- e-mail sent from the internet. Effective immediately: AOL 
220- may no longer accept connections from IP addresses which 
220 have no reverse-DNS (PTR record) assigned.

Estado

Este comportamiento es una característica del diseño de la aplicación.

Referencias

Para obtener más información acerca de las búsquedas DNS inversas de mensajes entrantes, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
297412 La opción "Realizar búsqueda DNS inversa en los mensajes entrantes" es para la resolución de nombres de host
Para obtener más información acerca de los registros PTR, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
166753 Se produce un error de búsqueda inversa en el servidor Microsoft DNS al agregar el registro de host
322856 Cómo configurar DNS para usarlo con Exchange Server
Para obtener más información acerca del DNS y de las zonas de búsqueda inversa, visite el siguiente sitio Web de Microsoft:

Para obtener información adicional acerca de cómo configurar un conector SMTP en Exchange 2000 y Exchange Server 2003, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
265293 Cómo configurar el conector SMTP en Exchange
Para obtener información adicional acerca de cómo usar el puerto 25 para probar las comunicaciones SMTP, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
153119 Iniciar una sesión de Telnet en el puerto 25 para comprobar una comunicación SMTP
Para obtener más información acerca de problemas similares en Microsoft Exchange Server 5.5, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:
198981 No se entregan mensajes SMTP en determinados dominios

Propiedades

Id. de artículo: 300171 - Última revisión: lunes, 3 de diciembre de 2007 - Versión: 5.4
La información de este artículo se refiere a:
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server Standard Edition
Palabras clave: 
kbprb KB300171

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