Impossibile inviare o ricevere messaggi SMTP da domini Internet specifici in Exchange 2000 Server, Exchange Server 2003 e Small Business Server 2003

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Sintomi

Questo articolo Ŕ una sintesi degli articoli precedentemente disponibili riportati di seguito: 322358, 840468 e 924235

Quando si tenta di inviare o ricevere messaggi in un computer che esegue Microsoft Exchange Server 2003, Microsoft Exchange 2000 Server o Microsoft Windows Small Business Server 2003, si verificano i seguenti sintomi:
  • Il server di Exchange non accetta messaggi SMTP (Simple Mail Transfer Protocol) da determinati domini Internet.
  • Il server di Exchange non Ŕ in grado di recapitare messaggi SMTP a determinati domini Internet.
Se si esegue una query DNS (Domain Name System) inversa, Ŕ possibile notare che il server di Exchange che invia il messaggio SMTP non pu˛ essere risolto. Osservando una traccia di Network Monitor Ŕ possibile notare che prima della disconnessione del server di Exchange vengono eseguite query di NBT.

Il mittente potrebbe ricevere un rapporto di mancato recapito contenente il codice di errore 5.5.0 simile al seguente. Questo codice indica un errore SMTP generico.
> Il messaggio non ha raggiunto alcuni o tutti i destinatari.
> 
>       Oggetto:	
>       Inviato:	24/05/01 18.41.00
> 
> Impossibile raggiungere i seguenti destinatari:
> 
> utente@dominiointernet.com il 24/05/01 18.41.00
> Impossibile comunicare con il sistema di destinazione. Avvertire l'amministratore. <server.origine.com> #5.5.0
					
Nota ╚ inoltre possibile che venga visualizzato il seguente codice di errore: #5.5.4 Transazione non riuscita.

Inoltre nel Visualizzatore eventi di Windows sul server di Exchange che invia il messaggio potrebbe essere presente un evento 4000 o 4001 analogo al seguente:

Tipo di evento: Avviso
Origine evento: MSExchangeTransport
ID evento: 4000
Descrizione: Recapito del messaggio al dominio remoto "destinazione.com " non riuscito per il motivo seguente: Errore di protocollo SMTP.

Cause

Questo problema si verifica generalmente se il server SMTP di destinazione esegue una ricerca inversa ed Ŕ presente una delle seguenti condizioni:
  • L'indirizzo IP non corrisponde al nome di dominio utilizzato nell'indirizzo mittente del messaggio di posta elettronica.
  • Un record puntatore (PTR) non esiste o non Ŕ valido come indirizzo IP del server SMTP di origine.
Si consideri, ad esempio, lo scenario seguente. Il nome di dominio utilizzato nell'indirizzo mittente del messaggio Ŕ origine.com. Il messaggio viene inviato a un dominio diverso. Il server SMTP di destinazione esegue quindi una ricerca inversa sul messaggio in arrivo. Se il record PTR per il dominio origine.com non esiste o non Ŕ corretto, il server SMTP di destinazione non recapiterÓ il messaggio.

Nota Se la scheda di rete connessa a Internet utilizza un indirizzo IP dinamico, potrebbe essere necessario configurare Exchange Server in modo che la posta venga inviata dal dominio origine.com tramite un connettore SMTP a uno SmartHost.

Nota ╚ possibile configurare il server di Exchange in modo che le connessioni in ingresso vengano rifiutate specificando un nome di dominio sul server virtuale SMTP. Una volta effettuata questa operazione, le ricerche inverse verranno eseguite su tutti i tentativi di connessione. Questa impostazione Ŕ disponibile in Controllo connessione nella scheda Accesso che viene visualizzata facendo clic con il pulsante destro del mouse sul server virtuale SMTP e quindi scegliendo ProprietÓ.

Risoluzione

Per risolvere il problema, attenersi alla seguente procedura:
  1. Assicurarsi che i record DNS pubblici presenti sul server DNS siano corretti. Esaminare i seguenti elementi sul server DNS:
    • ╚ necessaria la presenza di un record MX per il dominio che faccia riferimento a un record host (A) valido. Ad esempio, il record MX per origine.com fa riferimento a mail.origine.com. mail.origine.com Ŕ un server di posta elettronica valido.
    • Assicurarsi che il record host (A) faccia riferimento a un indirizzo IP valido. Ad esempio, verificare che mail.origine.com faccia riferimento a 209.54.61.76. Questo Ŕ l'indirizzo IP pubblico corretto per il server di posta elettronica in uso.
  2. Per ogni server SMTP o computer con installato Exchange Server che invia posta elettronica Internet in uscita assicurarsi che sia presente un record PTR per l'indirizzo IP pubblico di tale server SMTP o computer con Exchange Server. Potrebbe trattarsi di un firewall, un router o un altro dispositivo utilizzato per pubblicare informazioni relative al dominio su un indirizzo IP visibile agli host Internet.

    Ad esempio, il computer con installato Exchange Server Ŕ protetto da un firewall con un indirizzo IP interno 10.10.10.1 e l'indirizzo IP esterno del firewall Ŕ 4.3.2.1.

    Quando il computer che esegue Exchange Server invia un messaggio di posta elettronica al dominio origine.com attraverso il firewall, il server di posta ricevente rileva la connessione dell'indirizzo IP 4.3.2.1 per la comunicazione SMTP. Il server di posta elettronica ricevente esegue una ricerca DNS inversa su questo indirizzo IP, non necessariamente sul record MX. Il server di posta elettronica dovrÓ trovare un record PTR per l'indirizzo 4.3.2.1 che faccia riferimento a un record host valido nel dominio origine.com.

Informazioni

La ricerca inversa causa un overhead aggiuntivo dei server, ma viene comunemente utilizzata per evitare che venga introdotta posta indesiderata negli ambienti. ╚ possibile configurare il server SMTP affinchÚ esegua ricerche inverse sui messaggi di posta elettronica in arrivo. Questa configurazione consente di verificare che l'indirizzo IP, nonchÚ il nome di dominio completo del server da cui vengono inviati i messaggi di posta elettronica corrisponda al nome di dominio del mittente.

I server di posta di alcuni domini Internet richiedono la creazione di un record PTR valido che dall'indirizzo IP del server di origine faccia riferimento allo spazio dei nomi del dominio SMTP locale. A volte tali server di posta richiedono che il record PTR corrisponda al nome di dominio completo del relativo server virtuale SMTP in Exchange. In genere si tratta del record MX. Tra questi domini Internet vi sono AOL.com, Qwest.net, Mindspring, Earthlink e Hotmail. Per inviare posta a questi domini, Ŕ necessario creare un record PTR valido o un record di ricerca inversa sul server DNS Internet o esterno della societÓ.

Se si esegue telnet sulla porta SMTP del server di destinazione e quindi si tenta una conversazione SMTP, la conversazione sarÓ simile alla seguente (l'output originale potrebbe essere in inglese):
C:\telnet server.destinazione.com 25 
220 posta.destinazione.com Suffisso ESMTP
helo origine.com 
250 posta.destinazione.com
posta da:utente@origine.com 
250 Ok
destinatario: utente@dominiodestinazione.com
554 <utente@origine.com>: Indirizzo mittente rifiutato: dominio non trovato.
Inoltre, se si esegue telnet sulla porta 25 di uno dei record MX di AOL, verrÓ visualizzato quanto riportato di seguito (l'output originale potrebbe essere in inglese):
220-rly-ya06.mx.aol.com ESMTP mail_relay_in-ya6.3; ven 20 gen 2006 22.15.42 -05 00 
220-America Online (AOL) e le sue consociate non 
220- autorizzano l'uso dei computer di proprietÓ e delle proprie 
220- reti di computer per accettare, trasmettere o distribuire posta elettronica 
220- indesiderata in blocco inviata da Internet. ValiditÓ immediata: AOL
220- potrebbe non accettare pi¨ connessioni da indirizzi IP a cui 
220 non sono assegnati DNS (record PTR) inversi.

Status

Si tratta di un comportamento legato alla progettazione del prodotto.

Riferimenti

Per ulteriori informazioni sulla ricerca DNS inversa per i messaggi in arrivo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
297412 L'opzione "Esegui ricerca DNS inversa sui messaggi in arrivo" riguarda la risoluzione dei nomi host
Per ulteriori informazioni sui record PTR, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
166753 Errore della ricerca inversa dei server DNS Microsoft durante l'aggiunta di record host
322856 Configurazione di DNS per l'utilizzo con Exchange Server
Per ulteriori informazioni su DNS e sulle zone di ricerca inversa, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):

Per ulteriori informazioni sulla configurazione di un connettore SMTP in Exchange 2000 e in Exchange Server 2003, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
265293 Configurazione del connettore SMTP in Exchange 200x
Per ulteriori informazioni sull'utilizzo della porta 25 per il test della comunicazione SMTP, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
153119 Esecuzione di Telnet sulla porta 25 per verificare la comunicazione SMTP
Per ulteriori informazioni su problemi analoghi in Microsoft Exchange Server 5.5, fare clic sul numero dell'articolo della Knowledge Base riportato di seguito:
198981 I messaggi SMTP non vengono recapitati a determinati domini

ProprietÓ

Identificativo articolo: 300171 - Ultima modifica: lunedý 3 dicembre 2007 - Revisione: 5.5
Le informazioni in questo articolo si applicano a
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server Standard Edition
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