Não consegue enviar ou receber mensagens SMTP de determinados domínios da Internet no Exchange 2000 Server, no Exchange Server 2003 e no Small Business Server 2003

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Sintomas

Este artigo é uma consolidação dos seguintes artigos anteriormente disponíveis: 322358, 840468 e 924235

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Quando tenta enviar ou receber mensagens num computador com o Microsoft Exchange Server 2003, o Microsoft Exchange 2000 Server ou o Microsoft Windows Small Business Server 2003, detecta um dos seguintes sintomas:
  • O servidor do Exchange não aceita mensagens do protocolo simples de transferência de correio (SMTP, Simple Mail Transfer Protocol) de determinados domínios da Internet.
  • O servidor do Exchange não consegue enviar mensagens SMTP para determinados domínios da Internet.
Se efectuar uma consulta inversa ao sistema de nomes de domínio (DNS, Domain Name System), poderá observar que não é possível resolver o servidor do Exchange que está a enviar a mensagem SMTP. Se efectuar um rastreio do Monitor de rede (Network Monitor), poderá observar que existem consultas de NBT antes de o servidor do Exchange desligar.

O remetente poderá receber o seguinte relatório de falha de entrega (NDR, non-delivery report) que contém o código de erro 5.5.0. Este código indica uma falha genérica de SMTP.
> A sua mensagem não chegou a um ou mais destinatários.
> 
>       Assunto:	
>       Enviada:	24-05-01 18:41
> 
> Não foi possível contactar o(s) seguinte(s) destinatário(s):
> 
> utilizador@destino.com em 24-05-01 18:41
> Não foi possível ao sistema de correio comunicar com êxito com o sistema de destino. 
> Notifique o administrador. <Servidor.origem.com> #5.5.0

- ou -

> Your message did not reach some or all of the intended recipients.
> 
>       Subject:	
>       Sent:	5/24/01 6:41 PM
> 
> The following recipient(s) could not be reached:
> 
> user@destination.com on 5/24/01 6:41 PM
> Your mail system could not find a way to successfully communicate with the destination system. 
> Please notify your administrator. <Server.source.com> #5.5.0
					
Nota: também poderá receber o seguinte código de erro: #5.5.4 Transacção falhada (Transaction failed).

Além disso, o Visualizador de eventos (Event Viewer) do Windows no servidor do Exchange que está a enviar a mensagem poderá conter um evento 4000 ou 4001 semelhante ao seguinte:

Tipo de evento: Aviso (Warning)
Origem do evento: MSExchangeTransport
ID do evento: 4000
Descrição: A entrega de mensagens ao domínio remoto 'destino.com' falhou pela seguinte razão: erro do protocolo SMTP
[Message delivery to the remote domain 'destino.com' failed for the following reason: SMTP protocol error]

Causa

Normalmente, este problema ocorre se o servidor de SMTP de destino efectuar uma pesquisa inversa (reverse lookup) e caso se verifique uma das seguintes condições:
  • O endereço IP não corresponde ao nome de domínio utilizado no endereço de resposta da mensagem de correio electrónico.
  • Não existe um registo de apontador (PTR), ou o existente não é válido, para o endereço IP do servidor de SMTP de origem.
Por exemplo, considere o seguinte cenário: o nome de domínio utilizado no endereço de resposta da mensagem é origem.com. O utilizador envia a mensagem para outro domínio. Em seguida, o servidor de SMTP de destino efectua uma pesquisa inversa na mensagem recebida. Se o registo PTR do domínio origem.com não existir ou estiver incorrecto, o servidor de SMTP de destino não entrega a mensagem.

Nota: se a placa de rede que está ligada à Internet utilizar um endereço IP dinâmico, poderá ser necessário configurar o Exchange Server para encaminhar correio do domínio origem.com para um anfitrião avançado através de um conector SMTP.

Nota: pode configurar o servidor do Exchange para rejeitar ligações a receber especificando um nome de domínio no servidor virtual de SMTP. Se efectuar esta configuração, as pesquisas inversas serão efectuadas em todas as tentativas de ligação. Esta definição está disponível em Controlo de ligação (Connection Control) no separador Acesso (Access), quando clica com o botão direito do rato no servidor virtual de SMTP e clica em Propriedades (Properties).

Resolução

Para resolver este problema, siga estes passos:
  1. Certifique-se de que os registos públicos de DNS hospedados no servidor de DNS estão correctos. No servidor de DNS, examine o seguinte:
    • Tem de ter um registo MX para o domínio, que aponte para um registo de anfitrião (A) válido. Por exemplo, o registo MX de origem.com aponta para mail.origem.com. mail.origem.com é um servidor de correio electrónico válido.
    • Certifique-se de que o registo de anfitrião (A) aponta para um endereço IP válido. Por exemplo, certifique-se de que mail.origem.com aponta para 209.54.61.76. Este é o endereço IP público correcto do servidor de correio electrónico.
  2. Certifique-se de que existe um registo PTR válido para o endereço IP público de cada servidor de SMTP ou computador com Exchange Server que envie correio electrónico da Internet. Poderá ser um firewall, um router ou outro dispositivo utilizado para publicar as informações do domínio num endereço IP visível por anfitriões da Internet.

    Por exemplo, o computador com o Exchange Server está protegido por um firewall com um IP interno 10.10.10.1 e o firewall tem um IP externo 4.3.2.1.

    Quando o computador com o Exchange Server envia correio electrónico para o domínio origem.com através do firewall, o servidor de recepção de correio vê que o endereço IP 4.3.2.1 está a estabelecer ligação para comunicação SMTP. O servidor de recepção de correio electrónico efectua uma pesquisa de DNS inversa relativamente a este endereço IP, não necessariamente o registo MX. O servidor de correio electrónico tem de encontrar um PTR para o IP 4.3.2.1 que aponte para um registo de anfitrião válido no domínio origem.com.

Mais Informação

A pesquisa inversa impõe uma carga adicional nos servidores, mas é habitualmente utilizada para ajudar a evitar que os ambientes recebam mensagens de correio electrónico não solicitado (spam). Pode configurar o servidor de SMTP para efectuar pesquisas inversas relativamente a mensagens de correio electrónico a receber. Isto garante que o endereço IP e o nome de domínio totalmente qualificado (FQDN, Fully Qualified Domain Name) do servidor da mensagem de correio electrónico do remetente correspondem ao nome de domínio do remetente.

Os servidores de correio de alguns domínios da Internet requerem a criação de um registo PTR válido que aponte o endereço IP do servidor de envio para o espaço de nomes do domínio de SMTP local. Por vezes, estes servidores de correio requerem que o registo PTR corresponda ao FQDN real do respectivo servidor virtual de SMTP no Exchange. Normalmente, é o registo MX. Estes domínios da Internet incluem o AOL.com, Qwest.net, Mindspring, Earthlink e o Hotmail. Para enviar correio para estes domínios, crie um registo PTR ou de pesquisa inversa válido no servidor de DNS externo ou da Internet da empresa.

Se estabelecer ligação por telnet à porta de SMTP do servidor de destino e tentar efectuar uma conversação SMTP, esta será semelhante ao seguinte:
C:\telnet servidor.destino.com 25 
220 mail.destino.com ESMTP Postfix 
helo origem.com 
250 mail.destino.com 
mail from:utilizador@origem.com 
250 Ok 
rcpt to:utilizador@domíniodestino.com 
554 <utilizador@origem.com>: Sender address rejected: Domain not found
Além disso, se estabelecer ligação por telnet à porta 25 com as informações de um dos registos MX da AOL, é apresentado o seguinte:
220-rly-ya06.mx.aol.com ESMTP mail_relay_in-ya6.3; Fri, 20 Jan 2006 22:15:42 -05 00 
220-America Online (AOL) and its affiliated companies do not 
220- authorize the use of its proprietary computers and computer 
220- networks to accept, transmit, or distribute unsolicited bulk 
220- e-mail sent from the internet. Effective immediately: AOL 
220- may no longer accept connections from IP addresses which 
220 have no reverse-DNS (PTR record) assigned.

Ponto Da Situação

Este comportamento ocorre por predefinição.

Referências

Para obter mais informações sobre pesquisa inversa de DNS para mensagens a receber, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
297412 The "Perform Reverse DNS Lookup for Incoming Messages" option is for host name resolution
Para obter mais informações sobre registos PTR, clique nos números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
166753 Microsoft DNS server reverse lookup error adding host record
322856 How to configure DNS to use with Exchange Server
Para obter mais informações sobre DNS e sobre zonas de pesquisa inversa, visite o seguinte Web site da Microsoft:

Para obter mais informações sobre como configurar um conector SMTP no Exchange 2000 e no Exchange Server 2003, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
265293 XFOR: Como configurar o conector SMTP no Exchange 2000
Para obter mais informações sobre como utilizar a porta 25 para testar a comunicação SMTP, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
153119 XFOR: Ligar por Telnet à porta 25 para testar a comunicação SMTP
Para obter mais informações sobre problemas semelhantes no Microsoft Exchange Server 5.5, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
198981 SMTP messages not being delivered to certain domains

Propriedades

Artigo: 300171 - Última revisão: 3 de dezembro de 2007 - Revisão: 5.4
A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server Standard Edition
Palavras-chave: 
kbprb KB300171

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