Article ID: 300491 - Last Review: September 23, 2005 - Revision: 1.1

FIX: Applications That Use Component Categories Manager with Non-Administrator Credentials Fail on Application Center

This article was previously published under Q300491
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SYMPTOMS

If applications that are running on Application Center 2000 servers use the DllGetClassObject function or Component Categories Manager, these applications may fail with one of the following errors:
0x80070005 Access is denied
-or-
Permission to use object denied

CAUSE

Application Center 2000 tightened the security settings for all its component class keys and associated CLSIDs under the HKEY_CLASSES_ROOT registry subtree. Only the following accounts are allowed access to the affected keys in the registry:
  • Administrators
  • System
  • ACA_XXXX
Processes that attempt to touch the affected keys without appropriate credentials will fail with error 0x80040005 (Access denied). This usually affects those processes that use Component Categories Manager or the DllGetClassObject function.

For example, the Component Categories Manager's ICatInformation interface fails in the EnumClassesOfCategories method when it is called from a process that is not running under an Administrator's credentials:
STDMETHODIMP CExample::Example(BSTR sID)
{
...
CComPtr<ICatInformation> pCatInfo;
hr = CLSIDFromString(sID,&clsid);
hr = CoCreateInstance(CLSID_StdComponentCategoriesMgr,NULL,CLSCTX_INPROC,IID_ICatInformation,(LPVOID *) &pCatInfo);
/* EnumClassesOfCategories would fail with error 80040005 on an Application Center 2000 cluster member */ 
hr = pCatInfo->EnumClassesOfCategories(cImplemented,rgcatifImpl,cRequired,rgcatidReq,ppenumCLSID);
...
}
				

RESOLUTION

To resolve this problem, upgrade to Application Center 2000 Service Pack (SP) 1. For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
309384  (http://support.microsoft.com/kb/309384/EN-US/ ) INFO: How to Obtain the Latest Application Center 2000 Service Pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

This problem was corrected in Application Center 2000 Service Pack 1.

MORE INFORMATION

For more information about the Component Categories Manager and its implementation, refer to the Microsoft Platform Software Development Kit (SDK).

APPLIES TO
  • Microsoft Application Center 2000 Standard Edition
Keywords: 
kbbug kbfix kbqfe kbhotfixserver KB300491
 

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