XADM: "C1041737" ошибки и события кодом 470 сообщений может быть отображается при попытке подключения базы данных

Переводы статьи Переводы статьи
Код статьи: 300608 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

Проблема

При попытке подключения базы данных Microsoft Exchange 2000 Server, возможно появление следующих сообщений об ошибках и событиях:
Недопустимое имя одного из файлов базы данных в этом хранилище.
Номер ID: c1041737
Диспетчер Exchange
Тип события: ошибка
Источник события: ESE98
Категория события: Повреждения базы данных
КОД события: 470
Дата: 29 мая 2001 г.
Время: 4:55:47 по
Пользователь: н/Д
Компьютер: имя сервера
Описание::
Частично присоединяется Files\Exchsrvr\Mdbdata\Priv1.edb E:\Program базы данных банка (3112). Уровень вложения: 4. Ошибка:-1022.
Для получения дополнительных сведений щелкните ссылкуhttp://search.support.microsoft.com/search/?adv=1..
Примечание.: Если появляется сообщение об ошибке также появляется сообщение о событии (Event ID 470, ссылающийся на ошибки 1022).

В дополнение к предыдущем сообщений один или несколько из следующих событий регистрируются в журнале приложений.
Тип события: ошибка
Источник события: ESE98
Категория события: производительности
КОД события: 0
Дата: 29 мая 2001 г.
Время: 4:55:47 по
Пользователь: н/Д
Компьютер: имя сервера
Описание::
Хранилище информации (3112) Win32 непредвиденная ошибка:-273865466L
Тип события: ошибка
Источник события: MSExchangeIS
Категория события: Общие
КОД события: 9519
Дата: 29 мая 2001 г.
Время: 4:55:47 по
Пользователь: н/Д
Компьютер: имя сервера
Описание::
Ошибка ввода-ВЫВОДА диска ошибка при запуске базы данных «Первая хранилища Group\Public папки хранилища (имя сервера)» для банка данных Microsoft Exchange.
Для получения дополнительных сведений щелкните ссылкуhttp://search.support.microsoft.com/search/?adv=1..
Тип события: ошибка
Источник события: MSExchangeIS
Категория события: Общие
КОД события: 9518
Дата: 30 мая 2001 г.
Время: 3:49:49 по
Пользователь: н/Д
Компьютер: имя сервера
Описание::
Ошибка Ошибка ввода-ВЫВОДА диска при запуске /dc группы хранения com/dc = Candk/cn = конфигурация/cn = служб/cn = Microsoft Exchange/cn = Candk/cn = административные группы/cn = первый административные группы/cn = серверы/cn = имя сервера/cn = Informationstore/cn = = первая группа хранилищ данных для банка данных Microsoft Exchange.
Для получения дополнительных сведений щелкните ссылкуhttp://search.support.microsoft.com/search/?adv=1..
Тип события: сведения
Источник события: ESE98
Категория события: Общие
КОД события: 104
Дата: 30 мая 2001 г.
Время: 3:49:49 по
Пользователь: н/Д
Компьютер: имя сервера
Описание::
Банк данных (1732) СУБД остановлена экземпляра (0) с ошибкой (-1090).
Для получения дополнительных сведений щелкните ссылкуhttp://search.support.microsoft.com/search/?adv=1..

Причина

Такое поведение наблюдается, когда Exchange 2000 не удается записать на жесткий диск и выдает сообщение об ошибке: либо программное обеспечение, которое было установлено за операции записи, либо сам жесткий диск поврежден. Сообщение, поставляемое с сообщение об ошибке указывает на ошибку 1022. Такая ошибка возникает при обнаружении ошибки ввода вывода (I/O): это может означать, что жесткий диск поврежден.

В Exchange 2000 создается ошибка 1022 всякий раз, когда Exchange 2000 не удается записать на жесткий диск. Несмотря на то, что имеется проблема с жестким диском (например, она была повреждена), такая ошибка также может быть результатом другого программного обеспечения, не совместим с Exchange 2000, которая запрещает запись на жесткий диск Exchange 2000.

Эта проблема может также возникать из-за неправильной разрешений в структуре папки Exchsrvr.

Решение

Чтобы решить эту проблему, начните, запустив следующую команду на всех жестких дисках узел обмен данными:
команда chkdsk /f /r
Если команда chkdsk не приводит к устранению проблемы, проверьте разрешения на доступ к структуре папки Exchsrvr. Убедитесь в том, что система имеет полный контроль над Exchsrvr и все вложенные папки для каждого раздела, содержащего данные Exchange.

Если по-прежнему не удается подключить базы данных, устраните все Windows NT файлового уровня антивирусное программное обеспечение на компьютере Exchange 2000.

Примечание.: Это поведение нельзя исправить, если только остановить антивирусной службы.

Необходимо попытаться перенастроить антивирусное программное обеспечение таким образом, чтобы не сканировать базы данных Exchange и каталоги файлов журнала. In a default installation of Exchange, the database and log files are placed in the C:\Program Files\Exchsrvr\Mdbdata folder. If you have manually moved your logs and/or databases to another drive you must also exclude those directories from being scanned by the antivirus software. After you have made these changes, you can attempt to mount your databases.

If you still have a problem when you attempt to mount your databases, you must remove your antivirus software, and then restart the server. This step can remove the hooks that the antivirus software has into the file system that is not performed if you only stop the antivirus services. When the server has restarted, you can attempt to mount your databases.

If the behavior still persists, you have to troubleshoot your hard disk again. This time, examine the System log for any disk-related errors. You may also want to run the Chkdsk utility on the hard disk to scan for errors.

Свойства

Код статьи: 300608 - Последний отзыв: 22 ноября 2010 г. - Revision: 2.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Exchange 2000 Server Standard Edition
Ключевые слова: 
kberrmsg kbprb kbmt KB300608 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:300608

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com