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"Unable to Connect to Machine" Error Message When You Try to View Remote Counters

Article ID:300702
Last Review:December 3, 2007
Revision:4.3
This article was previously published under Q300702

SYMPTOMS

When you try to use System Monitor to view performance counters on a remote computer, you may receive the following error message:
Unable to connect to machine.

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CAUSE

This problem may occur if you do not have the appropriate permissions on the remote computer to view performance counters.

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RESOLUTION

To be able to view performance counters on a remote computer, you must have the following permissions on the remote computer that you want to monitor:
If the systemroot is on an NTFS partition, you must have at least Read access to the following two files:
%SystemRoot%\System32\Perfc009.dat
%SystemRoot%\System32\Perfh009.dat
You must have at least Read access to the following registry keys on the remote computer:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\winreg
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib
You must have Full access to the following registry key on the remote computer:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\servicename\performance
where servicename is the name of the service on the remote computer that you want to monitor.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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MORE INFORMATION

A user that has administrator rights to the remote computer can already view remote counters.

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APPLIES TO
Microsoft Windows Server 2003, 64-Bit Datacenter Edition
Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Microsoft Windows XP Professional
Microsoft Windows XP Home Edition
Microsoft Windows Small Business Server 2003 Premium Edition
Microsoft Windows Small Business Server 2003 Standard Edition

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Keywords: 
kberrmsg kbprb KB300702

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