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Windows NT 4.0 Winbond Super I/O Floppy Disk Controller May Not Report Data Underrun or Overrun Condition Correctly

Article ID:300987
Last Review:November 1, 2006
Revision:3.2
This article was previously published under Q300987

SYMPTOMS

Under a heavy system load, access to a floppy disk drive may result in the following error message:
System Process - No Disk
There is no disk in the drive. Please insert a disk into drive A.
This error message has occurred during testing of a third-party system using a Winbond Super I/O floppy disk controller. This issue has not been reported during use, only during testing.

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CAUSE

This issue occurs because the Winbond Super I/O controller does not report the data underrun or overrun condition correctly.

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RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem immediately, download the fix by clicking the download link later in this article or contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;en-us;cntactms)
NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The following file is available for download from the Microsoft Download Center:
DownloadDownload Q300987i.exe now (http://www.microsoft.com/Downloads/Release.asp?ReleaseID=32688)
Release Date: September 21, 2001

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 (http://support.microsoft.com/kb/119591/EN-US/) How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file. The English version of this update should have the following file attributes or later:
   Date         Time   Size    File name   Platform
   ------------------------------------------------
   12-Jun-2001  16:40  18,928  Floppy.sys  Intel
   12-Jun-2001  16:36  30,960  Floppy.sys  Alpha  
				
NOTE: Because of file dependencies, this update requires Microsoft Windows NT 4.0 Service Pack 6a.

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STATUS

Microsoft has confirmed this problem only under certain conditions during third-party testing, not during use.

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APPLIES TO
Microsoft Windows NT Workstation 4.0 Developer Edition
Microsoft Windows NT Workstation 4.0
Microsoft Windows NT Server 4.0 Standard Edition
Microsoft Windows NT 4.0 Service Pack 1
Microsoft Windows NT 4.0 Service Pack 2
Microsoft Windows NT 4.0 Service Pack 3
Microsoft Windows NT 4.0 Service Pack 4
Microsoft Windows NT 4.0 Service Pack 5
Microsoft Windows NT 4.0 Service Pack 6a

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Keywords: 
kbbug kbfix kbqfe kbhotfixserver KB300987

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