CÓMO: Crear un proyecto de Visual InterDev

Seleccione idioma Seleccione idioma
Id. de artículo: 301184 - Ver los productos a los que se aplica este artículo
Este artículo se publicó anteriormente con el número E301184
Expandir todo | Contraer todo

En esta página

Resumen

En este artículo paso a paso se demuestra cómo crear y comprobar un nuevo proyecto Web en Visual InterDev con una página Web de ejemplo. En el proyecto Web de Visual InterDev, puede identificar y manipular los archivos de aplicaciones Web. El proyecto no forma parte del conjunto de archivos de aplicaciones Web. Es un archivo que Visual InterDev utiliza para seleccionar los archivos asociados con la aplicación Web.

Requisitos

En la siguiente lista se enumera el hardware y el software necesario:
  • Windows NT 4.0 Professional, Windows NT 4.0 Server, Windows 2000 Professional, Windows 2000 Server o Windows 2000 Advanced Server
  • Servicios de Microsoft Internet Information Server (IIS) versión 4.0 ó 5.0.
  • Microsoft Visual InterDev versión 6.0

Instalar el software requerido

Servicios de Internet Information Server

IIS 5.0 es un requisito mínimo para que cualquier aplicación Web funcione en un equipo basado en Windows 2000. Por lo tanto debe instalar IIS en el equipo de destino antes de continuar. Para instalar IIS, siga las instrucciones que se proporcionan en el siguiente artículo de Microsoft Knowledge Base:
299868 HOW TO: Deploy an ASP Application to Another Server
Visual InterDev 6.0

Debe instalar Visual InterDev antes de crear un proyecto. Para instalar Visual InterDev, siga las instrucciones que se proporcionan en el siguiente artículo de Microsoft Knowledge Base:
243898 INFO: Visual InterDev 6.0 Installation Tips

Crear un nuevo proyecto Web en Visual InterDev

Una vez instalados Visual InterDev y los Servicios de Internet Information Server con las extensiones de servidor de FrontPage, ya puede crear un nuevo proyecto Web de Visual InterDev.

Para crear un nuevo proyecto en Visual InterDev, siga estos pasos:
  1. En el menú Inicio, seleccione Programas, elija Microsoft Visual Studio 6.0 y, a continuación, haga clic en Microsoft Visual InterDev 6.0.

    NOTA: si también ha instalado Microsoft Visual J++ 6.0, ambos productos se mostrarán en la primera pantalla inicial y en otras áreas de Visual InterDev ya que comparten el Entorno de desarrollo integrado (IDE).
  2. En la ventana Nuevo proyecto compruebe que Proyectos de Visual InterDev está seleccionado.

    NOTA: si no puede ver la ventana Nuevo proyecto, haga clic en Nuevo proyecto en el menú Archivo. Para mostrar la ventana Nuevo proyecto de manera predeterminada al abrir Visual InterDev, haga clic en el menú Opciones en el menú Herramientas. En el cuadro de diálogo Opciones, haga clic para expandir el nodo Entorno y, después, haga clic en General. En Al iniciar, haga clic en Mostrar el cuadro de diálogo Nueva solución .
  3. Haga clic en Nuevo proyecto Web.
  4. Escriba el nombre del proyecto en el cuadro de texto Nombre, escriba la ubicación en el cuadro de texto Ubicación y, a continuación, haga clic en Abrir.

    NOTA: la ubicación representa el lugar donde Visual InterDev guarda la copia local de la página Web. No utilice una ubicación de unidad en < unidad >/Inetpub/Wwwroot.
  5. Se abre el Asistente para aplicaciones Web. Siga estos pasos en el asistente:
    1. En el paso 1 del asistente, en el cuadro de lista desplegable ¿Qué servidor desea utilizar? escriba el nombre del equipo. También puede escribir el nombre de un host local en lugar del nombre del equipo. Si está creando una página Web en un servidor remoto, escriba el nombre de ese servidor.

      Para determinar el nombre del equipo en un equipo basado en Windows 2000, haga clic con el botón secundario del mouse (ratón) en Mi PC en el escritorio y, a continuación, haga clic en Propiedades. En la ficha Identificación de red, haga clic en Propiedades. El nombre de su equipo aparecerá en el cuadro de texto Nombre de equipo.
    2. En ¿En qué modo desea trabajar? se muestran las siguientes opciones:

      • Modo Maestro: utilice esta opción si desea que los cambios realizados en los archivos se guarden tanto en los archivos locales de la aplicación Web de la estación de trabajo como en los archivos principales del servidor Web principal.
      • Modo Local: utilice esta opción si desea que los cambios realizados en los archivos se guarden en la estación de trabajo, en la copia del archivo que reside en la aplicación Web local y no en la aplicación Web principal. Debe actualizar explícitamente la aplicación Web principal. Para ello, puede publicar la copia de trabajo, o bien sincronizar el proyecto.
      En este caso, haga clic en Modo Maestro y, a continuación, en Siguiente. Recibirá el mensaje "Estableciendo conexión con el servidor Web".
    3. En el paso 2 del Asistente para proyectos Web, mientras especifica el Web, mantenga la opción predeterminada Crear una nueva aplicación Web y, a continuación, haga clic en Siguiente.
    4. Si desea aplicar un diseño o un tema al proyecto, puede seleccionarlos en los pasos 3 y 4 del Asistente para proyectos Web. No es necesario que su proyecto tenga un tema o un diseño. Haga clic en Finalizar.
    5. Recibirá el mensaje "Creando archivo de proyecto" y "Copiando la biblioteca de secuencia de comandos". Cuando finalice el proceso, el IDE de Visual InterDev se abrirá y podrá ver el Cuadro de herramientas y el Explorador de proyectos.
  6. Haga clic en cualquier parte de la ventana Explorador de proyectos para activarla.
  7. En el menú Proyecto, haga clic en Agregar elemento Web, en Página Active Server, escriba un nombre y, a continuación, haga clic en Abrir. Se mostrará el origen de la nueva página de Active Server Pages (ASP). Haga clic en Pegar como HTML en el menú Edición para pegar el siguiente código ASP tras la etiqueta <BODY>:
    <% Response.Write "Hola" %>
  8. Guarde el proyecto.
  9. Haga clic con el botón secundario del mouse (ratón) en un área en blanco de la página ASP creada y, a continuación, haga clic en Ver en el explorador.
  10. Si puede ver el mensaje "Hola" en la ventana del explorador, ha creado correctamente un proyecto Web en Visual InterDev.
NOTA: este proyecto se ha creado en Modo Maestro en el equipo local. Si desea que uno o más desarrolladores trabajen en este proyecto desde diferentes equipos, deben crear un proyecto en sus equipos, escribir el nombre del equipo donde se encuentra el proyecto principal y seleccionar el Modo Local en el paso 5a. A continuación, deben seleccionar Establecer conexión con una aplicación Web existente en < NombreEquipo > , seleccionar el proyecto al que desean conectarse en el paso 5b y continuar.

Errores

Es posible que encuentre el mensaje de error "No se puede establecer conexión con el servidor Web" en determinadas circunstancias. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
220166 PRB: Troubleshooting "Unable to Contact Web Server" in Visual InterDev
Si el Service Pack 4 de Visual Studio 6.0 está instalado, consulte el siguiente artículo para obtener más información acerca de este mensaje de error:
272289 HOWTO: Troubleshoot Connectivity Issues in Visual InterDev 6.0
NOTA: si el asistente continúa con el paso 2, sabrá que el servidor Web se ha configurado correctamente. De lo contrario, recibirá un mensaje en el que se le notificará que "No se puede establecer conexión con el servidor Web http://< Nombre de equipo >".

Asimismo, puede recibir este mensaje si el servidor Web se ha detenido y debe reiniciarse, o bien si no tiene los privilegios necesarios para establecer conexión con el servidor Web. Para reiniciar los servicios Web de IIS en un equipo basado en Windows 2000, haga clic en Ejecutar en el menú Inicio de Windows. Escriba iisreset y, a continuación, haga clic en Aceptar.

REFERENCIAS

Para obtener más información, visite los siguientes sitios Web de MSDN:
Creating a Web Project (Crear un proyecto Web)
http://www.msdn.microsoft.com/library/default.asp?URL=/library/devprods/vs6/vinterdev/vidref/vihowcreatingwebproject.htm

Tutorial de Visual InterDev (Este programa está en inglés)
http://msdn.microsoft.com/vinterdev/technical/vi6tutorial.exe

Propiedades

Id. de artículo: 301184 - Última revisión: jueves, 10 de abril de 2003 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Visual InterDev 6.0 Standard Edition
Palabras clave: 
kbhowto kbhowtomaster kbvisidsearch kbgrpdsasp kbideproject KB301184

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com