Folder terkompresi rusak ketika lebih dari 2 gigabyte

Terjemahan Artikel Terjemahan Artikel
ID Artikel: 301325 - Melihat produk di mana artikel ini berlaku.
Perbesar semua | Perkecil semua

GEJALA

Ketika Anda membuat folder terkompresi (ZIP file) yang lebih besar daripada 2 gigabyte (GB), file tidak lagi dapat dibaca, dan mungkin rusak. Anda tidak menerima pesan galat ketika Anda membuat file, tetapi Anda tidak dapat membaca berkas setelah membuatnya.

Catatan Dalam Windows Vista dan Windows Server 2008, terkompresi folder dapat lebih besar dari 2 GB. Folder dikompresi dengan algoritma DEFLATE64. Namun, algoritma DEFLATE64 ini tidak kompatibel dengan versi sebelumnya dari Microsoft Windows.

PENYEBAB

Masalah ini dapat terjadi karena batas ukuran untuk folder kompresi adalah sekitar 2 GB.

TEKNIK PEMECAHAN MASALAH

Untuk mengatasi masalah ini, pastikan bahwa Anda membatasi ukuran folder terkompresi 2 GB atau kurang ketika Anda membuat folder terkompresi.

STATUS

Microsoft telah mengkonfirmasi bahwa ini adalah masalah di dalam produk Microsoft sebagaimana tercantum di bagian "Berlaku untuk".Untuk mengatasi masalah ini potensi, fungsi baru diperkenalkan pada tahun 2003 Paket Layanan 1 yang menghitung ukuran total semua file sebelum kompresi. Jika ukuran file gabungan sebelum untuk kompresi lebih besar daripada 2 GB, Windows kembali kesalahan:
Kompresi tidak dapat dilakukan karena ukuran map terkompresi yang dihasilkan terlalu besar.

Properti

ID Artikel: 301325 - Kajian Terakhir: 24 September 2011 - Revisi: 2.0
Berlaku bagi:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Kata kunci: 
kbenv kbprb kbmt KB301325 KbMtid
Penerjemahan Mesin
PENTING: Artikel ini diterjemahkan menggunakan perangkat lunak mesin penerjemah Microsoft dan bukan oleh seorang penerjemah. Microsoft menawarkan artikel yang diterjemahkan oleh seorang penerjemah maupun artikel yang diterjemahkan menggunakan mesin sehingga Anda akan memiliki akses ke seluruh artikel baru yang diterbitkan di Pangkalan Pengetahuan (Knowledge Base) dalam bahasa yang Anda gunakan. Namun, artikel yang diterjemahkan menggunakan mesin tidak selalu sempurna. Artikel tersebut mungkin memiliki kesalahan kosa kata, sintaksis, atau tata bahasa, hampir sama seperti orang asing yang berbicara dalam bahasa Anda. Microsoft tidak bertanggung jawab terhadap akurasi, kesalahan atau kerusakan yang disebabkan karena kesalahan penerjemahan konten atau penggunaannya oleh para pelanggan. Microsoft juga sering memperbarui perangkat lunak mesin penerjemah.
Klik disini untuk melihat versi Inggris dari artikel ini:301325

Berikan Masukan

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com