Artigo: 301438 - Última revisão: sexta-feira, 27 de Outubro de 2006 - Revisão: 4.1

Não pode montar uma base de dados porque existe um registo de transacções danificado no Exchange 2000

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Quando tenta montar um arquivo público ou de uma caixa de correio, poderá receber a seguinte mensagem de erro:
Ocorreu um erro de processamento interno. Tente reiniciar o Exchange System Manager ou o serviço Microsoft Exchange Information Store. ID não: c1041724
Seguintes mensagens de erro e informações poderão ser registadas no registo de eventos de aplicações:

ID do evento: 301
Origem: Ese98
Tipo: informação
Computador: servidor1
Arquivo de informações (2184) o motor de base de dados foi iniciada a reproduzir o ficheiro de registo C:\Programme\Exchsrvr\mdbdata\E00000E7.log.
Para mais informações, clique em http://search.support.microsoft.com/search/?adv=1.

ID do evento: 477
Origem: Ese98
Tipo: erro
Computador: servidor1
Arquivo de informações (2184), que o intervalo de registo de ler o ficheiro "C:\Programme\Exchsrvr\mdbdata\E00000E8.log" no deslocamento 3343872 (0x0000000000330600) para 35328 (0x00008a00) bytes falha na verificação devido a uma discrepância de soma de verificação de intervalo. A operação de leitura irá falhar com o Erro-501 (0xfffffe0b). Se esta condição persistir, em seguida, verifique restaure o ficheiro de registo partir cópia de uma segurança anterior.
Para mais informações, clique em http://search.support.microsoft.com/search/?adv=1.

ID do evento: 465
Origem: Ese98
Tipo: erro
Computador: servidor1
Foi detectada corrupção (2184) do arquivo de informações durante a recuperação simples no ficheiro de registo C:\Programme\Exchsrvr\mdbdata\E00000E8.log. Falha da soma de verificação registo está localizado na posição 6531:471. Dados não corresponde o padrão de preenchimento de ficheiro de registo primeiro apareceram no sector 6600. Este ficheiro de registo foi danificado e não é utilizável.
Para mais informações, clique em http://search.support.microsoft.com/search/?adv=1.

ID do evento: 301
Origem: Ese98
Tipo: informação
Computador: servidor1
Arquivo de informações (2184) O motor de base de dados foi iniciada a reproduzir o ficheiro de registo C:\Programme\Exchsrvr\mdbdata\E00000E8.log.
Para mais informações, clique em http://search.support.microsoft.com/search/?adv=1.

ID do evento: 454
Origem: Ese98
Tipo: erro
Computador: servidor1
O arquivo de informações (2184) da base de dados recuperação/restauro falhou com o erro inesperado-501.

Nota Estas mensagens de erro, a palavra "ficheiro de registo" é uma palavra escrita incorrectamente as palavras "ficheiro de registo".

Causa

Este problema poderá ocorrer se um ficheiro de registo de transacções está danificado. Por exemplo, nos eventos listados na secção "Sintomas", o ficheiro Edb00000E8.log está danificado. O evento ID 477 e mensagens de erro 465 especificamente indicam que o ficheiro Edb00000E8.log está danificado.

Nota O código de erro decimal Extensible Storage Engine 98-501 corresponde à mensagem de erro JET_errLogFileCorrupt.

Resolução

Para resolver este problema, tem de remover o ficheiro de registo danificados do computador do Microsoft Exchange 2000 Server. Para remover o ficheiro de registo danificadas, siga estes passos:
  1. Efectue uma cópia de segurança offline das bases de dados Exchange grupo de armazenamento que contém o ficheiro de registo danificado.

    importante Quando efectua uma cópia de segurança offline, o computador do Exchange 2000 está indisponível para os utilizadores cujas caixas de correio são armazenadas no grupo de armazenamento estiver a efectuar cópia de segurança. O computador do Exchange 2000 está indisponível para os utilizadores porque é necessário desmontar as bases de dados de grupo de armazenamento.
    1. Para desmontar as bases de dados de grupo de armazenamento, siga estes passos.
      1. Clique em Iniciar , aponte para programas , aponte para Microsoft Exchange e, em seguida, clique em System Manager .
      2. Expanda Servers , expanda o servidor que pretende e, em seguida, expanda Storage Group.

        Nota Se tiver grupos administrativos definidos, expanda Administrative Groups , expanda o Administrative Group, expanda Servers , expanda o servidor que pretende e, em seguida, expanda Storage Group.
      3. Clique com o botão direito do rato um arquivo de informações, clique em Dismount Store e em seguida, clique em Sim para continuar.
      4. Desmonte os restantes arquivos listadas em Storage Group.
    2. Efectuar cópias de segurança de grupo de armazenamento utilizando a versão do Microsoft Windows 2000 do programa de cópia de segurança do Windows. É possível executar a cópia de segurança do Windows em qualquer computador na floresta que esteja a executar o Exchange 2000. Para criar cópias de grupo de armazenamento, siga estes passos:
      1. Clique em Iniciar , aponte para programas , aponte para Acessórios , aponte para Ferramentas do sistema e, em seguida, clique em cópia de segurança .
      2. Clique em Assistente de cópias de segurança , clique em seguinte , clique em cópia de ficheiros seleccionados, unidades ou dados de rede e, em seguida, clique em seguinte .
      3. Expandir Microsoft Exchange Server , expanda nome_do_servidor , expanda o Arquivo de informações Microsoft , clique para seleccionar a caixa de verificação para o grupo de armazenamento que pretende efectuar uma cópia de segurança e, em seguida, clique em seguinte .
      4. Na caixa suporte de cópia de segurança ou nome de ficheiro , especifique a localização onde pretende que a cópia de segurança para ser armazenados, clique em seguinte e clique em Concluir para iniciar a cópia de segurança.
    Quando a cópia de segurança estiver concluída, continuam a passo 2.
  2. Utilize o utilitário Eseutil (Eseutil.exe) para determinar se as bases de dados estão num estado consistente ou num estado inconsistente. Um estado consistente é igual um estado de encerramento correcto . Um estado inconsistente é igual um estado de encerramento incorrecto . Para determinar se as bases de dados estão num estado consistente ou num estado inconsistente, siga estes passos:
    1. Certifique-se de que as bases de dados de grupo de armazenamento forem desmontadas.
    2. Mude para a pasta C:\Program Files\Exchsrvr\Bin e, em seguida, execute o comando eseutil /mh utilizando a sintaxe seguinte:
      eseutil /mh "C:\Program Files\Exchsrvr\Mdbdata\ Database .edb"
      Nota Este passo pressupõe que instalou Exchange 2000 na unidade C. Este passo também pressupõe que está a executar Exchange 2000 em Files\Exchsrvr\Bin programa pasta e de que os ficheiros .edb estão na pasta programas Files\Exchsrvr\Mdbdata. Se tiver efectuado uma actualização, os ficheiros de base de dados podem estar localizados na pasta C:\Exchsrvr\Mdbdata. Se tiver vários grupos de armazenamento, os ficheiros de base de dados podem estar localizados numa pasta diferente da pasta Mdbdata.
    3. Nos resultados da saída, localize a linha de saída com o nome "State". Se o estado da base de dados for consistente, verá "estado: limpar o encerramento." Se a base de dados estiver inconsistente, verá "estado: encerramento desactualizadas."
    Para obter informações adicionais sobre onde encontrar o utilitário Eseutil, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    170091  (http://support.microsoft.com/kb/170091/ ) XADM: Localização do utilitário Eseutil

    Para obter informações adicionais sobre parâmetros da linha de comandos Eseutil, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    317014  (http://support.microsoft.com/kb/317014/ ) XADM: Parâmetros da linha de comandos Eseutil do Exchange 2000 Server
  3. Se as bases de dados estiverem consistentes, mova todos os ficheiros de registo fora da pasta onde estão localizados os ficheiros de base de dados e, em seguida, montagem os arquivos. A pasta onde estão localizados os ficheiros de base de dados é normalmente a pasta Exchsrvr\Mdbdata. Tal como com qualquer situação em que um ficheiro de registo está danificado, irá ocorrer perda de alguns dados.
  4. Se as bases de dados estiverem inconsistentes, pode tentar efectuar uma recuperação simples dos ficheiros. importante Para efectuar uma recuperação simples, tem de parar o serviço Microsoft Exchange Information Store. Quando o serviço arquivo de informações é parado, todos os utilizadores com caixas de correio armazenadas no servidor não conseguirá enviar e receber correio.

    Para efectuar uma recuperação simples dos ficheiros, siga estes passos:
    1. Clique em Iniciar , aponte para programas , aponte para Ferramentas administrativas e, em seguida, clique em Serviços .
    2. Localize e, em seguida, clique com o botão direito do rato no serviço Microsoft Exchange Information Store , clique em Parar e aguarde que o serviço Information Store parar.
    3. Na linha de comandos, mude para a pasta onde a base de dados e os ficheiros de registo estão localizados. Por exemplo, mude para a pasta c:\Programas\Exchsrvr\Mdbdata.
    4. Execute o seguinte comando na pasta onde a base de dados e os ficheiros de registo estão localizados:
      "C:\Programas\Microsoft Files\Exchsrvr\Bin\Eseutil" /r E00
      Nota Substitua o nome de base de ficheiro de registo de três caracteres E00.

      Para obter informações adicionais sobre o procedimento de recuperação simples, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
      313184  (http://support.microsoft.com/kb/313184/ ) COMO: Recuperar o arquivo de informações no Exchange 2000 num único local
  5. Se a recuperação de software não tiver êxito, pode tentar efectuar uma recuperação da base de dados Exchange restaurando a partir de uma cópia de segurança. As bases de dados de grupo de armazenamento têm de permanecer desmontados se tentar restaurar a partir de uma cópia de segurança.

    Nota Se tiver activado o registo circular para o grupo de armazenamento que se encontra a base de dados inconsistente na, pode recuperar apenas os dados que estava na base de dados quando efectuou a cópia de segurança completo última do trabalho. Para determinar se o registo circular estiver activado, clique com o botão direito do rato no grupo de armazenamento, clique em Propriedades e, em seguida, ver o estado da caixa de verificação Activar o registo circular .
    • Se restaurar as bases de dados a partir de uma cópia de segurança online, reproduzir apenas registos de transacções sejam mais antigos do que o ficheiro de registo está danificado.

      Para obter informações adicionais sobre como restaurar o Exchange a partir de uma cópia de segurança online, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
      232938  (http://support.microsoft.com/kb/232938/ ) O "última cópia de segurança definido" verificar caixa e recuperação de hardware no Exchange
    • Se restaurar as bases de dados a partir de uma cópia de segurança offline, esvazie as pastas de registo da base de dados e as pastas de registo de transacções. Restaure apenas os ficheiros .edb e os ficheiros .stm.

      Para obter informações adicionais sobre cópia de segurança offline e procedimentos de restauro para o Exchange, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
      296788  (http://support.microsoft.com/kb/296788/ ) Procedimentos de cópia de segurança e restauro offline para o Exchange
  6. Se não existirem cópias de segurança não disponíveis que pode utilizar e se a base de dados permanece num estado inconsistente, pode tentar reparar bases de dados utilizando o comando eseutil /p .

    Nota Se utilizar o comando eseutil /p , poderá perder alguns dados do Exchange 2000. O comando é um comando de disco rígido. Um comando de disco rígido é também conhecido como um comando de recuperação forçada estado. A Microsoft recomenda que utilize este comando apenas se o arquivo de informações público ou o arquivo de informações privado não voltar a um estado consistente depois de efectuar os passos descritos neste artigo.

    Para obter mais informações sobre as consequências de utilizar o comando /p do eseutil, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    259851  (http://support.microsoft.com/kb/259851/ ) Consequências da execução do eseutil /p ou edbutil /d /r comando no Exchange

    Para obter informações adicionais sobre como utilizar o comando de /p eseutil, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    313184  (http://support.microsoft.com/kb/313184/ ) COMO: Recuperar o arquivo de informações no Exchange 2000 num único local

Mais Informação

Para obter informações adicionais sobre recuperação de desastres do Exchange 2000 Server, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
326052  (http://support.microsoft.com/kb/326052/ ) XADM: branco papel - recuperação de desastres do Microsoft Exchange 2000 Server


Para obter informações adicionais sobre como recuperar uma base de dados a partir de uma cópia de segurança offline, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
251403  (http://support.microsoft.com/kb/251403/ ) Base de dados não é montado depois de restaurar uma cópia de segurança offline

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange 2000 Server Standard Edition
Palavras-chave: 
kbmt kberrmsg kbprb KB301438 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 301438  (http://support.microsoft.com/kb/301438/en-us/ )