Artigo: 301474 - Última revisão: quarta-feira, 28 de Julho de 2004 - Revisão: 3.0

Erro: Se recebe um erro "A chave de procura não foi encontrada em qualquer registo" altera mensagem quando compactar uma base de dados ou guardar a estrutura no Access 2000

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Moderado: Requer básica macros, codificação e interoperabilidade competências.

Este artigo aplica-se apenas a uma base de dados do Microsoft Access (.mdb).

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Quando tenta guardar as alterações de estrutura um novo objecto ou quando compactar uma base de dados, receberá a seguinte mensagem de erro:
A chave de procura não foi encontrada em qualquer registo.
Além disso, poderá ver o objecto de base de dados listado na janela Base de dados, apesar de a tentativa de guardar falhou. No entanto, quando abrir o objecto, receberá a seguinte mensagem de erro:
O Microsoft Jet motor de base de dados não é possível localizar o objecto < nome do objecto >. Certifique-se o objecto existe e que ortografia correcta seu nome e nome do caminho.

Causa

Este comportamento ocorre em uma das seguintes circunstâncias:
  • A base de dados foi criado enquanto estiver a utilizar um ficheiro do grupo de trabalho (System.mdw) que é criado com o Microsoft Jet 4.0 Service Pack 4 (SP4) ou anterior e o ficheiro de grupo de trabalho actualmente em utilização é criado no Microsoft Jet 4.0 SP5.
  • Depois de instalar o Microsoft Windows 2000 SP2 ou depois de aplicar Jet 4.0 SP5 para o computador, utilizar o Assistente de segurança de nível de utilizador para proteger a base de dados e seleccionar a opção no Assistente para criar um novo ficheiro de grupo de trabalho.

Resolução

Para resolver este problema, obtenha o Jet 4.0 service pack mais recente. Para obter informações adicionais sobre como transferir o Jet 4.0 service pack mais recente, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
239114  (http://support.microsoft.com/kb/239114/ ) Como obter o service pack mais recente para o motor de base de dados do Microsoft Jet 4.0

Ponto Da Situação

A Microsoft confirmou que este é um problema no Microsoft Jet 4.0 SP5.

Este problema foi corrigido no Jet 4.0 service pack mais recente.

Mais Informação

O ficheiro de grupo de trabalho predefinido (System.mdw) que está instalada com o Microsoft Access é criado com uma versão de pré-SP5 do Microsoft Jet 4.0. Por conseguinte, o problema ocorre se criar uma base de dados utilizando este ficheiro de grupo de trabalho e, em seguida, mais tarde aderir a um ficheiro de grupo de trabalho que é criado no Microsoft Jet 4.0 SP5.

O motor de base de dados Microsoft Jet utiliza um ID de segurança (SID) para identificar exclusivamente o utilizador e contas de grupo. Um SID da conta é determinado por uma combinação encriptada do nome de utilizador com o ID pessoal que é utilizado para criar a conta.

Este problema ocorre quando o SID da conta de utilizador motor no ficheiro de grupo de trabalho actual não coincide com o SID da conta de utilizador de motor que é utilizado para criar a base de dados. O SID gerado para a conta de motor no ficheiros de grupo de trabalho que são criados no Microsoft Jet 4.0 SP5 difere o SID gerado para a conta de motor em versões anteriores do Jet 4.0.

O utilizador Engine é uma conta especial que é utilizada internamente pelo motor de base de dados Jet e não está exposta através da interface de utilizador do Microsoft Access. No entanto, quando o SID da conta motor no ficheiro do grupo de trabalho não corresponde ao SID da conta motor que é utilizado para criar a base de dados, o motor Jet não reconhece-los como a mesma conta. Por conseguinte, não pode guardar as alterações de estrutura efectuadas novos objectos. No entanto, pode guardar a estrutura alterações efectuadas a anteriormente objectos existentes.

Para objectos específicos do Microsoft Access, tais como formulários, relatórios, macros e módulos, o objecto aparece incorrectamente na base de dados da janela, apesar de não é realmente guardado. Quando tenta abrir um destes objectos, o Access devolve uma mensagem de erro que não é possível localizar o objecto.

Passos para reproduzir o comportamento

  1. Utilize o Microsoft Access para criar uma nova base de dados em branco num computador que não foi actualizado para o Microsoft Jet 4.0 SP5.
  2. Crie e, em seguida, guarde vários objectos tais como tabelas, consultas e formulários na base de dados.
  3. Saia do Microsoft Access.
  4. Utilize o utilitário do administrador do grupo de trabalho (Wrkgadm.exe) para criar um novo ficheiro de grupo de trabalho num computador que tenha sido actualizado para Microsoft Jet 4.0 SP5.
  5. Copie a base de dados que criou no passo 1 para o computador que tenha instalado o Microsoft Jet 4.0 SP5.
  6. Inicie o Microsoft Access e abra a base de dados.
  7. Abra um novo formulário na vista de estrutura.
  8. Adicionar vários controlos e, em seguida, feche o formulário.
  9. Quando o Microsoft Access lhe pedir para guardar o formulário, clique em Sim . Introduza um nome para o formulário e, em seguida, clique em OK . Repare que receberá a seguinte mensagem de erro:
    A chave de procura não foi encontrada em qualquer registo.
    Tenha em atenção que não fecha o formulário.
  10. Feche o formulário. Tenha em atenção que o Microsoft Access pede que guarde o formulário novamente. Clique em não para fechar o formulário sem guardar as alterações de estrutura. No entanto, Note que o formulário aparece na janela Base de dados, que indica que foi guardado.
  11. Abra o formulário. Repare que receberá a mensagem de erro:
    O motor de base de dados do Microsoft Jet não consegue localizar o objecto < nome do objecto >. Certifique-se o objecto existe e que ortografia correcta seu nome e nome do caminho.

A informação contida neste artigo aplica-se a:
  • Microsoft Access 2000 Standard Edition
Palavras-chave: 
kbmt kbsavefile kbbug kberrmsg kbfix KB301474 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 301474  (http://support.microsoft.com/kb/301474/en-us/ )