ID do artigo: 301474 - Última revisão: quarta-feira, 28 de julho de 2004 - Revisão: 3.0

Erro: Você recebe um erro "A chave de pesquisa não foi encontrada em qualquer registro" alterações de mensagem quando você compacta um banco de dados ou salvar o design no Access 2000

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Moderado: Requer básica de macro, codificação e interoperabilidade habilidades.

Este artigo se aplica somente a um banco de dados do Microsoft Access (.mdb).

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Quando você tenta salvar alterações de design para um novo objeto, ou quando você compacta um banco de dados, você receberá a seguinte mensagem de erro:
A chave de pesquisa não foi encontrada em qualquer registro.
Além disso, você pode ver o objeto de banco de dados na janela banco de dados, embora o salvamento tentativa falha. No entanto, quando você abre o objeto, você receber a seguinte mensagem de erro:
O Microsoft Jet o mecanismo de banco de dados não é possível localizar o objeto < nome do objeto >. Certifique-se o objeto existe e se você digitou seu nome e caminho corretamente.

Causa

Esse comportamento ocorre em uma das seguintes circunstâncias:
  • O banco de dados foi criado ao usar um arquivo do grupo de trabalho (System.mdw) que é criada com o Microsoft Jet 4.0 Service Pack 4 (SP4) ou anterior e o arquivo de grupo de trabalho em uso no momento é criado com o Microsoft Jet 4.0 SP5.
  • Após a instalação do Microsoft Windows 2000 SP2 ou após aplicar o Jet 4.0 SP5 ao computador, você usar o Assistente de segurança de nível de usuário para proteger o banco de dados e você selecionar a opção no Assistente para criar um novo arquivo de grupo de trabalho.

Resolução

Para resolver esse problema, obtenha o Jet 4.0 service pack mais recente. Para obter informações adicionais sobre como baixar o Jet 4.0 service pack mais recente, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
239114  (http://support.microsoft.com/kb/239114/ ) Como obter o service pack mais recente para o Microsoft Jet 4.0 Database Engine

Situação

A Microsoft confirmou que este é um problema no Microsoft Jet 4.0 SP5.

Esse problema foi corrigido no Jet 4.0 service pack mais recente.

Mais Informações

O arquivo de grupo de trabalho padrão (System.mdw) instalada com o Microsoft Access é criado com uma versão de pré-SP5 do Microsoft Jet 4.0. Portanto, o problema ocorre se você criar um banco de dados usando este arquivo de grupo de trabalho e, em seguida, associe um arquivo de grupo de trabalho que é criado com o Microsoft Jet 4.0 SP5 posteriormente.

O mecanismo de banco de dados Microsoft Jet usa uma identificação de segurança (SID) para identificar exclusivamente contas de usuário e de grupo. Um SID da conta é determinado por uma combinação criptografada do nome de usuário e identificação pessoal é usada para criar a conta.

Esse problema ocorre quando o SID da conta de usuário mecanismo no arquivo do grupo de trabalho atual não é compatível com o SID da conta de usuário mecanismo é usado para criar o banco de dados. O SID é gerado para a conta de mecanismo em arquivos de grupo de trabalho que são criados com o Microsoft Jet 4.0 SP5 difere o SID geradas para a conta do mecanismo nas versões anteriores do Jet 4.0.

O usuário do mecanismo é uma conta especial que é usada internamente pelo mecanismo de banco de dados Jet e não é exposta pela interface do usuário do Microsoft Access. No entanto, quando o SID da conta do mecanismo no arquivo do grupo de trabalho não coincidir com o SID da conta do mecanismo que é usado para criar o banco de dados, o mecanismo do Jet não reconhece-los como a mesma conta. Portanto, não é possível salvar alterações de design feitas para novos objetos. No entanto, você pode salvar alterações de design feitas anteriormente objetos existentes.

Para objetos específicos do Microsoft Access, como formulários, relatórios, macros e módulos, o objeto aparece incorretamente no banco de dados de janela, embora ele realmente não é salvo. Quando você tenta abrir um desses objetos, o Access retorna uma mensagem de erro que ele não é possível localizar o objeto.

Passos para reproduzir o problema

  1. Use o Microsoft Access para criar um novo banco de dados em branco em um computador que não tenha sido atualizado para o Microsoft Jet 4.0 SP5.
  2. Criar e salvar vários objetos como tabelas, consultas e formulários no banco de dados.
  3. Feche o Microsoft Access.
  4. Use o utilitário Administrador do grupo de trabalho (Wrkgadm.exe) para criar um novo arquivo de grupo de trabalho em um computador que tenha sido atualizado para o Microsoft Jet 4.0 SP5.
  5. Copie o banco de dados que você criou na etapa 1 para o computador que tenha o Microsoft Jet 4.0 SP5.
  6. Inicie o Microsoft Access e abra o banco de dados.
  7. Abra um novo formulário no modo de design.
  8. Adicionar vários controles e, em seguida, feche o formulário.
  9. Quando o Microsoft Access solicitar que você salvar o formulário, clique em Sim . Digite um nome para o formulário e, em seguida, clique em OK . Observe que você recebe a seguinte mensagem de erro:
    A chave de pesquisa não foi encontrada em qualquer registro.
    Observe que o formulário não será fechado.
  10. Feche o formulário. Observe que o Microsoft Access solicita que você salvar o formulário novamente. Clique em não para fechar o formulário sem salvar as alterações de design. Observe, no entanto, que o formulário aparece na janela banco de dados, que indica que ele foi salvo.
  11. Abra o formulário. Observe que você recebe a mensagem de erro:
    O mecanismo de banco de dados Microsoft Jet não pode localizar o objeto < nome do objeto >. Certifique-se o objeto existe e se você digitou seu nome e caminho corretamente.

A informação contida neste artigo aplica-se a:
  • Microsoft Access 2000 Standard Edition
Palavras-chave: 
kbmt kbsavefile kbbug kberrmsg kbfix KB301474 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 301474  (http://support.microsoft.com/kb/301474/en-us/ )