Makale numarası: 301474 - Son Gözden Geçirme: 28 Temmuz 2004 Çarşamba - Gözden geçirme: 3.0

Hata: Bir "arama anahtarı herhangi bir kayıt bulunamadı" hatası alıyorsunuz Access 2000'de bir veritabanını düzenlemek veya tasarım kaydetme iletisi değiştirir

Sistem İpucuBu makale, kullandığınızdan farklı bir işletim sistemine yöneliktir. Sizinle ilgili olmayabilecek makale içeriği devre dışı bırakıldı.
Orta: temel makro, kodlama ve birlikte çalışabilirlik becerileri gerektirir.

Bu makale yalnızca Microsoft Access veritabanı (.mdb) için geçerlidir.

Bu Sayfada

Hepsini aç | Hepsini kapa

Belirtiler

Yeni bir nesneye tasarım değişiklikleri kaydetmeye çalıştığınızda veya bir veritabanı sıkıştırdığınızda, aşağıdaki hata iletisini alırsınız:
Arama anahtarı herhangi bir kayıt bulunamadı.
Ayrıca, kaydetme girişimi olsa da Veritabanı penceresinde listelenen bir veritabanı nesnesini görebilirsiniz başarısız oldu. Nesneyi yeniden açtığınızda, aşağıdaki hata iletisini alırsınız:
Microsoft Jet veritabanı alt yapısı < nesne adı > nesne bulunamıyor. Nesnenin varolduğundan ve adı ve yol adı doğru yazdığınızdan emin olun.

Neden

Bu davranış aşağıdaki durumlardan birinde oluşur:
  • Bir çalışma grubu dosyasını kullanırken, veritabanı oluşturuldu (System.mdw) Microsoft Jet 4.0 Service Pack 4 (SP4) veya daha önceki sürümlerde oluşturulmuş ve şu anda kullanımda olan çalışma grubu dosyasını Microsoft Jet 4.0 SP5 ile oluşturulur.
  • Microsoft Windows 2000 SP2'yi yükledikten sonra veya Jet 4.0 SP5'i bilgisayarınıza uyguladıktan sonra veritabanının güvenliğini sağlamak için kullanıcı düzeyi güvenlik Sihirbazı'nı kullanın ve yeni bir çalışma grubu dosyası oluşturmak için sihirbazın seçeneğini seçin.

Çözüm

Bu sorunu gidermek için <a0></a0>, en son Jet 4.0 hizmet paketini edinin. En son Jet 4.0 hizmet paketini karşıdan yükleme hakkında ek bilgi için Microsoft Knowledge Base'deki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
239114  (http://support.microsoft.com/kb/239114/ ) Microsoft Jet 4.0 veritabanı altyapısı için en son hizmet paketi nasıl elde edilir

Durum

Microsoft bu sorunun, Microsoft Jet 4.0 SP5'da bulunduğunu onaylamıştır.

Bu sorun, en son Jet 4.0 hizmet paketi ile giderilmiştir.

Daha fazla bilgi

Microsoft Access ile birlikte yüklenen varsayılan çalışma grubu dosyası (System.mdw), Microsoft Jet 4.0 öncesi SP5 sürümü ile oluşturulur. Bu nedenle, bu çalışma grubu dosyasını kullanarak bir veritabanı oluşturun ve daha sonra Microsoft Jet 4.0 SP5 ile oluşturulan bir çalışma grubu dosyasını alanına, bu sorun oluşur.

Microsoft Jet veritabanı alt yapısı, kullanıcı ve grup hesaplarını benzersiz biçimde tanımlamak için bir güvenlik KIMLIĞI (SID) kullanır. Bir hesabın SıD'SI, şifrelenmiş bir kullanıcı adı ve hesap oluşturma için kullanılan kişisel KIMLIĞI birleşimiyle belirlenir.

Bu sorun, geçerli çalışma grubu dosyasında Engine kullanıcı hesabının SID veritabanını oluşturmak için kullanılan Engine kullanıcı hesabının SID eşleşmediğinde oluşur. SID oluşturulan Microsoft Jet 4.0 SP5 ile oluşturulan bir çalışma grubu dosyaları altyapısı hesapta farklı için Jet 4. 0'ın önceki sürümleri altyapısı hesap için SID oluşturulan.

Jet veritabanı alt yapısı tarafından dahili olarak kullanılır ve Microsoft Access kullanıcı arabirimi aracılığıyla yararlanılır özel bir hesap makinesi kullanıcıdır. <a0>Çalışma grubu</a0> dosyasındaki altyapısı hesabın SID Engine veritabanı oluşturmak için kullanılan hesabın SID ile eşleşmezse, ancak Jet alt yapısı bunları aynı hesabı tanımıyor. Bu nedenle, yeni nesnelere yapılan tasarım değişiklikleri kaydedemiyor. Ancak, tasarım değişiklikleri yapıldığından için önceden varolan nesneleri kaydedebilirsiniz.

Formları, raporları, makroları ve modülleri gibi Microsoft Access'e özgü nesneleri için nesne veritabanında yanlış görünür penceresinde rağmen aslında kaydedilir. Bu nesnelerden birini açmaya çalıştığınızda, Access nesne bulunamıyor hata iletisi döndürür.

Davranışı Yeniden Oluşturma Adımları

  1. Microsoft Access için Microsoft Jet 4.0 SP5 yükselttiğiniz bir bilgisayara yeni, boş bir veritabanı oluşturmak için kullanın.
  2. Oluşturun ve sonra da veritabanında tablolar, sorgular ve formlar gibi çeşitli nesnelerin kaydedin.
  3. Microsoft Access'nden çıkın.
  4. Çalışma Grubu Yöneticisi yardımcı programı'nı (Wrkgadm.exe) için Microsoft Jet 4.0 SP5 yükselttiğiniz bir bilgisayara yeni bir çalışma grubu dosyası oluşturmak için kullanın.
  5. Microsoft Jet 4.0 SP5 yüklü olduğu bilgisayarın için 1. adımda oluşturduğunuz veritabanını kopyalayın.
  6. Microsoft Access'i başlatın ve veritabanını açın.
  7. Yeni bir form, Tasarım görünümünde açın.
  8. Çok sayıda denetim ekleme ve formu kapatın.
  9. Microsoft Access formu kaydetmeniz için istemde bulunduğunda, Evet ' i tıklatın. Form için bir ad girin ve Tamam ' ı tıklatın. Not aşağıdaki hata iletisini alırsınız:
    Arama anahtarı herhangi bir kayıt bulunamadı.
    Not formu kapatın.
  10. Formu kapatın. Not Microsoft Access, form yeniden kaydetmeniz için sizi uyarır. Formu tasarım değişiklikleri kaydetmeden kapatmak için Hayır ' ı tıklatın. Ancak, form, kaydedilmiş gösteren Veritabanı penceresinde, göründüğünü unutmayın.
  11. Formu açın. Not hata iletisini alırsınız:
    Microsoft Jet veritabanı alt yapısı < nesne adı > nesne bulunamıyor. Nesnenin varolduğundan ve adı ve yol adı doğru yazdığınızdan emin olun.

Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Access 2000 Standard Edition
Anahtar Kelimeler: 
kbmt kbsavefile kbbug kberrmsg kbfix KB301474 KbMttr
Otomatik TercümeOtomatik Tercüme
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:301474  (http://support.microsoft.com/kb/301474/en-us/ )