Identificativo articolo: 301671 - Ultima modifica: martedì 4 dicembre 2007 - Revisione: 5.1

Messaggio di errore "Errore 2737. Si è verificato un errore interno" quando si installa Office XP in un computer che esegue Windows 98

Suggerimento di sistemaIl presente articolo fa riferimento a un sistema operativo diverso da quello in uso. Il contenuto dell'articolo che potrebbe non essere relativo al sistema in uso è disabilitato.
Questo articolo è stato precedentemente pubblicato con il codice di riferimento I301671
Espandi tutto | Chiudi tutto

Sintomi

Durante l'installazione di Microsoft Office XP in Microsoft Windows 98 è possibile che venga visualizzato il seguente messaggio di errore:
Errore 2737. Si è verificato un errore interno.

Cause

Questo errore può verificarsi quando il programma di installazione di Office rileva una versione non corretta del file Advapi32.dll.

Risoluzione

Per risolvere il problema, utilizzare il programma Controllo file di sistema di Windows 98 per estrarre manualmente il file Advapi32.dll dalla cartella \Win98 del CD di Windows 98. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Fare clic sul pulsante Start, scegliere Esegui, quindi digitare Sfc.exe nella casella Apri. Scegliere OK.
  2. Selezionare Estrai file da disco di installazione.
  3. Digitare advapi32.dll, quindi fare clic su Avvia.
  4. In Ripristina da individuare la cartella Win98 sul CD di Windows 98, quindi scegliere OK.
  5. Verificare che il file venga salvato in C:\Windows\System, quindi scegliere OK.
  6. Quando viene richiesto, riavviare il computer.
  7. Eseguire il programma di installazione di Office XP.

Informazioni

Durante l'installazione di Microsoft Office XP, è possibile che venga visualizzato il messaggio di errore riportato nella sezione "Sintomi" di questo articolo. Quando si esamina il file di registro dell'installazione, è possibile visualizzare il testo del seguente errore in un file di registro dettagliato:
Errore 2737. Si è verificato un errore interno. (CheckCAServer
   C:\WINDOWS\TEMP\MSI2A3.TMP   CheckCAServer                )

MSI (c) (CF:BB): Prodotto: Microsoft Office XP Professional con FrontPage
 -- Errore 2737. Si è verificato un errore interno. (CheckCAServer
  C:\WINDOWS\TEMP\MSI2A3.TMP   CheckCAServer                )

Azione terminata alle 10:33:02: CheckCAServer. Valore restituito 3.
Nota Nel file di registro dettagliato è possibile trovare anche l'errore 1723. La risoluzione per l'errore 1723 è uguale a quella per l'errore 2737.
Errore 1723. Si è verificato un problema con il pacchetto di Windows Installer. 
Non è stato possibile eseguire una DLL necessaria per il completamento dell'installazione. Contattare il supporto tecnico o il fornitore del pacchetto.  
Azione CheckCAServer, voce: CheckCAServer, libreria: C:\WINDOWS\TEMP\MSI53A1.TMP 

MSI (c) (7D:A5): Prodotto: Microsoft Office XP Standard -- Errore 1723. Si è verificato un problema con il pacchetto di Windows Installer. 
Non è stato possibile eseguire una DLL necessaria per il completamento dell'installazione. Contattare il supporto tecnico o il fornitore del pacchetto.  
Azione CheckCAServer, voce: CheckCAServer, libreria: C:\WINDOWS\TEMP\MSI53A1.TMP
Per ulteriori informazioni sulla lettura dei file di registro, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
290556  (http://support.microsoft.com/kb/290556/ ) OFFXP: Office si arresta nel corso dell'installazione: risoluzione dei problemi in Windows 98

Riferimenti

Per altri articoli sulla risoluzione dei problemi relativi all'installazione di Office XP, visitare il seguente sito Web Microsoft:
Fare clic qui per visualizzare un elenco di articoli relativi alla risoluzione di problemi di installazione di Office XP a seconda del sistema operativo in uso (http://support.microsoft.com/search/default.aspx?catalog=lcid%3d1033&spid=914&query=officexpsetupdwts&adv=&mode=s&cat=false)

Le informazioni in questo articolo si applicano a
  • Microsoft Visio 2002 Professional Edition
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Office XP Professional Edition
  • Microsoft Office XP Small Business Edition
  • Microsoft Office XP Standard Edition
  • Microsoft Office XP Standard Edition for Students and Teachers
  • Microsoft Office XP Developer Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Chiavi: 
kberrmsg kbsetup kbprb KB301671
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.