How To Diagram Your Network with Microsoft Visio Enterprise 2000

Article translations Article translations
Article ID: 301675
Expand all | Collapse all

On This Page

Summary

This step-by-step guide describes how to use the AutoDiscovery and Layout solution to create a network diagram with several hyperlinked pages that show detailed information about selected network devices.

This article also provides information about how to update your diagram after you make network changes, how to report on your network, and how to save your diagram in Hypertext Markup Language (HTML) format to post on your company's intranet.

Requirements

The following items describe the recommended hardware, software, network infrastructure, skills and knowledge, and service packs that you need:
  • Microsoft Visio Enterprise 2000
  • Operating system

Diagramming Your Network

Use the Discovery Wizard to search your network and create a database of the layer 2 and layer 3 devices found on the network. This wizard also gathers information about each device, such as the device's:
  • Network name
  • Internet Protocol (IP) address
  • Operating system
  • Manufacturer
  • The Simple Network Management Protocol (SNMP) community string used by the device
  • Interface information

Discovering the Devices on Your Network

To open the AutoDiscovery and Layout template:
  1. Click Start, point to Programs, and then click Microsoft Visio 2000. In the Welcome to Microsoft Visio dialog box, click OK.
  2. In the Choose Drawing Type dialog box, click Network Diagram.
  3. In the Drawing Type dialog box, double-click AutoDiscovery and Layout.

    The AutoDiscovery and Layout template and stencils open, and the AutoDiscovery and Layout menu and toolbar appear. The menu and toolbar are available only when you open this template or a diagram that was created from this template.
To discover your network devices:
  1. To begin working in the Discovery Wizard, point to AutoDiscovery, point to Discovery, and then click Discovery. Or, on the AutoDiscovery and Layout toolbar, click Discovery.
  2. Answer the questions on the wizard screens.

Laying out Your Network Diagram

To create a network diagram by using the AutoDiscovery and Layout toolbar:
  1. On the File menu, click Page Setup. Then, on the Page Size tab, specify the size of your page for your network diagram.
  2. On the AutoDiscovery and Layout toolbar, click Add Networks.
  3. In the Add Networks dialog box, select a network, and then click OK.
  4. To connect network devices such as routers to the network, right-click the network in the diagram, and then click Connect Devices on the shortcut menu.
  5. In the Connect Devices dialog box, select the devices that are connected to the network that you want to place on the diagram. Select the Attach Interface IP Address To Links check box to display the IP address of links between two devices on the diagram.
To create a hyperlinked diagram by using the AutoLayout feature:
  1. Point to AutoDiscovery, and then click AutoLayout.

    NOTE: Click Calculate at any time to see how many hyperlinked pages the diagram includes. To reduce the number of pages, reduce the number of hops used.
  2. On the Device Types tab, specify what types of devices are used as hyperlinks, and whether to list network objects by name or by device counter.
  3. On the Network Types tab, specify what kind of networks to include on the diagram.
  4. Click OK. The Laying Out Document progress dialog box opens to show you the progress of the layout.

    To navigate between hyperlinked pages:
    • In whole page view, right-click the hyperlinked object, and then on the shortcut menu, choose the name of the page that the object is linked to.
    • In full-screen view, click the hyperlinked object to display the page that the object is linked to.

Updating Your Network Diagram

To update your network diagram:
  1. On the AutoDiscovery and Layout toolbar, click Guided Update.
  2. Expand the type of change that you want to see: network changes, device changes, new objects, or connectivity changes.
  3. Right-click a specific device or change, and then click Details on the shortcut menu.
  4. To apply a change, select the button for the action that you want to perform and press ENTER.

    The appropriate dialog box appears and you can update the diagram with the change. If there are multiple changes, you can select as many changes as you want to implement.

    To save a list of network changes:
    • Point to AutoDiscovery, point to Guided Update, and then click Save.
    To open a list of network changes:

    • Point to AutoDiscovery, point to Guided Update, and then click Open. In the Open dialog box, navigate to the file.

Generating a Network Report

To generate a report on a device in your network diagram:
  1. Right-click the device that you want to report on, and then click Generate Reports on the shortcut menu.
  2. In the Report Template field, select a report template from the list.
  3. Select Output Options for your report. Click OK.

Sharing Your Network Diagram and Reports with Others

To save a diagram in HTML format:
  1. On the File menu, click Save As.
  2. Type a name for the HTML file that uses the .htm extension, such as ParisIE.htm.
  3. In the Save as type list, click HTML Files (*.htm, *.html).
  4. Select a location in which to save the file, and then click Save.
  5. In the Save As HTML dialog box, choose the graphics format and the drawing pages that you want the HTML file to include. Take into consideration the browser that you plan to use to show the drawing.
  6. To control the on-screen image size of the saved drawing or to choose options specific to the graphics format, click Filter Settings, and then click OK twice. When you are prompted to view the HTML pages, click Yes to open your Web browser and view the first HTML page.

Troubleshooting

AutoDiscovery Takes Too Long

Consider the number of devices that the Discovery Wizard must look for. When choosing options in the Discovery Wizard, remember that the more options you select (such as types of devices to be discovered and the number of networks), the longer it takes to complete the discovery.

Evaluate your time-out and retry settings. You can specify how long the Discovery engine should wait before timing out if a device does not respond to a Ping or an SNMP request, and how many times it should repeat the request. For example, if you have many devices that do not respond to SNMP requests, consider decreasing the SNMP time-out field.

Consider your link speeds. For example, if you have a remote office connected by a wide area network (WAN) link, the packet exchange is slower. You might want to exclude the devices on remote subnets from the network that you are discovering. Alternatively, you might want to increase the number of SNMP retries and time-outs.

Properties

Article ID: 301675 - Last Review: June 19, 2014 - Revision: 2.0
Keywords: 
kbhowto kbhowtomaster KB301675
Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com