Impressoras que utilizam portas que não comecem por COM, LPT ou USB não são redireccionadas numa sessão do ambiente de trabalho remoto ou de serviços de terminal

Traduções de Artigos Traduções de Artigos
Artigo: 302361 - Ver produtos para os quais este artigo se aplica.
Este artigo foi publicado anteriormente em PT302361
Expandir tudo | Reduzir tudo

Sintomas

Quando utiliza a Ligação ao ambiente de trabalho remoto (Remote Desktop Connection) ou o cliente de serviços de terminal versão 4.0 ou 5.0 para ligar a um outro computador baseado no Windows a partir de um computador que não está a utilizar o Windows Server 2003, as impressoras locais poderão não ser redireccionadas. Como resultado, as impressoras locais não estarão disponíveis na sessão de ambiente de trabalho remoto ou de serviços de terminal.

Por exemplo, se o computador baseado no Windows XP tiver um dispositivo de impressão multifunção que utiliza a porta DOT4, poderá não ser redireccionado numa sessão de ambiente de trabalho remoto para um computador baseado no Windows 2000 ou no Windows Server 2003.

Causa

Este problema ocorre porque a porta de impressora não começa por COM, LPT ou USB. Por predefinição, os nomes de portas de impressoras que não comecem por COM, LPT ou USB só são redireccionados no Windows Server 2003. Por predefinição, os dispositivos de impressão multifunção poderão não ser redireccionados a menos que esteja a utilizar o Windows Server 2003 no computador local, uma vez que são utilizadas as portas DOT4.

Resolução

Para resolver este problema num computador que não está a utilizar o Windows Server 2003, force todas as portas (incluindo a DOT4) existentes no computador cliente para que sejam filtradas para redireccionamento. Para o fazer, adicione um valor DWORD denominado FilterQueueType a HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR e defina os dados do valor como FFFFFFFF.

Siga estes passos e, em seguida, saia do Editor de registo (Registry Editor):
  1. Clique em Iniciar (Start), clique em Executar (Run), escreva regedit e clique em OK.
  2. Localize e clique na seguinte chave no registo:
    HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR
  3. No menu Editar (Edit), aponte para Novo (New) e clique em Valor DWORD (DWORD Value).
  4. Escreva FilterQueueType e prima ENTER.
  5. No menu Editar (Edit), clique em Modificar (Modify).
  6. Escreva FFFFFFFF e clique em OK.
Isto permite que todas as portas do cliente sejam redireccionadas.

Para contornar este problema num computador cliente com um dispositivo de impressão multifunção, altere a porta utilizada pelo dispositivo de impressão multifunção de DOT4 para LPT.

Por exemplo, para configurar um dispositivo de impressão multifunção de modo a utilizar uma porta LPT num computador baseado no Windows XP, siga estes passos:
  1. No Painel de controlo (Control Panel), abra Impressoras e faxes (Printers and Faxes).
  2. Clique com o botão direito do rato na impressora local que não está redireccionada e clique em Propriedades (Properties).
  3. Clique no separador Portas (Ports), clique numa porta LPT e clique em Aplicar (Apply).

    A impressora deverá aparecer junto a essa porta.
  4. Feche a janela de propriedades da impressora e, em seguida, volte a estabelecer ligação através do ambiente de trabalho remoto.
Importante: quando uma impressora multifunções está a utilizar uma porta LPT padrão em vez da porta DOT4, perde as respectivas capacidades de multifunção, tais como digitalização, envio de faxes ou cópia. Para readquirir as capacidades de multifunção, o dispositivo de impressão terá de utilizar a porta DOT4.

Ponto Da Situação

Este comportamento ocorre por predefinição.

Mais Informação

Para visualizar o nome da porta da impressora, ou para determinar se o dispositivo utiliza uma porta DOT4, visualize as propriedades dessa impressora e clique no separador Portas (Ports) (ou em Detalhes) (Details).

Propriedades

Artigo: 302361 - Última revisão: 3 de dezembro de 2007 - Revisão: 4.7
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Segunda Edição
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Terminal Server
  • Microsoft Windows NT Server 4.0 Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Palavras-chave: 
kbnofix kbprint kbenv kbprb KB302361

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com