Tlačiarne, ktoré používajú porty nezačínajúce označením COM, LPT alebo USB sa nepresmerujú počas relácie vzdialenej pracovnej plochy alebo relácie terminálových služieb

Preklady článku Preklady článku
ID článku: 302361 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

PRIZNAKY

Keď používate pripojenie vzdialenej pracovnej plochy Remote Desktop Connection alebo klienta Terminal Services Client 4.0 alebo 5.0 na pripojenie k inému počítaču so systému Windows z počítača, na ktorom sa nepoužíva systém Windows Server 2003, lokálne tlačiarne sa nemusia presmerovať. V dôsledku tohto správania nie sú lokálne tlačiarne v relácii vzdialenej pracovnej plochy alebo terminálových služieb dostupné.

Ak napríklad na počítači so systémom Windows XP používate multifunkčné zariadenie na tlač pripojené k portu DOT4, takéto zariadenie sa nemusí presmerovať počas relácie pripojenia vzdialenej pracovnej plochy počítača so systémom Windows 2000 alebo Windows Server 2003.

PRICINA

Tento problém sa vyskytuje, pretože port tlačiarne nezačína označením COM, LPT alebo USB. Na základe predvoleného nastavenia sa názvy portov tlačiarne, ktoré nezačínajú označením COM, LPT alebo USB, presmerovávajú len v systéme Windows Server 2003. Na základe predvoleného nastavenia nie je možné presmerovať multifunkčné tlačové zariadenia, pokiaľ na lokálnom počítači používate iný než systém Windows Server 2003, pretože takéto zariadenia používajú porty DOT4.

RIESENIE

Ak chcete vyriešiť tento problém na počítači, na ktorom sa nepoužíva systém Windows Server 2003, vynúťte filtrovanie všetkých portov (vrátane portu DOT4) na klientskom počítači za účelom ich presmerovania. Ak to chcete vykonať, pridajte hodnotu DWORD s názvom FilterQueueType do kľúča HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR a nastavte jej údaj hodnoty na FFFFFFFF.

Vykonajte tieto kroky a potom zatvorte Editor databázy Registry:
  1. Kliknite na tlačidlo Štart, kliknite na príkaz Spustiť, zadajte príkaz regedit a potom kliknite na tlačidlo OK.
  2. Nájdite v databáze Registry nasledujúci kľúč a kliknite naň:
    HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR
  3. V ponuke Úpravy ukážte na položku Nový a potom kliknite na položku Hodnota DWORD.
  4. Zadajte reťazec FilterQueueType a stlačte kláves ENTER.
  5. V ponuke Úpravy kliknite na položku Zmeniť.
  6. Zadajte reťazec FFFFFFFF a potom kliknite na tlačidlo OK.
Týmto povolíte presmerovanie všetkých portov na klientovi.

Ak chcete obísť tento problém na klientskom počítači, ktorý používa multifunkčné zariadenie na tlač, zmeňte port používaný týmto zariadením z portu DOT4 na port LPT.

Ak chcete nakonfigurovať napríklad multifunkčné zariadenie na tlač na používanie portu LPT na počítači so systémom Windows XP, postupujte nasledovne:
  1. V okne Ovládací panel otvorte položku Tlačiarne a faxy.
  2. Kliknite pravým tlačidlom na lokálnu nepresmerovanú tlačiareň a kliknite na položku Vlastnosti.
  3. Kliknite na kartu Porty, kliknite na port LPT a potom na tlačidlo Použiť.

    Tlačiareň by sa teraz mala zobraziť vedľa tohto portu.
  4. Zatvorte okno Vlastnosti tlačiarne a potom sa znovu pripojte pomocou funkcie Vzdialená pracovná plocha.
Dôležité. Keď multifunkčná tlačiareň používa štandardný port LPT namiesto portu DOT4, nebude môcť používať svoje funkcie, ktoré neslúžia na tlač, napr. skenovanie, faxovanie alebo kopírovanie. Ak chcete tieto funkcie použiť, zariadenie na tlač musí použiť port DOT4.

STAV

Toto správanie je predvolené.

DALSIE INFORMACIE

Ak chcete zobraziť názov portu, ktorý používa vaša tlačiareň, alebo či zariadenie používa port DOT4, zobrazte vlastnosti tlačiarne a kliknite na kartu Porty(alebo Podrobnosti).

Vlastnosti

ID článku: 302361 - Posledná kontrola: 3. decembra 2007 - Revízia: 4.8
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Terminal Server
  • Microsoft Windows NT Server 4.0 Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Kľúčové slová: 
kbnofix kbprint kbenv kbprb KB302361

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com