文書番号: 302396 - 最終更新日: 2004年3月3日 - リビジョン: 2.0

Shockwave または Flash が有効なサイトを参照しようとすると Internet Explorer が終了する

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

目次

すべて展開する | すべて折りたたむ

現象

Macromedia Shockwave または Macromedia Flash が有効になっている Web サイトを参照しようとした場合、次のメッセージに類似したエラー メッセージが表示されることがあります。
このプログラムは不正な処理を行ったので強制終了されます。

終了しない場合は、プログラムの製造元に連絡してください。
[詳細] をクリックすると、次の情報が表示されます。
IEXPLORE のページ違反です。
モジュール : DIRAPI.DLL アドレス :
この後、 Internet Explorer が終了することがあります。

: この現象は、Macromedia Shockwave または Macromedia Flash をインストールしようとした場合にも発生する可能性あります。

原因

この問題は、Dirapi.dll ファイルが存在しないか、破損している場合に発生する可能性があります。このファイルは、Shockwave Player と Flash Player が正常に機能するために必要です。

解決方法

この問題を解決するには、Macromedia Shockwave と Macromedia Flash を削除して、再インストールします。そのためには、次の手順を実行します。

Macromedia Shockwave と Macromedia Flash を削除する

  1. 実行中のプログラムをすべて終了します。
  2. タスク バーの [スタート] ボタンをクリックし、[設定] をポイントして [コントロール パネル] をクリックします。
  3. コントロール パネルの [インターネット オプション] をダブルクリックします。
  4. [インターネットのプロパティ] ダイアログ ボックスの [全般] タブをクリックし、[インターネット一時ファイル] の下の [設定] をクリックします。
  5. [設定] ダイアログ ボックスで [オブジェクトの表示] をクリックします。
  6. Downloaded Program Files ダイアログ ボックスの [プログラム ファイル] 一覧に Shockwave に関連した項目が表示された場合は、その項目を右クリックし、表示されるショートカット メニューで [削除] をクリックします。

    次のメッセージが表示されます。
    Shockwave ActiveX control は完全に削除されます。
    削除しますか?
  7. [はい] をクリックします。
  8. この一覧に表示されている Shockwave に関連する項目ごとに、手順 6 と 7 を繰り返します。
  9. [ファイル] メニューの [閉じる] をクリックします。
  10. [設定] ダイアログ ボックスで [OK] をクリックします。
  11. [インターネットのプロパティ] ダイアログ ボックスで [OK] をクリックし、次にコントロール パネルを閉じます。

Macromedia Shockwave と Macromedia Flash を再インストールする

  1. エクスプローラを起動します。
  2. 次のフォルダへ移動します。
    ドライブ:\Windows\System\Macromed
    ここで、ドライブ は、Windows がインストールされているドライブです。Windows は Windows がインストールされているフォルダです。System は Windows 9 xSystem フォルダです。
  3. Macromed フォルダを右クリックし、表示されるショートカット メニューの [削除] をクリックします。
  4. [フォルダの削除の確認] メッセージが表示されたら、[はい] をクリックします。
  5. Windows エクスプローラを終了して、コンピュータを再起動します。
  6. Macromedia Shockwave と Macromedia Flash を再インストールします。Macromedia Shockwave Player と Macromedia Flash Player は、次の URL から入手可能です。
    http://www.macromedia.com/jp/ (http://www.macromedia.com/jp/)
他社テクニカル サポートのお問い合わせ窓口は、ユーザーの便宜のために提供されているものであり、将来予告なしに変更されることがあります。マイクロソフトは、掲載している情報に対して、いかなる責任も負わないものとします。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 302396? (http://support.microsoft.com/kb/302396/EN-US/ ) (最終更新日 2003-11-17) を基に作成したものです。

この資料は以下の製品について記述したものです。
  • Microsoft Internet Explorer 5.5
キーワード:?
kb3rdparty kberrmsg kbinvalidpagefault kbprb KB302396
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"
Retired KB Articleサポート期間が終了した「サポート技術情報」資料に関する免責事項
この資料は、マイクロソフトでサポートされていない製品について記述したものです。そのため、この資料は現状ベースで提供されており、今後更新されることはありません。
 

サポート技術情報の翻訳

 

Related Support Centers