文書番号: 302829 - 最終更新日: 2005年11月4日 - リビジョン: 4.1

クラスタ サービスが LANMANSERVER のファイル共有エントリを削除しない

この記事は、以前は次の ID で公開されていました: JP302829
すべて展開する | すべて折りたたむ

現象

ファイル共有の数が多い環境では、シャットダウン中に、クラスタ サービスが LANMANSERVER キーのすべてのファイル共有エントリを削除しない場合があります。これが原因となって、LANMANSERVER キーの保存場所となるシステム ハイブのサイズによっては、コンピュータの次回起動時に問題が発生することがあります。キーに残されたそれぞれの値に関して、イベント ログに以下のログが生成されます。

イベントの種類 : 警告
ソース : Server
分類 : なし
イベント ID : 2511

説明 :
サーバー サービスは共有リソース user12604 を再作成できませんでした。ディレクトリ r:\users\user12604 が存在しません。

Windows 2000 を実行しているノードの場合、コンピュータが起動に失敗し、再起動を試みると以下のエラー メッセージが表示されることがあります。
次のファイルが存在しないかまたは壊れているため、Windows 2000 を起動できませんでした:

\WINNT\SYSTEM32\CONFIG\SYSTEM
Windows 2000 の問題解決と拡張起動オプションについては、F8 キーを押してください

オリジナル セットアップ フロッピー ディスクまたは CD-ROM から Windows 2000 セットアップを起動して、このファイルを修復できます。修復するには、最初の画面で 'R' キーを押してください。

原因

この現象は、LANMANSERVER キーのすべての値を削除するための時間がクラスタ サービスに十分与えられていないために発生します。

各種サービスのシャットダウン処理に要する時間は、通常、20,000 ミリ秒 (20 秒) です。より長いシャットダウン時間を必要とする場合は、サービス コントロール マネージャ (SCM) のレジストリ設定を変更することで、サービスのシャットダウンの所要時間を延長できます。ただし、クラスタ サービスは、このレジストリ値に準拠しません。 関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
146092? (http://support.microsoft.com/kb/146092/ ) サービスのシャットダウン時間を増やして正常に終了する方法
通常、クラスタ サービスがシャットダウンに 20 秒以上を要することはありません。20 秒以上を要する原因は、クラスタ上で実行中のプログラム (Microsoft Exchange や Microsoft SQL Server など) にあります。これらのプログラムは SCM を操作し、シャットダウン時間を延長できます。一方、クラスタ サービスは 20 秒以内にシャットダウンするため、LANMANSERVER キーからすべての値を削除するのに十分な時間を確保できないことがあります。

解決方法

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。
Windows 2000 では、システム ハイブが 10 〜 12 MB を超える場合に、ノードを起動できないことがあります。システム ハイブが許容できないサイズになるほどの大量のファイル共有がクラスタ上に存在する場合、正常に起動するようにノードを回復させるには、以下の手順を実行します。ノードの起動に成功したときは、ファイル共有の一部を別のサーバーに移動し、システム ハイブのサイズを減らして、この現象が再発しないようにしてください。

システム ハイブおよび Windows 2000 の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
269075? (http://support.microsoft.com/kb/269075/ ) エラー メッセージ : 次のファイルが存在しないかまたは壊れているため、Windows を起動できませんでした: \Winnt\System32\Config\Systemced
資料 269075 の方法で問題が解決しない場合は、以下の方法を使用してください。
  1. コンピュータに Windows 2000 のパラレル インストールを作成します。

    : この資料では、元のインストールは C:\Winnt に配置され、新しいパラレル インストールが Winnt.new であることを前提としています。 パラレル インストールの実行方法についての関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    266465? (http://support.microsoft.com/kb/266465/ ) [HOW TO] Windows 2000 の並行インストールを実行する方法
  2. パラレル インストールの完了後、パラレル インストール上で "Administrator" としてコンピュータに対してローカルにログオンします。
  3. C:\Winnt\System32\Config フォルダを探し、システム ハイブの元のインストールのコピーをバックアップします。次に "System" (拡張子なし) という名前のファイルをバックアップ (または別の保存場所にコピー) します。

    : バックアップするのは System ファイルです。System.log ではありません。
  4. レジストリ エディタ (Regedt32) を起動します。
  5. [ローカル コンピュータ上の HKEY_LOCAL_MACHINE] ウィンドウをクリックし、最前面に配置します。
  6. ルート フォルダ HKEY_LOCAL_MACHINE をクリックします。
  7. [レジストリ] メニューの [ハイブのロード] をクリックします。
  8. C:\Winnt\System32\Config フォルダを参照し、システム ハイブを探します。
  9. [System] ファイルをクリックし、[開く] をクリックします。

    : 必ず System ファイル (拡張子なし) を開いてください。System.log ファイルではありません。
  10. [キー名] ボックスに OriginalInstall と入力し、[OK] をクリックします。

    : ここで使用するキー名は、表示されているサブハイブに対して一意である限り、重要ではありません。
  11. 読み込まれた "OriginalInstall" という名前のサブハイブが一覧表示されます。[OriginalInstall] をダブルクリックし、下位ノードを展開します。
  12. [Select] キーをクリックします。
  13. Current、Default、Failed、および LastKnownGood の値をメモします。
  14. これらの値の数字は、上に表示される CONTROLSETS を表します。正常な状態では、CONTROLSET001 と CONTROLSET002 が表示されます。通常、Select キーでは Current および Default の値が CONTROLSET001 になっています。また、LastKnownGood の値は CONTROLSET002 になるのが一般的です。Failed の値は、多くの場合、0 になります。 Select キーおよび CONTROLSETS の使用の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    102984? (http://support.microsoft.com/kb/102984/ ) [REG] ControlSet\Select サブキーのエントリ
  15. 手順 13. でメモした Failed の値に対応する CONTROLSET をクリックします。
  16. [セキュリティ] メニューの [アクセス許可] をクリックします。
  17. [継承可能なアクセス許可を親からこのオブジェクトに継承できるようにする] チェック ボックスをオフにします。
  18. [削除] をクリックします。
  19. 一覧表示されているユーザーとグループを削除します。
  20. ローカルの Administrator アカウントを追加し、このアカウントにフル コントロールのアクセス許可が与えられていることを確認します。
  21. [詳細] をクリックします。
  22. [すべての子オブジェクトのアクセス許可を元に戻し、継承可能なアクセス許可を継承できるようにする] チェック ボックスをオンにし、[OK] をクリックします。
  23. [セキュリティ] ダイアログ ボックスで [はい] をクリックします。
  24. [アクセス許可] ダイアログ ボックスで [OK] をクリックします。
  25. Failed の値に対応する CONTROLSET を削除します。

    : これは、ハイブを削除するためにハイブのセキュリティを取り除く手順です。必ず、システム ハイブのバックアップを実行してください。
  26. 手順 6. 〜 12. を繰り返し、LastKnownGood の値に対応する CONTROLSET を削除します。
  27. Current の値に対応する CONTROLSET をダブルクリックします。
  28. HKEY_LOCAL_MACHINE で、[OriginalInstall] をクリックします。
  29. [レジストリ] メニューの [キーの保存] をクリックし、System という名前 (拡張子なし) でデスクトップにファイルを保存します。

    : ファイルを保存するとハイブ内の空白が削除され、ファイル サイズが縮小されます。
  30. OriginalInstall がまだ選択されている状態であることを確認します。
  31. [レジストリ] メニューの [ハイブのアンロード] をクリックし、[はい] をクリックして確認します。
  32. Regedt32 を終了します。
  33. [マイ コンピュータ] で C:\Winnt\System32\Config フォルダを開き、既存の System ファイルの名前を System.org に変更します。
  34. デスクトップの System ファイルを C:\Winnt\System32\Config にコピーします。
  35. コンピュータを再起動し、元のインストールを選択します。

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。

この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
キーワード:?
kbbug kbenv kberrmsg kbpending KB302829
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"
 

サポート技術情報の翻訳

 

Related Support Centers