Numéro d'article: 303360 - Dernière mise à jour: jeudi 17 février 2005 - Version: 2.0

Message d'erreur lors de l'impression à partir d'Internet Explorer : Erreur d'impression : L'imprimante est introuvable

Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).

Sommaire

Agrandir tout | Réduire tout

Symptômes

Lorsque vous essayez d'imprimer à partir de Microsoft Internet Explorer, un message d'erreur semblable au suivant peut s'afficher :
Erreur d'impression : L'imprimante est introuvable.
- ou -
Erreur de script Internet Explorer
Ligne : 1015
Car : 1
Erreur non spécifiée :
Code 0 URL : res://c:\windows\system\shdoclc.dll/preview.dlg
Il se peut que vous puissiez imprimer une page de test ou imprimer à partir d'autres programmes, tels que Microsoft Word, mais vous ne pouvez pas imprimer à partir d'Internet Explorer.

Cause

Ce problème peut se produire lorsque l'une des conditions suivantes est remplie :
  • Le pilote d'imprimante est endommagé.

    - ou -
  • Le fichier Iepeers.dll est endommagé ou sa version est incorrecte.

    - ou -
  • Les paramètres du spouleur de l'imprimante sont incorrects.

Résolution

Pour résoudre ce problème, appliquez l'une des méthodes suivantes, en fonction de votre situation :

Méthode 1

Supprimer et réinstaller le pilote d'imprimante.

Si vous utilisez un pilote tiers fourni par le fabricant de votre imprimante au lieu d'un pilote fourni avec Microsoft Windows Millennium Edition (Me), suivez les instructions fournies par le fabricant de votre imprimante pour supprimer puis réinstaller le pilote d'imprimante.
  1. Cliquez sur Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, puis double-cliquez sur Ajout/Suppression de programmes.
  2. Sous l'onglet Installation/Désinstallation, cliquez sur votre imprimante (si elle est répertoriée dans la liste), puis sur Ajouter/Supprimer.
  3. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Imprimantes.
  4. Cliquez avec le bouton droit sur l'imprimante, puis cliquez sur Supprimer.
  5. Double-cliquez sur Ajouter une imprimante pour démarrer l'Assistant Ajout d'imprimante, puis cliquez sur Suivant.
  6. Suivez les instructions fournies par l'Assistant Ajout d'imprimante pour installer le pilote d'imprimante.
  7. Répétez les étapes 1 à 7 pour supprimer et réinstaller toutes les imprimantes de votre dossier Imprimantes.
REMARQUE : Vous souhaiterez peut-être installer le pilote d'imprimante le plus récent pour votre imprimante. Pour obtenir les pilotes d'imprimante les plus récents, contactez le fabricant de votre imprimante.

Pour plus d'informations sur la façon de contacter le fabricant de votre imprimante, cliquez sur le numéro approprié dans la liste ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
65416  (http://support.microsoft.com/kb/65416/ ) Liste des fournisseurs tiers de matériels et de logiciels, A-K

60781  (http://support.microsoft.com/kb/60781/ ) Liste des fournisseurs tiers de matériels et de logiciels, L-P

60782  (http://support.microsoft.com/kb/60782/ ) Liste des fournisseurs tiers de matériels et de logiciels, Q-Z
Microsoft fournit les coordonnées de sociétés tierces afin de vous aider à trouver un support technique. Ces informations peuvent être modifiées sans préavis. Microsoft ne garantit en aucun cas l'exactitude des informations concernant les sociétés tierces.

Méthode 2

Extraire le fichier Iepeers.dll d'origine du CD-ROM Windows Millennium Edition et remplacer le fichier Iepeers.dll présent sur votre disque dur.

REMARQUE : N'appliquez pas cette méthode si vous avez installé le Service Pack 1 Internet Explorer 5.5 et les Outils Internet. La version du fichier Iepeers.dll fournie avec le Service Pack 1 Internet Explorer 5.5 est ultérieure à celle fournie sur le CD-ROM Windows Millennium Edition. Pour déterminer la version d'Internet Explorer installée sur votre ordinateur, démarrez Internet Explorer, puis cliquez sur À propos de Internet Explorer dans le menu ? (Aide). Si "SP1" apparaît sur la ligne Nombre de mises à jour, cela signifie que le Service Pack 1 Internet Explorer 5.5 et les Outils Internet sont installés et que vous possédez la dernière version du fichier Iepeers.dll pour Internet Explorer 5.5.
  1. Cliquez sur Démarrer, pointez sur Rechercher, puis cliquez sur Des fichiers ou des dossiers.
  2. Dans la zone Rechercher les fichiers ou les dossiers nommés, tapez iepeers.dll.
  3. Dans la zone Rechercher dans, cliquez sur Disques durs locaux, puis sur Rechercher.
  4. Dans la liste Résultats de la recherche, cliquez avec le bouton droit sur Iepeers.dll, puis cliquez sur Renommer.
  5. Tapez iepeers.old, puis appuyez sur ENTRÉE.
  6. Insérez votre CD-ROM Windows Millennium Edition dans le lecteur de CD-ROM ou de DVD-ROM de l'ordinateur. Lorsque vous insérez le CD-ROM, appuyez sur la touche MAJ et maintenez-la enfoncée pour éviter le démarrage automatique du CD-ROM..
  7. Cliquez sur Démarrer, puis sur Exécuter.
  8. Dans la zone Ouvrir, tapez msconfig, puis cliquez sur OK.
  9. Dans la boîte de dialogue Utilitaire de configuration système, cliquez sur Extraire le fichier.
  10. Dans la zone Spécifiez le fichier système à restaurer, tapez iepeers.dll, puis cliquez sur Démarrer.
  11. Dans la zone Restaurer à partir de, cliquez sur Parcourir, puis accédez au dossier x:\win9x (où x correspond à votre lecteur de CD-ROM), puis cliquez sur OK.
  12. Dans la zone Enregistrer le fichier dans, cliquez sur Parcourir, accédez au dossier x\Windows\System (où x correspond au lecteur sur lequel Windows Millennium Edition est installé), puis cliquez sur OK.
  13. Cliquez sur OK pour extraire le fichier.
  14. Cliquez sur OK en réponse au message Le fichier a été extrait, puis cliquez sur OK pour fermer la boîte de dialogue Utilitaire de configuration système.
  15. Consignez le fichier Iepeers.dll dans le Registre :
    1. Cliquez sur Démarrer, puis sur Exécuter.
    2. Dans la zone Ouvrir, tapez regsvr32 iepeers.dll, puis cliquez sur OK.
  16. Redémarrez votre ordinateur.

Méthode 3

Spécifier différents paramètres de spouleur pour l'imprimante. Pour cela, procédez comme suit :
  1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Imprimantes.
  2. Cliquez avec le bouton droit sur l'imprimante, puis cliquez sur Propriétés.
  3. Sous l'onglet Détails, cliquez sur Paramètres du spouleur.
  4. Cliquez sur Mise en attente des travaux d'impression (impression plus rapide), sur Commencer l'impression une fois la dernière page spoulée, puis sur OK.
  5. Redémarrez votre ordinateur.
  6. Démarrez Internet Explorer, puis essayez d'imprimer une page Web.
  7. Si le problème n'est pas résolu, répétez les étapes 1 à 3, cliquez sur Imprimer directement sur l'imprimante, puis sur OK.
  8. Redémarrez votre ordinateur.

Plus d'informations

Pour plus d'informations sur la résolution du message d'erreur "Impossible d'imprimer à partir d'Internet Explorer", cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
293176  (http://support.microsoft.com/kb/293176/ ) Impossible d'imprimer à partir d'Internet Explorer
Pour plus d'informations sur la résolution des problèmes d'impression dans Windows Millennium Edition, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
128345  (http://support.microsoft.com/kb/128345/ ) Résolution des problèmes d'impression dans Windows 95/98

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5 Service Pack 1
Mots-clés : 
kberrmsg kbprb kbprint KB303360
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Retired KB ArticleExclusion de responsabilité concernant les contenus obsolètes dans la Base de connaissances
Cet article concerne des produits pour lesquels Microsoft n'offre plus de support. Il est par conséquent fourni « en l'état » et ne sera plus mis à jour.
 

Traductions disponibles

 

Related Support Centers