Installation oder Update von Internet Explorer kann nicht abgeschlossen werden

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 303399 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel wurde zuvor veröffentlicht unter D303399
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
303399 You Cannot Finish Installing or Upgrading Internet Explorer
Wichtig: Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Bevor Sie die Registrierung bearbeiten, vergewissern Sie sich bitte, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256986 Beschreibung der Microsoft Windows-Registrierung
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Bei dem Versuch Microsoft Internet Explorer zu installieren können folgende Probleme auftreten:
  • Eine der folgenden Fehlermeldungen wird angezeigt:
    Es konnten nicht alle Komponenten für diese Installation übertragen werden.

    Starten Sie Setup später erneut, und wählen Sie "Setup fortsetzen".
    -oder-
    Es konnten nicht alle Komponenten installiert werden. Schließen Sie alle Anwendungen, und führen Sie Setup erneut aus.
    -oder-
    Es konnten nicht alle Komponenten für diese Installation übertragen werden.
  • Während der Installation reagiert der Computer nicht mehr (das System "hängt").

Lösung

Führen Sie die folgenden Schritte in der angegebenen Reihenfolge aus, um dieses Problem zu beheben.
Hinweis: Da es verschiedene Windows-Versionen gibt, können die folgenden Schritte auf Ihrem Computer anders aussehen. Ist dies der Fall, sehen Sie in der Dokumentation zu Ihrem Produkt nach, bevor Sie diese Schritte ausführen.

Methode 1: Überprüfen der Windows-Konfiguration

  1. Vergewissern Sie sich, dass Sie in Microsoft Windows NT 4.0 oder Microsoft Windows 2000 als Administrator angemeldet sind.
  2. Installieren Sie das neueste Service Pack für Ihr Betriebssystem.

    Weitere Informationen dazu, wie Sie Windows NT 4.0 Service Pack 6 (SP6) erhalten können, finden Sie auf folgender Microsoft-Website:
    http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=e396d059-e402-46ef-b095-a74399e25737
    Weitere Informationen dazu, wie Sie Windows 2000 Service Pack 2 (SP2) bekommen, finden Sie auf folgender Microsoft-Website:
    http://www.microsoft.com/windows2000/downloads/servicepacks/sp2/default.mspx
  3. Beenden Sie alle aktiven Programme, auch Antivirus-Programme.
Versuchen Sie, Internet Explorer zu aktualisieren oder zu installieren. Versuchen Sie folgende Methode, falls dies nicht gelingt.

Methode 2: RAM auf 256 MB beschränken

Entfernen oder beschränken Sie den von Windows genutzten RAM auf 256 MB oder weniger, falls Sie mehr als 256 Megabytes (MB) RAM (Random-Access Memory) installiert haben.

Microsoft Windows 95

Wenn Sie mit Windows 95 arbeiten, können Sie ein RAM-Laufwerk benutzen, um den für Windows verfügbaren RAM zu beschränken.

Weitere Informationen über die Verwendung eines RAM-Laufwerks zur Beschränkung des verfügbaren Speichers finden Sie im folgenden Artikel der Microsoft Knowledge Base:
142546 Verwendung eines RAM-Laufwerks zur Behandlung von Speicherproblemen

Microsoft Windows Millennium Edition (Me) oder Microsoft Windows 98

Verwenden Sie das Systemkonfigurationsprogramm zur Beschränkung des für Windows verfügbaren RAM, wenn Sie mit Windows Me, Windows 98 Second Edition oder Windows 98 arbeiten:
  1. Klicken Sie auf Start und anschließend auf Ausführen.
  2. Geben Sie im Feld Öffnen den Dateinamen msconfig ein. Klicken Sie danach auf OK.
  3. Klicken Sie auf Erweitert und aktivieren Sie das Kontrollkästchen Speicherbegrenzung auf.
  4. Geben Sie im Feld MB den Speicherwert ein, auf den Sie Windows beschränken möchten, z. B. 256.
  5. Klicken Sie zweimal auf OK und danach auf Ja, um den Computer neu zu starten.

Windows 2000 oder Windows NT 4.0

Bearbeiten Sie die Datei "Boot.ini", um den für Windows verfügbaren RAM zu beschränken, wenn Sie mit Windows 2000 oder Windows NT 4.0 arbeiten. Fügen Sie folgende Option zum Pfad ARC im Abschnitt [Operating System] der Datei "Boot.ini" hinzu. Dabei steht RAM-Wert für den RAM, den Sie Windows zur Verfügung stellen möchten.
/MAXMEM=RAM-Wert
Der folgende ARC-Pfad beschränkt Windows z. B. auf 256 MB RAM:
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Server"  /fastdetect /MAXMEM=256
				
Hinweis: Die Datei "Boot.ini" ist eine versteckte Datei, die im Stammverzeichnis des Startlaufwerks liegt.

Gehen Sie folgendermaßen vor, um die Datei "Boot.ini" zu bearbeiten.

Warnung: Eine fehlerhafte Änderung an der Datei "boot.ini" kann dazu führen, dass Windows nicht mehr funktionsfähig ist.
  1. Melden Sie sich als Administrator an Windows NT 4.0 oder Windows 2000 an.
  2. Klicken Sie auf Start und anschließend auf Ausführen.
  3. Geben Sie cmd im Feld Öffnen ein, und klicken Sie auf OK.
  4. Wechseln Sie in das Stammverzeichnis der Startpartition. Geben Sie z. B. cd\ ein, wenn Ihr Computer keine Multiple-Boot-Konfiguration besitzt.
  5. Geben Sie attrib -a -h -s boot.ini ein und drücken Sie die [EINGABETASTE].
  6. Geben Sie copy boot.ini boot.old ein.

    Hinweis: Wenn Sie diesen Befehl ausführen, erstellt Windows eine Sicherungskopie der Datei "Boot.ini" mit Namen "Boot.old".
  7. Geben Sie edit boot.ini ein und drücken Sie die [EINGABETASTE].
  8. Gehen Sie mit den Pfeiltasten an das Ende des ARC-Pfades, den Sie ändern möchten (unter [operating systems]).
  9. Geben Sie /MAXMEM=256 ein.
  10. Drücken Sie [ALT]+[F] und anschließend [S].
  11. Drücken Sie [ALT]+[F] und anschließend [X].
  12. Geben Sie attrib +a +s +h boot.ini ein und drücken Sie die [EINGABETASTE].
  13. Geben Sie exit ein, und drücken Sie die [EINGABETASTE].
  14. Starten Sie Ihren Computer neu.
Versuchen Sie, Internet Explorer zu aktualisieren oder zu installieren. Versuchen Sie folgende Methode, falls dies nicht gelingt.

Methode 3: Überprüfen von Größe und Speicherort der Auslagerungsdatei

Vergewissern Sie sich, dass der Computer über eine Auslagerungsdatei verfügt und dass diese Datei größer ist als der derzeit installierte RAM. Falls möglich, verschieben Sie die Auslagerungsdatei in eine andere Partition auf dem Computer. Gehen Sie folgendermaßen vor, um die Einstellungen für die Auslagerungsdatei zu überprüfen.

Windows Me, Windows 98 und Windows 95

  1. Klicken Sie auf Start, zeigen Sie auf Einstellungen, klicken Sie auf Systemsteuerung, und doppelklicken Sie danach auf System.
  2. Klicken Sie auf die Registerkarte Leistung, notieren Sie den Wert des auf dem Computer installierten RAM, der neben Speicher angezeigt wird, und klicken Sie danach auf Virtueller Speicher.
    • Wenn Windows verwaltet die Einstellungen für den virtuellen Speicher (empfohlen) aktiviert ist, enthält der Datenträger, der den Windows-Ordner enthält, auch die Auslagerungsdatei, und Windows bestimmt die Größe der Auslagerungsdatei.
    • Wenn Es gelten benutzerdefinierte Einstellungen für den virtuellen Speicher aktiviert ist, zeigt das Feld Festplatte den Datenträger der Auslagerungsdatei an.
  3. Aktivieren Sie die Option Es gelten benutzerdefinierte Einstellungen für den virtuellen Speicher, wenn sie noch nicht aktiviert ist.
  4. Wählen Sie im Feld Festplatte eine andere Partition als die, in der Windows installiert ist (sofern vorhanden).
  5. Wählen Sie im Feld Minimum einen Wert, der größer ist als der bereits auf dem Computer installierte RAM.
  6. Wählen Sie im Feld Maximum einen Wert, der größer als der im Feld Minimum angegebene Wert oder gleich ist.
  7. Klicken Sie auf OK und danach auf Ja, wenn die Meldung Einstellungen für den virtuellen Arbeitsspeicher bestätigen erscheint.
  8. Klicken Sie auf Schließen und danach auf Ja, wenn Sie dazu aufgefordert werden, den Computer neu zu starten.

Windows 2000 und Windows NT 4.0

  1. Melden Sie sich als Administrator am Computer an.
  2. Klicken Sie auf Start, zeigen Sie auf Einstellungen, klicken Sie auf Systemsteuerung, und doppelklicken Sie danach auf System.
  3. Notieren Sie den RAM-Wert, der unter Computer angezeigt wird.
  4. Klicken Sie auf die Registerkarte Erweitert und anschließend auf Leistungsmerkmale.

    Hinweis: In Windows NT 4.0 klicken Sie auf die Registerkarte Leistung.
  5. Klicken Sie unter Virtueller Speicher auf Ändern.
  6. Notieren Sie die Größe der Auslagerungsdatei, die unter Gesamtgröße der Auslagerungsdatei für alle Laufwerke neben Im Moment zugeteilt angezeigt wird.
    • Gehen Sie folgendermaßen vor, um die Größe der Auslagerungsdatei zu ändern:
      1. Geben Sie im Feld Anfangsgröße (MB) einen Wert ein, der mindestens 12 MB größer ist als der bereits auf dem Computer installierte RAM.
      2. Geben Sie im Feld Maximale Größe (MB) den maximalen Wert an, den Sie für die Größe der Auslagerungsdatei zulassen möchten. Klicken Sie danach Setzen.
    • Gehen Sie folgendermaßen vor, um die Auslagerungsdatei in eine andere Partition zu verschieben:
      1. Klicken Sie unter Laufwerk [Volumebezeichnung] auf die Partition, in die Sie die Auslagerungsdatei verschieben möchten.
      2. Geben Sie im Feld Anfangsgröße (MB) einen Wert ein, der mindestens 12 MB größer ist als der bereits auf dem Computer installierte RAM.
      3. Geben Sie im Feld Maximale Größe (MB) den maximalen Wert an, den Sie für die Größe der Auslagerungsdatei zulassen möchten. Klicken Sie danach Setzen.
      4. Klicken Sie unter Laufwerk [Volumebezeichnung] auf die Partition, in der Windows installiert ist.
      5. Geben Sie im Feld Anfangsgröße (MB) den Wert 0 ein.
      6. Geben Sie im Feld Maximale Größe (MB) den Wert 0 ein. Klicken Sie danach auf Setzen.
      7. Klicken Sie auf Ja, um zu bestätigen, dass die Einstellung für die Größe der Auslagerungsdatei die Größe des auf dem Computer installierten RAM unterschreitet, wenn eine Meldung der Systemsteuerung angezeigt wird.
  7. Klicken Sie auf OK.

    Klicken Sie auf OK, wenn die folgende Meldung angezeigt wird:
    Die Änderungen werden erst nach einem Neustart des Computers übernommen.
  8. Klicken Sie zweimal auf OK und danach auf Ja, um den Computer neu zu starten.
Versuchen Sie, Internet Explorer zu aktualisieren oder zu installieren. Versuchen Sie folgende Methode, falls dies nicht gelingt.

Methode 4: Entfernen von Antivirusprogrammen

  1. Klicken Sie auf Start, zeigen Sie auf Einstellungen, klicken Sie auf Systemsteuerung, und klicken Sie auf Software.
  2. Klicken Sie auf das Antivirusprogramm und danach auf Hinzufügen/Entfernen.

    Hinweis: Klicken Sie auf Entfernen, wenn Sie Windows 2000 verwenden.
  3. Folgen Sie den Anweisungen, um das Antivirusprogramm vollständig zu entfernen, und starten Sie Ihren Computer neu.
Versuchen Sie, Internet Explorer zu aktualisieren oder zu installieren. Versuchen Sie folgende Methode, falls dies nicht gelingt.

Methode 5: Entfernen von Internet Explorer-Komponenten

Entfernen Sie Internet Explorer-Updates und alle folgenden zusätzlichen Internet Explorer-Komponenten:
  • Microsoft Outlook Express
  • Microsoft Netmeeting
  • Microsoft Wallet
  • Microsoft Active Movie
  • Microsoft Netshow
  • Microsoft Chat
  • Internet Mail und News
  • Microsoft VRML Player
  • VDOLive Player
  • Microsoft FrontPage Express
  • Microsoft Internet Explorer Access Kit (IEAK)
Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start, zeigen Sie auf Einstellungen, klicken Sie auf Systemsteuerung, und klicken Sie auf Software.
  2. Klicken Sie auf das zu entfernende Internet Explorer-Element und danach auf Hinzufügen/Entfernen.

    Hinweis: Klicken Sie auf Entfernen, wenn Sie Windows 2000 verwenden.
  3. Folgen Sie den Anweisungen, um den Internet Explorer und die zugehörigen Komponenten vollständig zu entfernen.

    Hinweis: Entfernen Sie keine gemeinsam genutzte Dateien, falls Sie dazu aufgefordert werden.
  4. Installieren Sie das neueste Service Pack, falls Sie Windows NT 4.0 verwenden.

    Weitere Informationen über das neueste Windows NT 4.0 Service Pack finden Sie auf folgender Microsoft-Website:
    http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=e396d059-e402-46ef-b095-a74399e25737
  5. Starten Sie Ihren Computer neu.
Versuchen Sie, Internet Explorer zu aktualisieren oder zu installieren. Versuchen Sie folgende Methode, falls dies nicht gelingt.

Methode 6: Entfernen von Dateien und Einstellungen

Schritt 1: Umbenennen von DLL-Dateien

Benennen Sie die folgenden DLL-Dateien um (DLL = Dynamic-Link Library) um:
Actxprxy.dll
Advpack.dll
Comcat.dll
Inseng.dll
Jobexec.dll
Url.dll
Urlmon.dll
Wininet.dll
Wintrust.dll
Gehen Sie dabei nach dem im entsprechenden Abschnitt beschriebenen Verfahren vor.

Hinweis: Einige dieser Dateien sind möglicherweise auf Ihrem Computer nicht vorhanden.

Warnung: Löschen Sie keinesfalls die Datei "Wintrust.dll".

Windows Me, Windows 98 und Windows 95
  1. Starten Sie Windows im Abgesicherten Modus. Weitere Informationen zum Starten von Windows im abgesicherten Modus finden Sie in folgenden Artikeln der Microsoft Knowledge Base:
    180902 Windows 98 Computer im abgesicherten Modus starten
    122051 Vorgang beim Start von Windows 95 im abgesicherten Modus
  2. Starten Sie Windows Explorer.
  3. Klicken Sie im Menü Extras auf Ordneroptionen.
  4. Klicken Sie auf die Registerkarte Ansicht.
  5. Klicken Sie auf Versteckte Dateien und Ordner anzeigen und deaktivieren Sie das Kontrollkästchen Erweiterungen bei bekannten Dateitypen ausblenden. Klicken Sie danach auf OK.
  6. Navigieren Sie zu folgendem Pfad, wobei Laufwerk für das Laufwerk steht, auf dem Windows installiert ist:
    Laufwerk:\Windows\System
  7. Klicken Sie mit der rechten Maustaste auf eine Datei aus der vorherigen Liste, und klicken Sie danach auf Umbenennen.
  8. Benennen Sie die Dateinamenerweiterung der .dll-Datei in .old um und drücken Sie die [EINGABETASTE].
  9. Benennen Sie alle DLL-Dateien aus der obigen Liste um, die sich auf Ihrem Computer befinden, wie in Schritt 7 and 8 beschrieben.
Windows 2000 und Windows NT 4.0
  1. Starten Sie Windows Explorer.
  2. Klicken Sie im Menü Extras auf Ordneroptionen.

    Hinweis: Klicken Sie im Menü Ansicht auf Optionen, falls Sie Windows 4.0 verwenden.
  3. Klicken Sie auf die Registerkarte Ansicht.
  4. Klicken Sie auf Versteckte Dateien und Ordner anzeigen und deaktivieren Sie das Kontrollkästchen Erweiterungen bei bekannten Dateitypen ausblenden. Klicken Sie danach auf OK.
  5. Navigieren Sie zu folgendem Pfad, wobei Laufwerk für das Laufwerk steht, auf dem Windows installiert ist:
    Laufwerk :\Winnt\System32
  6. Klicken Sie mit der rechten Maustaste auf eine Datei aus der vorherigen Liste, und klicken Sie danach auf Umbenennen.
  7. Benennen Sie die Dateinamenerweiterung der .dll-Datei in .old um und drücken Sie die [EINGABETASTE].
  8. Benennen Sie alle DLL-Dateien aus der obigen Liste um, die sich auf Ihrem Computer befinden, wie in Schritt 6 and 7 beschrieben.

Schritt 2: Umbenennen der Setup-Protokolldateien

Benennen Sie die Dateien "Active Setup Log.txt" und "Internet Explorer Setup Log.txt" um, sofern sie vorhanden sind. Gehen Sie dabei nach dem im entsprechenden Abschnitt beschriebenen Verfahren vor.

Windows NT 4.0, Windows 98 und Windows 95
  1. Klicken Sie auf Start, zeigen Sie auf Suchen, und klicken Sie anschließend auf Dateien/Ordner.
  2. Geben Sie im Feld Name die Dateinamen "Active Setup Log.txt";" IE Setup Log.txt" ein.
  3. Klicken Sie in der Liste Suchen in auf Arbeitsplatz, und klicken Sie anschließend auf Suchen.
  4. Klicken Sie in der Ergebnisliste mit der rechten Maustaste auf Active Setup Log.txt. Klicken Sie danach auf Umbenennen.
  5. Benennen Sie "Active Setup Log.txt" in oldsetup log.txt um. Drücken Sie danach die [EINGABETASTE].
  6. Klicken Sie mit der rechten Maustaste auf IE Setup Log.txt. Klicken Sie danach auf Umbenennen.
  7. Benennen Sie "IE Setup Log.txt" in oldIE Setup Log.txt um. Drücken Sie danach die [EINGABETASTE].
  8. Klicken Sie im Menü Datei auf Schließen.
Windows 2000 und Windows Me
  1. Klicken Sie auf Start, zeigen Sie auf Suchen, und klicken Sie auf Nach Dateien oder Ordnern.
  2. Geben Sie im Feld Nach folgenden Dateien oder Ordnern suchen die Dateinamen "Active Setup Log.txt";"IE Setup Log.txt" ein.
  3. Klicken Sie in der Liste Suchen in auf Arbeitsplatz und danach auf Jetzt suchen.
  4. Klicken Sie im Fenster Suchergebnisse mit der rechten Maustaste auf Active Setup Log.txt. Klicken Sie danach auf Umbenennen.
  5. Benennen Sie "Active Setup Log.txt" in oldsetup log.txt um. Drücken Sie danach die [EINGABETASTE].
  6. Klicken Sie mit der rechten Maustaste auf IE Setup Log.txt. Klicken Sie danach auf Umbenennen.
  7. Benennen Sie "IE Setup Log.txt" in oldIE Setup Log.txt um. Drücken Sie danach die [EINGABETASTE].
  8. Klicken Sie im Menü Datei auf Schließen.

Schritt 3: Entfernen des Ordners "Windows Update Setup Files"

Wenn der Ordner "Windows Update Setup Files" vorhanden ist, löschen Sie ihn:
  1. Starten Sie Windows Explorer und blenden Sie den Ordner ein, in dem Windows installiert ist.
  2. Klicken Sie mit der rechten Maustaste auf Windows Update Setup Files. Klicken Sie danach auf Löschen.
  3. Klicken Sie auf Ja, wenn die Meldung Löschen von Ordnern bestätigen angezeigt wird.
  4. Klicken Sie auf Ja, alle, wenn Sie aufgefordert werden, das Entfernen von Dateien oder Ordnern zu bestätigen.

Schritt 4: Löschen temporärer Dateien

Löschen Sie den Inhalt des Ordners "Temp":
  1. Navigieren Sie im Windows Explorer zum Ordner Temp.
  2. Klicken Sie im Menü Bearbeiten auf Alles markieren.
  3. Klicken Sie im Menü Datei auf Löschen.
  4. Klicken Sie auf Ja, wenn Sie dazu aufgefordert werden, das Löschen von Dateien oder Ordnern zu bestätigen.
  5. Beenden Sie Windows Explorer.
  6. Starten Sie Ihren Computer neu.

Schritt 5:

Bearbeiten der Windows-RegistrierungWarnung: Die unkorrekte Verwendung des Registrierungs-Editors kann schwerwiegende Probleme verursachen, die das gesamte System betreffen und eine Neuinstallation des Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungs-Editors herrühren, behoben werden können. Benutzen Sie den Registrierungs-Editor auf eigene Verantwortung.

  1. Klicken Sie auf Start und anschließend auf Ausführen.
  2. Geben Sie in das Feld Öffnen die Zeichenfolge regedit ein, und klicken Sie auf OK.
  3. Klicken Sie im Registrierungs-Editor auf folgenden Unterschlüssel:
    HKEY_CURRENT_USER\Software\Microsoft\Active Setup
  4. Klicken Sie im Menü Registrierung auf Registrierungsdatei exportieren.
  5. Geben Sie im Feld Dateiname den Namen active setup ein, und klicken Sie auf Speichern.
  6. Klicken Sie im Menü Bearbeiten auf Löschen.
  7. Wenn die Meldung Löschen des Schlüssels bestätigen angezeigt wird, klicken Sie auf Ja.
  8. Führen Sie jeweils die Schritte 3 bis 7 aus, um alle folgenden Registrierungsschlüssel zu exportieren und danach zu löschen:
    • HKEY_CURRENT_USER\SOFTARE\Microsoft\Internet Explorer
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

Schritt 6: Überprüfen der Registrierungseinstellung für den Ordner "Programme"

Vergewissern Sie sich, dass die Registrierungswerte ProgramFilesDir und ProgramFilesPath für den Ordner "Programme" auf den richtigen Speicherort zeigen:
  1. Klicken Sie im Registrierungs-Editor auf folgenden Unterschlüssel:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
  2. Doppelklicken Sie im rechten Fenster des Registrierungs-Editors auf ProgramFilesDir.
  3. Geben Sie im Feld Wert den richtige Pfad zum Ordner "Programme" ein, falls er nicht bereits angezeigt wird. Geben Sie z. B. C:\Programme ein.
  4. Klicken Sie auf OK.
  5. Doppelklicken Sie auf ProgramFilesPath.
  6. Wenn %Programme% im Feld Wert nicht angezeigt wird, geben Sie %Programme% ein.
  7. Klicken Sie auf OK.
  8. Beenden Sie den Registrierungs-Editor.

    Hinweis: Starten Sie den Computer zu diesem Zeitpunkt nicht neu.

Schritt 7: Trennen zugeordneter Laufwerke

Trennen Sie sie Netzlaufwerke, falls auf Ihrem Computer Laufwerkbuchstaben zu Netzlaufwerken zugeordnet sind:
  1. Doppelklicken Sie auf dem Desktop auf Arbeitsplatz.
  2. Klicken Sie mit der rechten Maustaste auf das Netzwerk, das Sie ändern möchten (das Laufwerk erscheint als Laufwerksymbol mit zugehöriger Netzwerkverbindung). Klicken Sie danach auf Trennen.

Schritt 8: Ersetzen der Datei "Winhlp32.exe"

Hinweis: Zwar ist dieser Schritt zur Behebung des Problems nicht erforderlich, jedoch bewirkt er, dass zahlreiche DLL-bezogene Meldungen nicht angezeigt werden, wenn Sie versuchen, den Internet Explorer zu installieren oder zu aktualisieren.

Hinweis: Diesen Schritt können Sie nur durchführbar, wenn Sie mit Windows 2000 oder Windows NT 4.0 arbeiten.
  1. Starten Sie Windows Explorer und gehen Sie zu folgendem Pfad. Dabei steht Laufwerk für das Laufwerk, auf dem Windows installiert ist:
    Laufwerk :\Winnt
  2. Klicken Sie im rechten Fenster mit der rechten Maustaste auf Winhlp32.exe. Klicken Sie danach auf Kopieren.
  3. Navigieren Sie zu folgendem Ordner:
    Laufwerk :\Winnt\System32
  4. Klicken Sie im rechten Fenster mit der rechten Maustaste auf Winhlp32.exe. Klicken Sie danach auf Umbenennen.
  5. Benennen Sie Winhlp32.exe um in Winhlp32.old und drücken Sie die [EINGABETASTE].

    Klicken Sie auf Ja, wenn Sie aufgefordert werden, das Ändern der Dateinamenerweiterung zu bestätigen.
  6. Klicken Sie im Menü Bearbeiten auf Einfügen.
  7. Beenden Sie Windows Explorer.

Schritt 9: Installieren des Internet Explorer

Versuchen Sie, den Internet Explorer in der beschriebenen Reihenfolge mit folgenden Methoden zu installieren oder zu aktualisieren:
  • Installieren Sie den Internet Explorer von der folgenden Microsoft-Website:
    http://www.microsoft.com/germany/windows/ie/default.mspx
  • Installieren Sie den Internet Explorer von der Internet Explorer-CD.
  • Kopieren Sie die IE-Installationsdateien auf die lokale Festplatte und führen Sie anschließend Setup von der Festplatte aus.
  • Installieren Sie Internet Explorer in einen anderen Ordner als die folgenden Standardinstallationsordner:
    Laufwerk:\Programme\Plus!\Microsoft Internet

    -oder-

    Laufwerk:\Programme\Internet Explorer
Hinweis: Bei Versuch, den Internet Explorer zu installieren, kann folgende Fehlermeldung angezeigt werden:
Eine frühere Installation eines Programms wurde nie abgeschlossen.
Der Computer muss neu gestartet werden, um die Installation zu beenden, bevor Internet Explorer Setup ausgeführt werden kann. Setup wird beendet.
Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:
  1. Klicken Sie auf Start und anschließend auf Ausführen.
  2. Geben Sie in das Feld Öffnen die Zeichenfolge regedit ein, und klicken Sie auf OK.
  3. Klicken Sie im Registrierungs-Editor auf folgenden Unterschlüssel:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager
    Hinweis: In diesem Registrierungsschlüssel ist "Session Manager" mit zwei Worten geschrieben.
  4. Klicken Sie im rechten Fenster des Registrierungs-Editors auf PendingFileRenameOperations, und klicken Sie danach auf Löschen.
  5. Wenn die Meldung Löschen der Werte bestätigen angezeigt wird, klicken Sie auf Ja.
  6. Blenden Sie im linken Fenster des Registrierungs-Editors den Unterschlüssel Session Manager ein.
  7. Wenn ein Unterschlüssel FileRenameOperations erscheint, klicken Sie darauf und löschen Sie alle Einträge des Unterschlüssels FileRenameOperations im rechten Fenster.
  8. Beenden Sie den Registrierungs-Editor.
  9. Starten Sie Internet Explorer Setup erneut.

Weitere Informationen

Weitere Informationen zur Größe der Auslagerungsdatei auf Windows 2000-Domänencontrollern finden Sie im folgenden Artikel der Microsoft Knowledge Base:
216899 Richtlinien für die Konfiguration von Windows 2000-Domänencontrollern
Weitere Informationen zum Hinzufügen und Entfernen von Internet Explorer unter Windows 2000 mithilfe der Systemsteuerung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
265829 Systemprogramm "Software" funktioniert nach Installation von Internet Explorer 5.5 oder Internet Explorer 6 auf Windows 2000 eventuell nicht

Eigenschaften

Artikel-ID: 303399 - Geändert am: Mittwoch, 30. Mai 2007 - Version: 5.2
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 6.0, wenn verwendet mit:
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
Keywords: 
kbupgrade kbenv kbsetup kbprb KB303399
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com