Nelze dokončit instalaci nebo upgrade aplikace Internet Explorer

Překlady článku Překlady článku
ID článku: 303399 - Produkty, které se vztahují k tomuto článku.
DŮLEŽITÉ: Tento článek obsahuje informace o úpravě registru. Před úpravou registru je nutné jej zálohovat. Je také nutné předem vědět, jak registr obnovit v případě, že nastanou potíže. Další informace o zálohování, obnovení a úpravách registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986 Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Pokud se pokusíte nainstalovat aplikaci Internet Explorer, může dojít k následujícímu chování:
  • Zobrazí se jedna z následujících chybových zpráv:
    Instalačnímu programu se nezdařilo stáhnout všechny součásti potřebné k této instalaci.

    Zkuste znovu spustit instalační program později a použijte možnost pokračování v instalaci.
    -nebo-
    Instalace některých součástí se nezdařila. Ukončete všechny aplikace a zkuste znovu spustit instalační program.
    -nebo-
    Instalačnímu programu se nezdařilo stáhnout všechny součásti potřebné k této instalaci.
  • Počítač přestane při instalaci reagovat (zablokuje se).

Řešení

K řešení uvedených potíží použijte následující metody v uvedeném pořadí.
POZNÁMKA: Vzhledem k různým verzím systému Microsoft Windows se následující postup může lišit od postupu ve vašem počítači. V takovém případě vyhledejte návod k provedení těchto kroků v dokumentaci k danému produktu.

Metoda 1: Ověření konfigurace systému Windows

  1. V systému Microsoft Windows 2000 nebo Microsoft Windows NT 4.0 ověřte, že jste k počítači přihlášeni jako správce.
  2. Nainstalujte nejnovější aktualizaci Service Pack pro svůj operační systém.

    Další informace o tom, jak získat aktualizaci Service Pack 6 (SP6) pro systém Windows NT 4.0, naleznete na následujícím webu společnosti Microsoft:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=e396d059-e402-46ef-b095-a74399e25737&DisplayLang=en
    Další informace o tom, jak získat aktualizaci Service Pack 2 (SP2) pro systém Windows 2000, naleznete na následujícím webu společnosti Microsoft:
    http://www.microsoft.com/windows2000/downloads/servicepacks/sp2/default.mspx
  3. Ukončete všechny spuštěné programy, včetně všech antivirových programů.
Pokuste se upgradovat nebo nainstalovat aplikaci Internet Explorer. Pokud se upgrade nebo instalace nezdaří, použijte následující metodu.

Metoda 2: Omezení velikosti paměti RAM na 256 MB

Jestliže je v počítači nainstalováno více než 256 MB paměti RAM (random-access memory), odeberte některé paměťové moduly RAM z počítače nebo používání paměti omezte tak, aby se v systému Windows používalo pouze 256 MB nebo méně.

Microsoft Windows 95

Pokud používáte systém Windows 95, můžete ke snížení velikosti paměti RAM dostupné pro systém Windows použít jednotku RAM.

Další informace o tom, jak omezit dostupnou paměť pomocí jednotky RAM, naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
142546 Jak pomocí jednotky RAM řešit problémy s pamětí (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Microsoft Windows Millennium Edition (ME) nebo Microsoft Windows 98

Jestliže používáte operační systém Windows ME, Windows 98 Druhé vydání nebo Windows 98, použijte pro omezení velikosti paměti RAM dostupné pro systém Windows nástroj Konfigurace systému:
  1. Klepněte na tlačítko Start a potom na příkaz Spustit.
  2. Do pole Otevřít zadejte příkaz msconfig a klepněte na tlačítko OK.
  3. Klepněte na tlačítko Upřesnit a potom zaškrtněte políčko Omezit používání paměti na.
  4. Do pole MB zadejte maximální hodnotu velikosti paměti, kterou má systém Windows používat, například 256.
  5. Klepněte dvakrát na tlačítko OK a potom klepnutím na tlačítko Ano restartujte počítač.

Windows 2000 nebo Windows NT 4.0

Používáte-li systém Windows 2000 nebo Windows NT 4.0, nastavte maximální velikost paměti pro systém Windows úpravou souboru Boot.ini. Do oddílu [Operating System] souboru Boot.ini přidejte následující parametr do cesty ARC, kde položka velikost paměti RAM představuje maximální velikost paměti RAM, kterou bude v systému Windows povoleno používat.
/MAXMEM=velikost paměti RAM
Následující cesta ARC například omezí velikost paměti RAM pro systém Windows na 256 MB:
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Server"  /fastdetect /MAXMEM=256
				
POZNÁMKA: Soubor Boot.ini je skrytý soubor uložený v kořenové složce spouštěcí jednotky.

Chcete-li upravit soubor Boot.ini, postupujte následujícím způsobem.

Upozornění: Chybná změna souboru Boot.ini může způsobit, že systém Windows nebude možné spustit.
  1. Přihlaste se k systému Windows NT 4.0 nebo Windows 2000 jako správce.
  2. Klepněte na tlačítko Start a potom na příkaz Spustit.
  3. Do pole Otevřít zadejte příkaz cmd a potom klepněte na tlačítko OK.
  4. Přejděte do kořenové složky spouštěcího oddílu. Pokud se v počítači nepoužívá více konfigurací pro spuštění, bude stačit, když zadáte příkaz cd\.
  5. Zadejte příkaz attrib -a -h -s boot.ini a stiskněte klávesu ENTER.
  6. Zadejte příkaz copy boot.ini boot.old.

    POZNÁMKA: Po spuštění tohoto příkazu vytvoří systém Windows záložní kopii souboru Boot.ini s názvem Boot.old.
  7. Zadejte příkaz edit boot.ini a stiskněte klávesu ENTER.
  8. Pomocí kláves se šipkami přejděte v oddíle [operating systems] kurzorem na konec cesty ARC, kterou chcete změnit.
  9. Zadejte /MAXMEM=256.
  10. Stiskněte kombinaci kláves ALT+F a potom stiskněte klávesu S.
  11. Stiskněte kombinaci kláves ALT+F a potom stiskněte klávesu X.
  12. Zadejte příkaz attrib +a +s +h boot.ini a stiskněte klávesu ENTER.
  13. Zadejte příkaz exit a potom stiskněte klávesu ENTER.
  14. Restartujte počítač.
Pokuste se upgradovat nebo nainstalovat aplikaci Internet Explorer. Pokud se upgrade nebo instalace nezdaří, použijte následující metodu.

Metoda 3: Ověření velikosti a umístění odkládacího souboru

Ověřte, že odkládací soubor v počítači existuje a že je jeho velikost větší, než jaká je velikost paměti RAM aktuálně nainstalované v počítači. Pokud je to možné, přesuňte odkládací soubor na jiný oddíl v počítači. Chcete-li ověřit nastavení odkládacího souboru, proveďte kroky v odpovídající části.

Windows ME, Windows 98 a Windows 95

  1. Klepněte na tlačítko Start, přejděte na příkaz Nastavení, klepněte na položku Ovládací panely a poklepejte na panel Systém.
  2. Klepněte na kartu Výkon a poznamenejte si hodnotu velikosti paměti RAM nainstalované v počítači. Tato hodnota je uvedena u položky Paměť. Potom klepněte na tlačítko Virtuální paměť.
    • Pokud je vybrána možnost Virtuální paměť nastaví systém Windows (doporučeno), je na disku, na kterém je uložena složka Windows, uložen také odkládací soubor a systém Windows určuje jeho velikost.
    • Jestliže je vybrána možnost Virtuální paměť nastaví uživatel, zobrazí se v poli Pevný disk informace o tom, na kterém disku je odkládací soubor uložen.
  3. Klepněte na možnost Virtuální paměť nastaví uživatel (pokud ještě není vybrána).
  4. V poli Pevný disk vyberte jiný oddíl než ten, na kterém je nainstalován systém Windows (pokud je k dispozici).
  5. V poli Nejméně vyberte nebo zadejte hodnotu, která je vyšší než velikost paměti RAM, která je již v počítači nainstalována.
  6. V poli Nejvíce zadejte nebo vyberte hodnotu, která je větší než hodnota v poli Nejméně. Můžete také vybrat stejnou hodnotu.
  7. Klepněte na tlačítko OK a potom klepněte na tlačítko Ano v zobrazené zprávě Potvrdit nastavení virtuální paměti.
  8. Klepněte na tlačítko Zavřít a po zobrazení výzvy k restartování počítače klepněte na tlačítko Ano.

Windows 2000 a Windows NT 4.0

  1. Přihlaste se k počítači jako správce.
  2. Klepněte na tlačítko Start, přejděte na příkaz Nastavení, klepněte na položku Ovládací panely a poklepejte na panel Systém.
  3. Poznamenejte si hodnotu velikosti paměti RAM zobrazenou v části Počítač.
  4. Klepněte na kartu Upřesnit a potom klepněte na položku Možnosti výkonu.

    POZNÁMKA: V systému Windows NT 4.0 klepněte na kartu Výkon.
  5. V části Virtuální paměť klepněte na tlačítko Změnit.
  6. Ve skupinovém rámečku Celková velikost stránkovacího souboru všech jednotek si poznamenejte velikost stránkovacího souboru uvedenou u položky Aktuálně přidělená hodnota.
    • Chcete-li velikost stránkovacího souboru změnit, postupujte takto:
      1. V poli Počáteční velikost (MB) zadejte hodnotu, která je alespoň o 12 MB větší než hodnota velikosti paměti RAM nainstalované v počítači.
      2. V poli Maximální velikost (MB) zadejte maximální velikost, kterou může stránkovací soubor mít, a klepněte na tlačítko Nastavit.
    • Chcete-li stránkovací soubor přesunout na jiný oddíl, postupujte takto:
      1. V seznamu Jednotka [název svazku] klepněte na oddíl, na který chcete stránkovací soubor přesunout.
      2. V poli Počáteční velikost (MB) zadejte hodnotu, která je alespoň o 12 MB větší než hodnota velikosti paměti RAM nainstalované v počítači.
      3. V poli Maximální velikost (MB) zadejte maximální velikost, kterou může stránkovací soubor mít, a klepněte na tlačítko Nastavit.
      4. V seznamu Jednotka [název svazku] klepněte na oddíl, na kterém je nainstalován systém Windows.
      5. Do pole Počáteční velikost (MB) zadejte hodnotu 0.
      6. Do pole Maximální velikost (MB) zadejte hodnotu 0 a klepněte na tlačítko Nastavit.
      7. V zobrazené zprávě Ovládací panel Systém potvrďte klepnutím na tlačítko Ano, že je nastavená velikost stránkovacího souboru menší než velikost paměti RAM nainstalované v počítači.
  7. Klepněte na tlačítko OK.

    Pokud se zobrazí následující zpráva, klepněte na tlačítko OK:
    Provedené změny se projeví až po restartování počítače.
  8. Klepněte dvakrát na tlačítko OK a potom klepnutím na tlačítko Ano restartujte počítač.
Pokuste se upgradovat nebo nainstalovat aplikaci Internet Explorer. Pokud se upgrade nebo instalace nezdaří, použijte následující metodu.

Metoda 4: Odebrání antivirových programů

  1. Klepněte na tlačítko Start, přejděte na příkaz Nastavení, klepněte na položku Ovládací panely a potom na panel Přidat nebo odebrat programy.
  2. Klepněte na název antivirového programu a potom na tlačítko Přidat či odebrat.

    POZNÁMKA: V systému Windows 2000 klepněte na tlačítko Odebrat.
  3. Podle pokynů úplně odeberte antivirový program a potom počítač restartujte.
Pokuste se upgradovat nebo nainstalovat aplikaci Internet Explorer. Pokud se upgrade nebo instalace nezdaří, použijte následující metodu.

Metoda 5: Odebrání součástí aplikace Internet Explorer

Odeberte upgrady aplikace Internet Explorer a všechny následující součásti aplikace Internet Explorer:
  • Microsoft Outlook Express,
  • Microsoft Netmeeting,
  • Microsoft Wallet,
  • Microsoft Active Movie,
  • Microsoft Netshow,
  • Microsoft Chat,
  • Internet Mail and News,
  • Microsoft VRML Player,
  • VDOLive Player,
  • Microsoft FrontPage Express,
  • Microsoft Internet Explorer Access Kit (IEAK).
Postupujte následujícím způsobem:
  1. Klepněte na tlačítko Start, přejděte na příkaz Nastavení, klepněte na položku Ovládací panely a potom na panel Přidat nebo odebrat programy.
  2. Klepněte na položku aplikace Internet Explorer, kterou chcete odebrat, a klepněte na tlačítko Přidat či odebrat.

    POZNÁMKA: V systému Windows 2000 klepněte na tlačítko Odebrat.
  3. Podle pokynů úplně odeberte aplikaci Internet Explorer a související součásti.

    POZNÁMKA: Pokud se zobrazí výzva k odebrání sdílených souborů, nepotvrzujte ji.
  4. V systému Windows NT 4.0 je potřeba znovu nainstalovat nejnovější aktualizaci Service Pack.

    Další informace o nejnovějších aktualizacích Service Pack pro systém Windows NT 4.0 získáte na následujícím webu společnosti Microsoft:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=e396d059-e402-46ef-b095-a74399e25737&DisplayLang=en
  5. Restartujte počítač.
Pokuste se upgradovat nebo nainstalovat aplikaci Internet Explorer. Pokud se upgrade nebo instalace nezdaří, použijte následující metodu.

Metoda 6: Odebrání souborů a nastavení

Krok 1: Přejmenování souborů DLL

Přejmenujte následující soubory DLL (Dynamic-Link Library):
Actxprxy.dll
Advpack.dll
Comcat.dll
Inseng.dll
Jobexec.dll
Url.dll
Urlmon.dll
Wininet.dll
Wintrust.dll
Chcete-li to provést, postupujte podle kroků v příslušné části.

POZNÁMKA: Některé z těchto souborů nebudou pravděpodobně v počítači uloženy.

Upozornění: Neodstraňujte soubor Wintrust.dll.

Windows ME, Windows 98 a Windows 95
  1. Spusťte systém Windows v nouzovém režimu. Další informace o spuštění systému Windows v nouzovém režimu získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
    180902 Jak spustit počítač se systémem Windows 98 v nouzovém režimu (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
    122051 Jak spustit systém Windows 95 v nouzovém režimu (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
  2. Spusťte program Průzkumník Windows.
  3. V nabídce Nástroje klepněte na příkaz Možnosti složky.
  4. Klepněte na kartu Zobrazení.
  5. Klepněte na možnost Zobrazovat skryté soubory a složky, zrušte zaškrtnutí políčka Skrýt příponu souborů známých typů a pak klepněte na tlačítko OK.
  6. Přejděte do následujícího umístění, kde jednotka je jednotka, na které je nainstalován systém Windows:
    jednotka:\Windows\System
  7. Pravým tlačítkem klepněte na soubor v předchozím seznamu a klepněte na příkaz Přejmenovat.
  8. Přejmenujte příponu souboru DLL na .old a stiskněte klávesu ENTER.
  9. Opakováním kroku 7 a 8 přejmenujte postupně všechny soubory DLL v předchozím seznamu, které v počítači naleznete.
Windows 2000 a Windows NT 4.0
  1. Spusťte program Průzkumník Windows.
  2. V nabídce Nástroje klepněte na příkaz Možnosti složky.

    POZNÁMKA: V systému Windows NT 4.0 klepněte v nabídce Zobrazit na příkaz Možnosti.
  3. Klepněte na kartu Zobrazení.
  4. Klepněte na možnost Zobrazovat skryté soubory a složky, zrušte zaškrtnutí políčka Skrýt příponu souborů známých typů a pak klepněte na tlačítko OK.
  5. Přejděte do následujícího umístění, kde jednotka je jednotka, na které je nainstalován systém Windows:
    jednotka:\Winnt\System32
  6. Pravým tlačítkem klepněte na soubor v předchozím seznamu a klepněte na příkaz Přejmenovat.
  7. Přejmenujte příponu souboru DLL na .old a stiskněte klávesu ENTER.
  8. Opakováním kroku 6 a 7 přejmenujte postupně všechny soubory DLL v předchozím seznamu, které v počítači naleznete.

Krok 2: Přejmenování souborů protokolu instalace

Přejmenujte soubory Active Setup Log.txt a Internet Explorer Setup Log.txt, pokud v počítači existují. Chcete-li to provést, postupujte podle kroků v příslušné části.

Windows NT 4.0, Windows 98 a Windows 95
  1. Klepněte na tlačítko Start, přejděte na příkaz Najít a pak klepněte na položku Soubory či složky.
  2. Do pole Název zadejte "Active Setup Log.txt";" IE Setup Log.txt".
  3. V seznamu Kde hledat vyberte položku Tento počítač a klepněte na tlačítko Najít.
  4. V seznamu nalezených položek klepněte pravým tlačítkem na soubor Active Setup Log.txt a klepněte na příkaz Přejmenovat.
  5. Přejmenujte soubor Active Setup Log.txt na oldsetup log.txt a stiskněte klávesu ENTER.
  6. Pravým tlačítkem klepněte na soubor IE Setup Log.txt a klepněte na příkaz Přejmenovat.
  7. Přejmenujte soubor IE Setup Log.txt na oldIE Setup Log.txt a stiskněte klávesu ENTER.
  8. V nabídce Soubor klepněte na příkaz Zavřít.
Windows 2000 a Windows ME
  1. Klepněte na tlačítko Start, přejděte na příkaz Hledat a pak klepněte na položku Soubory či složky.
  2. Do pole Vyhledat soubory a složky s názvem zadejte "Active Setup Log.txt";" IE Setup Log.txt".
  3. V seznamu Kde hledat vyberte položku Tento počítač a klepněte na tlačítko Vyhledat.
  4. V podokně Výsledky hledání klepněte pravým tlačítkem myši na soubor Active Setup Log.txt a klepněte na příkaz Přejmenovat.
  5. Přejmenujte soubor Active Setup Log.txt na oldsetup log.txt a stiskněte klávesu ENTER.
  6. Pravým tlačítkem klepněte na soubor IE Setup Log.txt a klepněte na příkaz Přejmenovat.
  7. Přejmenujte soubor IE Setup Log.txt na oldIE Setup Log.txt a stiskněte klávesu ENTER.
  8. V nabídce Soubor klepněte na příkaz Zavřít.

Krok 3: Odebrání složky Windows Update Setup Files

Pokud složka Windows Update Setup Files existuje, odstraňte ji:
  1. Spusťte program Průzkumník Windows a rozbalte složku, ve které je nainstalován systém Windows.
  2. Pravým tlačítkem klepněte na složku Windows Update Setup Files a klepněte na příkaz Odstranit.
  3. V zobrazené zprávě Potvrdit odstranění složky klepněte na tlačítko Ano.
  4. Pokud se zobrazí výzva k potvrzení odebrání souborů nebo složek, klepněte na tlačítko Ano všem.

Krok 4: Odstranění dočasných souborů

Odstraňte obsah složky Temp:
  1. V programu Průzkumník Windows přejděte do složky Temp.
  2. V nabídce Úpravy klepněte na příkaz Vybrat vše.
  3. V nabídce Soubor klepněte na příkaz Odstranit.
  4. Pokud se zobrazí výzva k potvrzení odstranění souboru nebo složky, klepněte na tlačítko Ano.
  5. Ukončete program Průzkumník Windows.
  6. Restartujte počítač.

Krok 5: Úprava registru systému Windows

UPOZORNĚNÍ: Použijete-li Editor registru nesprávně, můžete způsobit vážné problémy, které mohou vyžadovat přeinstalování operačního systému. Společnost Microsoft nemůže zaručit, že problémy vzniklé v důsledku nesprávného použití Editoru registru budete moci vyřešit. Editor registru používáte na vlastní nebezpečí.

  1. Klepněte na tlačítko Start a potom na příkaz Spustit.
  2. Do pole Otevřít zadejte příkaz regedit a potom klepněte na tlačítko OK.
  3. V Editoru registru vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_CURRENT_USER\Software\Microsoft\Active Setup
  4. V nabídce Registr klepněte na příkaz Exportovat soubor registru.
  5. Do pole Název souboru zadejte aktivní nastavení a klepněte na tlačítko Uložit.
  6. V nabídce Úpravy klepněte na příkaz Odstranit.
  7. V zobrazené zprávě Potvrdit odstranění klíče klepněte na tlačítko Ano.
  8. Opakováním kroku 3 až 7 vyexportujte a následně odstraňte všechny tyto klíče registru:
    • HKEY_CURRENT_USER\SOFTARE\Microsoft\Internet Explorer
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

Krok 6: Ověření nastavení registru pro složku Program Files

Ověřte, že hodnoty registru ProgramFilesDir a ProgramFilesPath odkazují na správné umístění složky Program Files:
  1. V Editoru registru vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
  2. V pravém podokně okna Editor registru poklepejte na položku ProgramFilesDir.
  3. Pokud v poli Údaj hodnoty není uvedena správná cesta ke složce Program Files, zadejte správnou cestu. Zadejte například C:\Program Files.
  4. Klepněte na tlačítko OK.
  5. Poklepejte na položku ProgramFilesPath.
  6. Pokud v poli Údaj hodnoty není uvedena hodnota %Program Files%, zadejte hodnotu %Program Files%.
  7. Klepněte na tlačítko OK.
  8. Ukončete Editor registru.

    POZNÁMKA: Počítač není potřeba restartovat.

Krok 7: Odpojení namapovaných síťových jednotek

Pokud jsou v počítači namapována další písmena jednotek na sdílené položky v síti, odpojte je:
  1. Na ploše poklepejte na ikonu Tento počítač.
  2. Pravým tlačítkem myši klepněte na síťovou jednotku, kterou chcete změnit (jednotka se zobrazí jako ikona jednotky s připojeným síťovým připojením), a klepněte na příkaz Odpojit.

Krok 8: Nahrazení souboru Winhlp32.exe

POZNÁMKA: Přestože tento krok není k odstranění uvedeného problému nutné provádět, můžete se jeho provedením vyhnout při instalaci nebo upgradu aplikace Internet Explorer zobrazení řady chybových zpráv vztahujících se na soubory DLL.

POZNÁMKA: Tento krok platí pouze pro systém Windows 2000 nebo Windows NT 4.0.
  1. Spusťte program Průzkumník Windows a přejděte do následujícího umístění, kde jednotka představuje jednotku, na které je systém Windows nainstalován:
    jednotka:\Winnt
  2. V pravém podokně klepněte pravým tlačítkem na soubor Winhlp32.exe a potom klepněte na příkaz Kopírovat.
  3. Přejděte do následující složky:
    jednotka:\Winnt\System32
  4. V pravém podokně klepněte pravým tlačítkem na soubor Winhlp32.exe a potom klepněte na příkaz Přejmenovat.
  5. Přejmenujte soubor Winhlp32.exe na Winhlp32.old a stiskněte klávesu ENTER.

    Pokud se zobrazí výzva k potvrzení změny přípony názvu souboru, klepněte na tlačítko Ano.
  6. V nabídce Úpravy klepněte na příkaz Vložit.
  7. Ukončete program Průzkumník Windows.

Krok 9: Instalace aplikace Internet Explorer

Pokuste se upgradovat nebo nainstalovat aplikaci Internet Explorer pomocí následujících metod v uvedeném pořadí:
  • Nainstalujte aplikaci Internet Explorer z následujícího webu společnosti Microsoft:
    http://www.microsoft.com/windows/ie_intl/cs/default.mspx
  • Nainstalujte aplikaci Internet Explorer z disku CD-ROM s aplikací Internet Explorer.
  • Zkopírujte instalační soubory aplikace Internet Explorer na místní pevný disk a následně spusťte instalaci z místního pevného disku.
  • Nainstalujte aplikaci Internet Explorer do jiné složky, než jsou tyto výchozí instalační složky:
    jednotka:\Program Files\Plus!\Microsoft Internet

    -nebo-

    jednotka:\Program Files\Internet Explorer
POZNÁMKA: Pokud se pokusíte nainstalovat aplikaci Internet Explorer, zobrazí se pravděpodobně následující chybová zpráva:
Nebyla dokončena instalace předchozího programu.
Před spuštěním instalačního programu aplikace Internet Explorer je třeba počítač restartovat a dokončit předchozí instalaci. Instalační program bude nyní ukončen.
Při řešení problému postupujte takto:
  1. Klepněte na tlačítko Start a potom na příkaz Spustit.
  2. Do pole Otevřít zadejte příkaz regedit a potom klepněte na tlačítko OK.
  3. V Editoru registru vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager
    POZNÁMKA: Tento klíč registru má název Session Manager.
  4. V pravém podokně okna Editor registru klepněte pravým tlačítkem na položku PendingFileRenameOperations a klepněte na příkaz Odstranit.
  5. V zobrazené zprávě Potvrdit odstranění hodnoty klepněte na tlačítko Ano.
  6. V levém podokně okna Editor registru rozbalte podklíč Session Manager.
  7. Pokud je v seznamu uveden podklíč FileRenameOperations, klepněte na něj a následně v pravém podokně odstraňte všechny položky z podklíče FileRenameOperations.
  8. Ukončete Editor registru.
  9. Restartujte instalační program aplikace Internet Explorer.

Další informace

Další informace o velikosti stránkovacího souboru v řadičích domén systému Windows 2000 získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
216899 Doporučené metody pro nastavení řadiče domény systému Windows 2000 (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
Další informace o tom, jak pomocí ovládacího panelu Přidat nebo odebrat programy odebrat aplikaci Internet Explorer v systému Windows 2000, získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
265829 Po instalaci aplikace Internet Explorer 5.5 do systému Windows 2000 nefunguje panel Přidat nebo odebrat programy

Vlastnosti

ID článku: 303399 - Poslední aktualizace: 13. října 2006 - Revize: 5.1
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • 128bitová verze aplikace Microsoft Internet Explorer 4.0
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 6.0 na těchto platformách
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
Klíčová slova: 
kbupgrade kbenv kbsetup kbprb KB303399

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com