Nie można dokończyć instalowania lub uaktualniania programu Internet Explorer

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 303399 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
WAŻNE: Ten artykuł zawiera informacje na temat modyfikowania rejestru. Przed edycją rejestru należy utworzyć jego kopię zapasową i upewnić się, że zna się metodę przywracania rejestru w przypadku pojawienia się problemu. Aby uzyskać informacje dotyczące wykonywania kopii zapasowej, przywracania i edytowania rejestru, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
256986 Opis rejestru systemu Microsoft Windows
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Podczas instalowania programu Microsoft Internet Explorer mogą pojawić się następujące problemy:
  • Pojawia się jeden z następujących komunikatów o błędzie:
    Instalator nie mógł pobrać wszystkich wymaganych składników dla tej instalacji.

    Spróbuj uruchomić Instalatora później i wybierz opcję Wznów instalację.
    -lub-
    Instalator nie mógł zainstalować wszystkich składników. Zamknij wszystkie aplikacje i spróbuj ponownie uruchomić Instalatora.
    -lub-
    Instalator nie mógł pobrać wszystkich wymaganych składników dla tej instalacji.
  • Komputer przestaje odpowiadać (zawiesza się) podczas instalacji.

Rozwiązanie

Aby rozwiązać ten problem, użyj następujących metod w kolejności ich przedstawienia.
UWAGA: Ponieważ istnieje wiele wersji systemu Microsoft Windows, poniższe kroki mogą wyglądać inaczej na różnych komputerach. W razie wątpliwości należy odwołać się do dokumentacji posiadanego produktu.

Metoda 1: Weryfikacja konfiguracji systemu Windows

  1. W systemie Microsoft Windows 2000 lub Microsoft Windows NT 4.0 należy zalogować się do komputera jako administrator.
  2. Zainstaluj najnowszy dodatek Service Pack dla systemu operacyjnego.

    Aby uzyskać dodatkowe informacje o tym, jak uzyskać dodatek Service Pack 6 (SP6) dla systemu Windows NT 4.0, odwiedź następującą witrynę firmy Microsoft w sieci Web:
    http://www.microsoft.com/ntserver/nts/downloads/recommended/SP6/allSP6.asp
    Aby uzyskać dodatkowe informacje o tym, jak uzyskać dodatek Service Pack 2 (SP2) dla systemu Windows 2000, odwiedź następującą witrynę firmy Microsoft w sieci Web:
    http://www.microsoft.com/windows2000/downloads/servicepacks/sp2/default.mspx
  3. Zamknij wszystkie uruchomione programy, w tym także programy antywirusowe.
Spróbuj uaktualnić lub zainstalować program Internet Explorer. Jeśli to się nie uda, przejdź do następnej metody.

Metoda 2: Ograniczenie pojemności pamięci RAM do 256 MB

Jeśli w komputerze jest zainstalowane więcej niż 256 MB pamięci RAM, zmniejsz pamięć wykorzystywaną przez system Windows do 256 MB lub mniej.

Microsoft Windows 95

W systemie Windows 95 można użyć dysku RAM, aby ograniczyć ilość pamięci RAM, która jest dostępna dla systemu Windows.

Aby uzyskać dodatkowe informacje o tym, jak ograniczyć dostępną pojemność pamięci za pomocą dysku RAM, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
142546 How to use a RAM drive to troubleshoot memory

Microsoft Windows Millennium Edition (Me) lub Microsoft Windows 98

Jeśli używasz systemu Windows Me, Windows 98 Wydanie drugie lub Windows 98, użyj narzędzia konfiguracji systemu, aby ograniczyć ilość pamięci RAM dostępną dla systemu Windows:
  1. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  2. W polu Otwórz wpisz polecenie msconfig, a następnie kliknij przycisk OK.
  3. Kliknij przycisk Zaawansowane, a następnie kliknij pole wyboru Ograniczaj pamięć do, aby je zaznaczyć.
  4. W polu MB wpisz ilość pamięci, jaka ma być dostępna dla systemu Windows, na przykład 256.
  5. Kliknij dwa razy przycisk OK, a następnie kliknij przycisk Tak, aby ponownie uruchomić komputer.

Windows 2000 lub Windows NT 4.0

Jeśli używasz systemu Windows 2000 lub Windows NT 4.0, edytuj plik Boot.ini, aby ograniczyć ilość pamięci dostępną dla systemu Windows. Dodaj następujący przełącznik do ścieżki ARC w sekcji [Operating System] pliku Boot.ini, gdzie ilość RAM jest pamięcią RAM, która ma być dostępna dla systemu Windows.
/MAXMEM=ilość RAM
Na przykład następująca ścieżka ARC ogranicza ilość pamięci dostępnej dla systemu Windows do 256 MB:
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Server"  /fastdetect /MAXMEM=256
				
UWAGA: Plik Boot.ini jest plikiem ukrytym znajdującym się w folderze głównym dysku startowego.

Aby edytować plik Boot.ini, użyj następującej procedury.

Ostrzeżenie: Jeśli plik Boot.ini zostanie zmieniony w sposób niepoprawny, system Windows może przestać działać.
  1. Zaloguj się do systemu Windows NT 4.0 lub Windows 2000 jako administrator.
  2. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  3. W polu Otwórz wpisz polecenie cmd, a następnie kliknij przycisk OK.
  4. Przejdź do folderu głównego partycji startowej. Na przykład wpisz nazwę cd\, jeśli nie używasz konfiguracji z wieloma opcjami rozruchu.
  5. Wpisz polecenie attrib -a -h -s boot.ini, a następnie naciśnij klawisz ENTER.
  6. Wpisz polecenie copy boot.ini boot.old.

    UWAGA: Jeśli polecenie to zostanie uruchomione, system Windows utworzy kopię zapasową pliku Boot.ini i nazwie ją „Boot.old”.
  7. Wpisz polecenie edit boot.ini, a następnie naciśnij klawisz ENTER.
  8. Naciskając klawisze strzałek, przejdź w sekcji [operating systems] do końca ścieżki ARC, którą chcesz zmienić.
  9. Wpisz polecenie /MAXMEM=256.
  10. Naciśnij klawisz Alt+F, a następnie naciśnij S.
  11. Naciśnij klawisze ALT + F, a następnie klawisz X.
  12. Wpisz polecenie attrib +a +s +h boot.ini, a następnie naciśnij klawisz ENTER.
  13. Wpisz polecenie exit, a następnie naciśnij klawisz ENTER.
  14. Ponownie uruchom komputer.
Spróbuj uaktualnić lub zainstalować program Internet Explorer. Jeśli to się nie uda, przejdź do następnej metody.

Metoda 3: Weryfikacja rozmiaru i lokalizacji pliku wymiany

Zweryfikuj, czy komputer zawiera plik wymiany i czy jego rozmiar przekracza ilość pamięci RAM zainstalowanej aktualnie w komputerze. Jeśli to możliwe, przenieś plik wymiany na inną partycję w komputerze. Aby zweryfikować ustawienia pliku wymiany, wykonaj kroki podane w odpowiedniej sekcji.

Windows Me, Windows 98 i Windows 95

  1. Kliknij przycisk Start, wskaż polecenie Ustawienia, kliknij polecenie Panel sterowania, a następnie kliknij dwukrotnie ikonę System.
  2. Kliknij kartę Wydajność, zanotuj ilość pamięci RAM zainstalowanej w komputerze, która jest podana obok pola Pamięć, a następnie kliknij przycisk Pamięć wirtualna.
    • Jeśli zaznaczone jest pole wyboru Pozwól systemowi Windows ustawić parametry pamięci wirtualnej (zalecane), plik wymiany znajduje się na tym samym dysku co system Windows i to system Windows określa rozmiar pliku wymiany.
    • Jeśli zaznaczone jest pole wyboru Pozwól mi określić własne parametry pamięci wirtualnej, dysk pliku wymiany jest podany w polu Dysk twardy.
  3. Jeśli pole wyboru Pozwól mi określić własne parametry pamięci wirtualnej nie jest zaznaczone, kliknij je.
  4. W polu Dysk twardy wybierz inną partycję niż ta, na której jest zainstalowany system Windows (jeżeli jest dostępna inna partycja).
  5. W polu Minimum wybierz lub wpisz wartość przekraczającą ilość pamięci RAM zainstalowanej w komputerze.
  6. W polu Maksimum wpisz lub wybierz wartość, która jest przynajmniej równa wartości podanej w polu Minimum.
  7. Kliknij przycisk OK, a następnie kliknij przycisk Tak, gdy zostanie wyświetlony komunikat Potwierdź ustawienia pamięci wirtualnej.
  8. Kliknij przycisk Zamknij, a po wyświetleniu monitu o ponowne uruchomienie komputera kliknij przycisk Tak.

Windows 2000 i Windows NT 4.0

  1. Zaloguj się do komputera jako administrator.
  2. Kliknij przycisk Start, wskaż polecenie Ustawienia, kliknij polecenie Panel sterowania, a następnie kliknij dwukrotnie ikonę System.
  3. Zanotuj ilość pamięci RAM podaną w obszarze Komputer.
  4. Kliknij kartę Zaawansowane, a następnie kliknij przycisk Opcje wydajności.

    UWAGA: W systemie Windows NT 4.0 należy kliknąć kartę Wydajność.
  5. W obszarze Pamięć wirtualna kliknij przycisk Zmień.
  6. W obszarze Całkowity rozmiar pliku stronicowania dla wszystkich dysków zanotuj rozmiar pliku stronicowania podany obok pola Aktualnie przydzielono.
    • Aby zmienić rozmiar pliku stronicowania, wykonaj następujące kroki:
      1. W polu Rozmiar początkowy (MB) wpisz wartość, która jest co najmniej o 12 MB większa niż ilość pamięci RAM zainstalowanej w komputerze.
      2. W polu Rozmiar maksymalny (MB) wpisz rozmiar maksymalny, którego nie może przekroczyć plik stronicowania, a następnie kliknij przycisk Ustaw.
    • Aby przenieść plik stronicowania na inną partycję, wykonaj następujące kroki:
      1. Na liście Dysk [Etykieta woluminu] kliknij partycję, na którą chcesz przenieść plik stronicowania.
      2. W polu Rozmiar początkowy (MB) wpisz wartość, która jest co najmniej o 12 MB większa niż ilość pamięci RAM zainstalowanej w komputerze.
      3. W polu Rozmiar maksymalny (MB) wpisz rozmiar maksymalny, którego nie może przekroczyć plik stronicowania, a następnie kliknij przycisk Ustaw.
      4. Na liście Dysk [Etykieta woluminu] kliknij partycję, na której jest zainstalowany system Windows.
      5. W polu Rozmiar początkowy (MB) wpisz 0.
      6. W polu Rozmiar maksymalny (MB) wpisz 0, a następnie kliknij przycisk Ustaw.
      7. Gdy zostanie wyświetlony komunikat apletu System w Panelu sterowania, kliknij przycisk Tak, aby potwierdzić ustawienie pliku stronicowania mniejsze niż pamięć RAM zainstalowana w komputerze.
  7. Kliknij przycisk OK.

    Jeśli pojawi się następujący komunikat, kliknij przycisk OK:
    Aby wprowadzone zmiany zaczęły obowiązywać, konieczne jest ponowne uruchomienie komputera.
  8. Kliknij dwa razy przycisk OK, a następnie kliknij przycisk Tak, aby ponownie uruchomić komputer.
Spróbuj uaktualnić lub zainstalować program Internet Explorer. Jeśli to się nie uda, przejdź do następnej metody.

Metoda 4: Usunięcie programów antywirusowych

  1. Kliknij przycisk Start, wskaż polecenie Ustawienia, kliknij polecenie Panel sterowania, a następnie kliknij ikonę Dodaj/Usuń programy.
  2. Kliknij program antywirusowy, a następnie kliknij przycisk Dodaj/Usuń.

    UWAGA: W systemie Windows 2000 należy kliknąć przycisk Usuń.
  3. Postępuj zgodnie z instrukcjami, aby całkowicie usunąć program antywirusowy, a następnie ponownie uruchom komputer.
Spróbuj uaktualnić lub zainstalować program Internet Explorer. Jeśli to się nie uda, przejdź do następnej metody.

Metoda 5: Usunięcie składników programu Internet Explorer

Usuń uaktualnienia programu Internet Explorer i wszystkie następujące dodatkowe składniki programu Internet Explorer:
  • Microsoft Outlook Express
  • Microsoft Netmeeting
  • Microsoft Wallet
  • Microsoft Active Movie
  • Microsoft Netshow
  • Microsoft Chat
  • Internet Mail and News
  • Microsoft VRML Player
  • VDOLive Player
  • Microsoft FrontPage Express
  • Microsoft Internet Explorer Access Kit (IEAK)
Aby to zrobić, wykonaj następujące czynności:
  1. Kliknij przycisk Start, wskaż polecenie Ustawienia, kliknij polecenie Panel sterowania, a następnie kliknij ikonę Dodaj/Usuń programy.
  2. Kliknij pozycję programu Internet Explorer, którą chcesz usunąć, a następnie kliknij przycisk Dodaj/Usuń.

    UWAGA: W systemie Windows 2000 należy kliknąć przycisk Usuń.
  3. Postępuj zgodnie z wyświetlanymi instrukcjami, aby całkowicie usunąć program Internet Explorer i związane z nim składniki.

    UWAGA: Jeśli będą wyświetlane monity o usunięcie plików współużytkowanych, nie usuwaj ich.
  4. W systemie Windows NT 4.0 zastosuj ponownie najnowszy dodatek Service Pack.

    Aby uzyskać dodatkowe informacje dotyczące najnowszych dodatków Service Pack dla systemu Windows NT, odwiedź następującą witrynę sieci Web:
    http://www.microsoft.com/ntserver/nts/downloads/recommended/SP6/allSP6.asp
  5. Ponownie uruchom komputer.
Spróbuj uaktualnić lub zainstalować program Internet Explorer. Jeśli to się nie uda, przejdź do następnej metody.

Metoda 6: Usunięcie plików i ustawień

Krok 1: Zmiana nazw plików DLL

Zmień nazwy następujących plików DLL:
Actxprxy.dll
Advpack.dll
Comcat.dll
Inseng.dll
Jobexec.dll
Url.dll
Urlmon.dll
Wininet.dll
Wintrust.dll
W tym celu wykonaj procedurę w odpowiedniej sekcji.

UWAGA: Nie wszystkie z tych plików muszą znajdować się na komputerze.

Ostrzeżenie: Nie należy usuwać pliku Wintrust.dll.

Windows Me, Windows 98 i Windows 95
  1. Uruchom system Windows w trybie awaryjnym Aby uzyskać dodatkowe informacje dotyczące uruchamiania systemu Windows w trybie awaryjnym, kliknij następujące numer artykułów w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:
    180902 Jak uruchomić komputer z systemem Windows w trybie awaryjnym
    122051 How Windows 95 performs a safe-mode start
  2. Uruchom Eksploratora Windows.
  3. W menu Narzędzia kliknij polecenie Opcje folderów.
  4. Kliknij kartę Widok.
  5. Kliknij pole wyboru Pokazuj ukryte pliki i foldery, kliknij pole wyboru Ukryj rozszerzenia plików znanych typów, aby je wyczyścić, a następnie kliknij przycisk OK.
  6. Przejdź do następującej lokalizacji, gdzie dysk jest dyskiem, na którym jest zainstalowany system Windows:
    dysk:\Windows\System
  7. Kliknij prawym przyciskiem myszy jeden z plików wymienionych na powyższej liście, a następnie kliknij polecenie Zmień nazwę.
  8. Zmień rozszerzenie nazwy pliku dll na old, a następnie naciśnij klawisz ENTER.
  9. Wykonaj kroki 7 i 8 tyle razy, aby zmienić rozszerzenia wszystkich plików DLL wymienionych na liście, które znajdują się na komputerze.
Windows 2000 i Windows NT 4.0
  1. Uruchom Eksploratora Windows.
  2. Kliknij polecenie Opcje folderów w menu Narzędzia.

    UWAGA: W systemie Windows NT 4.0 należy kliknąć kartę Opcje w menu Widok.
  3. Kliknij kartę Widok.
  4. Kliknij pole wyboru Pokazuj ukryte pliki i foldery, kliknij pole wyboru Ukryj rozszerzenia plików znanych typów, aby je wyczyścić, a następnie kliknij przycisk OK.
  5. Przejdź do następującej lokalizacji, gdzie dysk jest dyskiem, na którym jest zainstalowany system Windows:
    dysk:\Winnt\System32
  6. Kliknij prawym przyciskiem myszy jeden z plików wymienionych na powyższej liście, a następnie kliknij polecenie Zmień nazwę.
  7. Zmień rozszerzenie nazwy pliku dll na old, a następnie naciśnij klawisz ENTER.
  8. Wykonaj kroki 6 i 7 tyle razy, aby zmienić rozszerzenia wszystkich plików DLL wymienionych na liście, które znajdują się na komputerze.

Krok 2: Zmiana nazw plików dziennika Instalatora

Jeśli istnieją pliki Active Setup Log.txt i Internet Explorer Setup Log.txt, zmień ich nazwy. W tym celu wykonaj procedurę w odpowiedniej sekcji.

System Windows NT 4.0/Windows 98:
  1. Kliknij przycisk Start, wskaż polecenie Znajdź, a następnie kliknij polecenie Pliki lub foldery.
  2. W polu Nazwa wpisz tekst "Active Setup Log.txt";" IE Setup Log.txt".
  3. Na liście Szukaj w wybierz pozycję Mój komputer, a następnie kliknij przycisk Znajdź teraz.
  4. Na liście znalezionych pozycji kliknij prawym przyciskiem myszy plik Active Setup Log.txt, a następnie kliknij polecenie Zmień nazwę.
  5. Zmień nazwę pliku Active Setup Log.txt na oldsetup log.txt, a następnie naciśnij klawisz ENTER.
  6. Kliknij prawym przyciskiem myszy plik IE Setup Log.txt, a następnie kliknij polecenie Zmień nazwę.
  7. Zmień nazwę pliku IE Setup Log.txt na oldIE Setup Log.txt, a następnie naciśnij klawisz ENTER.
  8. W menu Plik kliknij polecenie Zamknij.
Windows 2000 i Windows Me
  1. Kliknij przycisk Start, wskaż polecenie Wyszukaj, a następnie kliknij polecenie Pliki lub foldery.
  2. W polu Wyszukaj pliki i foldery o nazwie wpisz "Active Setup Log.txt";" IE Setup Log.txt".
  3. Na liście Szukaj w wybierz opcję Mój komputer, a następnie kliknij przycisk Wyszukaj teraz.
  4. W okienku Wyniki wyszukiwania kliknij prawym przyciskiem myszy plik Active Setup Log.txt, a następnie kliknij polecenie Zmień nazwę.
  5. Zmień nazwę pliku Active Setup Log.txt na oldsetup log.txt, a następnie naciśnij klawisz ENTER.
  6. Kliknij prawym przyciskiem myszy plik IE Setup Log.txt, a następnie kliknij polecenie Zmień nazwę.
  7. Zmień nazwę pliku IE Setup Log.txt na oldIE Setup Log.txt, a następnie naciśnij klawisz ENTER.
  8. W menu Plik kliknij polecenie Zamknij.

Krok 3: Usuwanie folderu Windows Update Setup Files

Jeśli istnieje folder Windows Update Setup Files, usuń go:
  1. Uruchom Eksploratora Windows, a następnie rozwiń folder, w którym jest zainstalowany system Windows.
  2. Kliknij prawym przyciskiem folder Windows Update Setup Files, a następnie kliknij polecenie Usuń.
  3. W wyświetlonym oknie komunikatu Potwierdzanie usunięcia folderu kliknij przycisk Tak.
  4. Jeżeli pojawi się monit o potwierdzenie usunięcia, kliknij przycisk OK.

Krok 4: Usuwanie plików tymczasowych

Usuń zawartość folderu Temp:
  1. W Eksploratorze Windows przejdź do folderu Temp.
  2. W menu Edycja kliknij polecenie Zaznacz wszystko.
  3. W menu Plik kliknij polecenie Usuń.
  4. Jeśli pojawi się monit o potwierdzenie usunięcia plików lub folderów, kliknij przycisk Tak.
  5. Zamknij Eksploratora Windows.
  6. Ponownie uruchom komputer.

Krok 5: Edytowanie rejestru systemu Windows

OSTRZEŻENIE: Nieprawidłowe korzystanie z Edytora rejestru może stać się przyczyną poważnych problemów, które spowodują, że konieczna będzie ponowna instalacja systemu operacyjnego. Firma Microsoft nie może zagwarantować, że rozwiązanie problemów spowodowanych niepoprawnym użyciem Edytora rejestru będzie możliwe. Używanie Edytora rejestru odbywa się na własną odpowiedzialność.

  1. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  2. W polu Otwórz wpisz polecenie regedit, a następnie kliknij przycisk OK.
  3. W Edytorze rejestru odszukaj i kliknij następujący podklucz rejestru:
    HKEY_CURRENT_USER\Software\Microsoft\Active Setup
  4. W menu Rejestr kliknij polecenie Eksportuj plik Rejestru.
  5. W polu Nazwa pliku wpisz active setup, a następnie kliknij przycisk Zapisz.
  6. W menu Edycja kliknij polecenie Usuń.
  7. W wyświetlonym komunikacie Potwierdzanie usunięcia klucza kliknij przycisk Tak.
  8. Wykonaj kroki od 3 do 7, aby wyeksportować, a następnie usunąć następujące klucze rejestru:
    • HKEY_CURRENT_USER\SOFTARE\Microsoft\Internet Explorer
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

Krok 6: Weryfikacja ustawień rejestru dla folderu Program Files

Zweryfikuj, czy wartości rejestru ProgramFilesDir i ProgramFilesPath wskazują na poprawną lokalizację folderu Program Files:
  1. W Edytorze rejestru odszukaj i kliknij następujący podklucz rejestru:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
  2. W prawym okienku okna Edytor rejestru kliknij dwukrotnie pozycję ProgramFilesDir.
  3. Jeśli w polu Dane wartości nie jest podana poprawna ścieżka folderu Program Files, wpisz poprawną ścieżkę folderu Program Files. Na przykład wpisz nazwę C:\Program Files.
  4. Kliknij przycisk OK.
  5. Kliknij dwukrotnie pozycję ProgramFilesPath.
  6. Jeśli tekst %Program Files% nie jest wyświetlany w polu Dane wartości, wpisz tekst %Program Files%.
  7. Kliknij przycisk OK.
  8. Zamknij Edytor rejestru.

    UWAGA: W tym momencie nie uruchamiaj ponownie komputera.

Krok 7: Odłączenie zamapowanych dysków sieciowych

Jeśli litery dysków komputera zostały zamapowane na udziały sieciowe, odłącz je:
  1. Na pulpicie kliknij dwukrotnie ikonę Mój komputer.
  2. Kliknij prawym przyciskiem myszy dysk sieciowy, który chcesz zmienić (dysk jest wyświetlany jako ikona dysku z podłączonym połączeniem sieciowym), a następnie kliknij polecenie Odłącz.

Krok 8: Zastąpienie pliku Winhlp32.exe

UWAGA: Chociaż wykonanie tego kroku może nie mieć wpływu na rozwiązanie tego problemu, to dzięki niemu podczas instalowania lub uaktualniania programu Internet Explorer nie będą wyświetlane liczne komunikaty związane z plikami DLL.

UWAGA: Ten krok dotyczy tylko systemów Windows 2000 lub Windows NT 4.0.
  1. W Eksploratorze Windows przejdź do następującej lokalizacji, gdzie dysk jest dyskiem, na którym jest zainstalowany system Windows:
    dysk:\Winnt
  2. W prawym okienku kliknij prawym przyciskiem myszy plik Winhlp32.exe, a następnie kliknij polecenie Kopiuj.
  3. Przejdź do następującego folderu:
    dysk:\Winnt\System32
  4. W prawym okienku kliknij prawym przyciskiem myszy plik Winhlp32.exe, a następnie kliknij polecenie Zmień nazwę.
  5. Zmień nazwę pliku Winhlp32.exe na Winhlp32.old, a następnie naciśnij klawisz ENTER.

    Jeśli pojawi się monit o potwierdzenie zmiany rozszerzenia nazwy pliku, kliknij przycisk Tak.
  6. W menu Edycja kliknij polecenie Wklej.
  7. Zamknij Eksploratora Windows.

Krok 9: Zainstalowanie programu Internet Explorer

Spróbuj uaktualnić lub zainstalować program Internet Explorer, używając następujących metod w kolejności, w jakiej są przedstawione:
  • Zainstaluj program Internet Explorer z następującej witryny firmy Microsoft w sieci Web:
    http://www.microsoft.com/windows/ie_intl/pl/default.mspx
  • Zainstaluj program Internet Explorer z dysku CD z programem Internet Explorer.
  • Skopiuj pliki instalacyjne programu Internet Explorer na dysk twardy, a następnie uruchom Instalatora z lokalnego dysku twardego.
  • Zainstaluj program Internet Explorer w innym folderze niż domyślne foldery instalacyjne:
    dysk:\Program Files\Plus!\Microsoft Internet

    - lub -

    dysk:\Program Files\Internet Explorer
UWAGA: Podczas instalowania programu Internet Explorer może pojawić się następujący komunikat o błędzie:
Instalacja poprzedniego programu nie została nigdy ukończona.
Należy ponownie uruchomić komputer, aby zakończyć tę instalację przed uruchomieniem Instalatora programu Internet Explorer. Instalator zakończy teraz działanie.
Aby rozwiązać ten problem, wykonaj następujące kroki:
  1. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  2. W polu Otwórz wpisz polecenie regedit, a następnie kliknij przycisk OK.
  3. W Edytorze rejestru odszukaj i kliknij następujący podklucz rejestru:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager
    UWAGA: W tym kluczu rejestru Session Manager to dwa wyrazy.
  4. W prawym okienku Edytora rejestru kliknij prawym przyciskiem myszy pozycję PendingFileRenameOperations, a następnie kliknij polecenie Usuń.
  5. W wyświetlonym komunikacie Potwierdzanie usunięcia wartości kliknij przycisk Tak.
  6. W lewym okienku Edytora rejestru rozwiń podklucz Session Manager.
  7. Jeśli na liście figuruje podklucz FileRenameOperations, kliknij go, a następnie usuń wszystkie pozycje z podklucza FileRenameOperations w prawym okienku.
  8. Zamknij Edytor rejestru.
  9. Uruchom ponownie Instalatora programu Internet Explorer.

Więcej informacji

Aby uzyskać dodatkowe informacje dotyczące rozmiaru pliku stronicowania na kontrolerach domen systemu Windows 2000, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
216899 Najważniejsze wskazówki dotyczące metod instalacji kontrolera domeny systemu Windows 2000
Aby uzyskać dodatkowe informacje dotyczące sposobu usuwania programu Internet Explorer w systemie Windows 2000 za pomocą apletu Dodaj/Usuń programy w panelu sterowania, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
265829 Add\Remove Programs tool may not work after installing Internet Explorer 5.5 or Internet Explorer 6 on Windows 2000

Właściwości

Numer ID artykułu: 303399 - Ostatnia weryfikacja: 15 września 2006 - Weryfikacja: 5.3
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.0 (128-bitowy)
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 6.0 na następujących platformach
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
Słowa kluczowe: 
kbupgrade kbenv kbsetup kbprb KB303399

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com