Article ID: 303487 - Last Review: October 27, 2007 - Revision: 3.10

"XML Page Cannot Be Displayed" Error Message When You Open An XML File Attachment in E-Mail

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This article was previously published under Q303487
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SYMPTOMS

When you attempt to open an Extensible Markup Language (XML) document attached to an e-mail message, you may receive the following error message in a Microsoft Internet Explorer browser window:
The XML page cannot be displayed.

Cannot view XML input using style sheet. Please correct the error and then click the Refresh button, or try again later.

Access is denied.

CAUSE

This behavior occurs if both of the following conditions are true:
  • The .xml file is attached to a Microsoft Outlook or Microsoft Outlook Express e-mail message.

    -and-
  • You attempt to open the .xml file attachment either by double-clicking the attachment or by right-clicking the attachment and then clicking Open.
When you open an attachment in an HTML or XML-formatted mail message, the attachment is placed in the Temporary Internet Files folder on your computer's hard disk, and Internet Explorer opens the file from this location. Internet Explorer is unable to load .xml files from the Temporary Internet Files folder, and as a result, when you attempt to open an .xml file attachment from an Outlook or Outlook Express e-mail message, you receive the message described in the "Symptoms" section of this article.

WORKAROUND

To work around this issue, save the .xml file attachment to another location on your hard disk, and then open the file from this location. To do this, follow these steps:
  1. Start Outlook or Outlook Express, and then open the message that contains the .xml file attachment that you want to open.
  2. For Outlook, Right-click the attachment, and then click Save As. For Outlook Express, on the File menu, click Save Attachments.
  3. In the Save Attachment dialog box for Outlook, or in the Save Attachment As dialog box for Outlook Express, specify a name and a location in which to save the file, and then click Save.
  4. Close the message window.
  5. Start Windows Explorer, and then locate the .xml file that you saved in step 3.
  6. Double-click the file to open it.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The Temporary Internet Files folder (Internet Explorer cache) is the location on your hard disk in which Web pages and other files, such as graphics, are stored as you view them. This feature speeds up the display of pages that you frequently visit or have already viewed, because Internet Explorer can access and open them from your hard disk instead of from the Web.

APPLIES TO
  • Microsoft Outlook Express 5.5 Service Pack 2
  • Microsoft Outlook Express 5.01 Service Pack 1
  • Microsoft Outlook Express 5.0
  • Microsoft Outlook Express 5.5 Service Pack 1
  • Microsoft Outlook Express 5.5 Service Pack 2
  • Microsoft Outlook Express 5.5 Service Pack 1
  • Microsoft Outlook Express 5.5 Service Pack 2
  • Microsoft Outlook Express 5.01 Service Pack 1
  • Microsoft Outlook Express 5.0
  • Microsoft Outlook Express 5.5 Service Pack 1
  • Microsoft Outlook Express 5.5 Service Pack 2
  • Microsoft Outlook Express 5.01 Service Pack 1
  • Microsoft Outlook Express 5.0
  • Microsoft Outlook Express 5.5 Service Pack 1
  • Microsoft Outlook Express 5.5 Service Pack 2
  • Microsoft Outlook Express 5.01 Service Pack 1
  • Microsoft Outlook Express 5.0
  • Microsoft Outlook Express 5.5 Service Pack 1
  • Microsoft Outlook Express 5.5 Service Pack 2
  • Microsoft Outlook Express 5.01 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows XP Professional x64 Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
  • Windows Internet Explorer 7
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 for Windows Server 2003 IA64
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