PowerPoint 2002- tai Office PowerPoint 2003 -esityksen luominen ja näyttäminen automaation avulla käytettäessä Visual Basic .NET 2002:ta tai Visual Basic .NET 2003:a

Artikkeleiden käännökset Artikkeleiden käännökset
Artikkelin tunnus: 303717 - Näytä tuotteet, joita tämä artikkeli koskee.
Tämän artikkelin Microsoft Visual C# .NET -versio on 303718 (tämä artikkeli saattaa olla englanninkielinen).
Tämän artikkelin Microsoft Visual C++ .NET -versio on 308336 (tämä artikkeli saattaa olla englanninkielinen).
Laajenna kaikki | Kutista kaikki

Tällä sivulla

Yhteenveto

Tässä artikkelissa kuvataan, miten PowerPoint 2002- tai Office PowerPoint 2003 -esitys luodaan ja näytetään automaation avulla käytettäessä Microsoft Visual Basic .NET 2002:ta tai Visual Basic .NET 2003:a.

Enemmän tietoa

Microsoft PowerPoint 2002:n ja Microsoft Office PowerPoint 2003:n automaatioasiakkaan luominen

  1. Käynnistä Microsoft Visual Studio .NET 2002 tai Visual Studio .NET 2003. Valitse File-valikosta New ja valitse sitten Project. Valitse Visual Basic -projektilajeista Windows Application. Form1 luodaan oletusarvon mukaan.
  2. Lisää Microsoft PowerPoint Object Library- ja Microsoft Graph Object Library -viittaukset. Voit tehdä tämän seuraavasti:
    1. Valitse Project-valikosta Add Reference.
    2. Etsi COM-välilehdessä Microsoft PowerPoint Object Library ja valitse sitten Select. Etsi myös Microsoft Graph Object Library ja valitse sitten Select.

      Huomautus: Microsoft Office 2003 sisältää PIA (Primary Interop Assembly) -kokoonpanot. Microsoft Office XP ei sisällä PIA-kokoonpanoja, mutta ne voidaan ladata. Saat lisätietoja artikkelista Office XP:n PIA-kokoonpanoista napsauttamalla seuraavaa artikkelin numeroa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:
      328912 Microsoft Office XP:n PIA-kokoonpanot ovat ladattavissa (tämä artikkeli saattaa olla englanninkielinen)
    3. Hyväksy tekemäsi valinnat valitsemalla Add References -valintaikkunassa OK.
  3. Tuo Toolbox näyttöön valitsemalla View-valikosta Toolbox ja lisää painike Form1-lomakkeeseen.
  4. Kaksoisnapsauta Button1. Lomakkeen koodi-ikkuna tulee näyttöön.
  5. Etsi koodi-ikkunassa seuraava koodi:
        Private Sub Button1_Click(ByVal sender As System.Object, _
            ByVal e As System.EventArgs) Handles Button1.Click
    
        End Sub
    					
    Korvaa se seuraavalla koodilla:
        Private Sub Button1_Click(ByVal sender As System.Object, _
            ByVal e As System.EventArgs) Handles Button1.Click
    
            Const sTemplate = _
               "C:\Program Files\Microsoft Office\Templates\Presentation Designs\Blends.pot"
            Const sPic = "C:\WINNT\Soap Bubbles.bmp"
    
            Dim oApp As PowerPoint.Application
            Dim oPres As PowerPoint.Presentation
            Dim oSlide As PowerPoint.Slide
            Dim bAssistantOn As Boolean
    
            'Käynnistä Powerpoint ja tee sen ikkunasta näkyvä mutta pienennetty.
            oApp = New PowerPoint.Application()
            oApp.Visible = True
            oApp.WindowState = PowerPoint.PpWindowState.ppWindowMinimized
    
            'Luo uusi esitys määritetyn mallin pohjalta.
            oPres = oApp.Presentations.Open(sTemplate, , , True)
    
            'Muodosta dia 1:
            'Lisää diaan tekstiä, muuta fonttia ja lisää/sijoita kuvana
            'ensimmäiseen diaan.
            oSlide = oPres.Slides.Add(1, PowerPoint.PpSlideLayout.ppLayoutTitleOnly)
            With oSlide.Shapes.Item(1).TextFrame.TextRange
                .Text = "Oma malliesitys"
                .Font.Name = "Comic Sans MS"
                .Font.Size = 48
            End With
            oSlide.Shapes.AddPicture(sPic, False, True, 150, 150, 500, 350)
            oSlide = Nothing
    
            'Muodosta dia 2:
            'Lisää dian otsikkoon tekstiä ja muotoile teksti. Lisää myös kaavio
            'diaan ja muuta kaavion lajiksi kolmiulotteinen ympyräkaavio.
            oSlide = oPres.Slides.Add(2, PowerPoint.PpSlideLayout.ppLayoutTitleOnly)
            With oSlide.Shapes.Item(1).TextFrame.TextRange
                .Text = "Oma kaavio"
                .Font.Name = "Comic Sans MS"
                .Font.Size = 48
            End With
            Dim oChart As Graph.Chart
            oChart = oSlide.Shapes.AddOLEObject(150, 150, 480, 320, _
                        "MSGraph.Chart.8").OLEFormat.Object
            oChart.ChartType = Graph.XlChartType.xl3DPie
            oChart = Nothing
            oSlide = Nothing
    
            'Muodosta dia 3:
            'Lisää diaan tekstitehoste ja käytä tekstitehosteeseen varjostuksia.
            oSlide = oPres.Slides.Add(3, PowerPoint.PpSlideLayout.ppLayoutBlank)
            oSlide.FollowMasterBackground = False
            Dim oShape As PowerPoint.Shape
            oShape = oSlide.Shapes.AddTextEffect(Office.MsoPresetTextEffect.msoTextEffect27, _
                "The End", "Impact", 96, False, False, 230, 200)
            oShape.Shadow.ForeColor.SchemeColor = PowerPoint.PpColorSchemeIndex.ppForeground
            oShape.Shadow.Visible = True
            oShape.Shadow.OffsetX = 3
            oShape.Shadow.OffsetY = 3
            oShape = Nothing
            oSlide = Nothing
    
            'Muokkaa diaesityksen siirtymisasetuksia kaikille kolmelle
            'esityksen dialle.
            Dim SlideIdx(3) As Integer
            SlideIdx(0) = 1
            SlideIdx(1) = 2
            SlideIdx(2) = 3
            With oPres.Slides.Range(SlideIdx).SlideShowTransition
                .AdvanceOnTime = True
                .AdvanceTime = 3
                .EntryEffect = PowerPoint.PpEntryEffect.ppEffectBoxOut
            End With
            Dim oSettings As PowerPoint.SlideShowSettings
            oSettings = oPres.SlideShowSettings
            oSettings.StartingSlide = 1
            oSettings.EndingSlide = 3
    
            'Estä Office-avustajaa näyttämästä varoitussanomia.
            bAssistantOn = oApp.Assistant.On
            oApp.Assistant.On = False
    
            'Suorita diaesitys ja odota sen päättymistä.
            oSettings.Run()
            Do While oApp.SlideShowWindows.Count >= 1
                System.Windows.Forms.Application.DoEvents()
            Loop
            oSettings = Nothing
    
            'Ota Office-avustaja jälleen käyttöön, jos se oli käytössä.
            If bAssistantOn Then
                oApp.Assistant.On = True
                oApp.Assistant.Visible = False
            End If
    
            'Sulje esitys tallentamatta muutoksia ja sulje sitten PowerPoint.
            oPres.Saved = True
            oPres.Close()
            oPres = Nothing
            oApp.Quit()
            oApp = Nothing
            GC.Collect()
        End Sub
    					
    Huomautus Tässä koodissa sTemplate- ja sPic-vakiot edustavat PowerPointin mallin ja kuvan (tässä järjestyksessä) täydellistä polkua ja tiedostonimeä. Muokkaa näitä polkuja tarvittaessa, jotta voit käyttää järjestelmääsi asennettua mallia tai kuvaa.
  6. Lisää seuraava koodi Form1.vb:n yläosaan:
    Imports Office = Microsoft.Office.Core
    Imports Graph = Microsoft.Office.Interop.Graph
    					
  7. Muodosta ja suorita ohjelma painamalla F5-näppäintä.
  8. Luo ja näytä PowerPoint-esitys napsauttamalla lomakkeen Button1-painiketta.

Suositukset

Saat lisätietoja seuraavasta Microsoft Developer Networkin (MSDN) Web-sivustosta:
http://msdn.microsoft.com/library/en-us/odc_2003_ta/html/odc_landvsto03_tr.asp
Saat lisätietoja PowerPoint-automaatiosta napsauttamalla seuraavia artikkelien numeroita, jolloin pääset lukemaan artikkelit Microsoft Knowledge Base -tietokannassa:
180616 PowerPoint-esityksen luominen ja näyttäminen MFC:n avulla (tämä artikkeli saattaa olla englanninkielinen)
222929 PowerPointin automatisoiminen Visual Basicin avulla (tämä artikkeli saattaa olla englanninkielinen)

Ominaisuudet

Artikkelin tunnus: 303717 - Viimeisin tarkistus: 17. tammikuuta 2007 - Versio: 8.2
Artikkelin tiedot koskevat seuraavia tuotteita:
  • Microsoft Visual Basic .NET 2003 Standard Edition
  • Microsoft Visual Basic .NET 2002 Standard Edition
  • Microsoft Office PowerPoint 2003
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Visual Studio .NET 2002 Academic Edition
  • Microsoft Visual Studio .NET 2002 Enterprise Architect
  • Microsoft Visual Studio .NET 2002 Enterprise Developer
  • Microsoft Visual Studio .NET 2003 Academic Edition
  • Microsoft Visual Studio .NET 2003 Enterprise Architect
  • Microsoft Visual Studio .NET 2003 Enterprise Developer
  • Microsoft Visual Studio .NET 2003 Professional Edition
Hakusanat: 
kbautomation kbhowto KB303717

Anna palautetta

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com