文書番号: 303750 - 最終更新日: 2005年9月26日 - リビジョン: 4.6

[ファイルを開く] または [ファイルの保存] ダイアログ ボックスに表示されるファイル名が正しくない

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。
この記事は、以前は次の ID で公開されていました: JP303750

目次

すべて展開する | すべて折りたたむ

現象

Internet Explorer 5.5 Service Pack 2 (SP2) および Internet Explorer 6 でファイルを開くとき、またはファイルを保存するときに、[ファイルを開く] ダイアログ ボックスまたは [ファイルの保存] ダイアログ ボックスに正しくないファイル名が表示され、ファイルを開くことや、ファイルを保存することができない場合があります。

原因

この問題は、[ファイルを開く] または [ファイルの保存] ダイアログ ボックスでは Content-Disposition ヘッダーに指定された実際のファイル名ではなく、Internet Explorer アドレス バーのファイル名が使用されるために発生します。

解決方法

Internet Explorer 5.5 Service Pack 2

以下の「サポート技術情報」 (Microsoft Knowledge Base) の資料に記載されている修正プログラムを入手し、資料へのリンクの下に記載されている手順を実行します。
306121? (http://support.microsoft.com/kb/306121/ ) 不正なドットなしIPアドレスによりWebページがイントラネットゾーンで処理される
[ファイルを開く] または [ファイルの保存] ダイアログ ボックスに Content-Disposition のファイル名が表示されるようにするには、修正プログラムをインストールした後、次の手順を実行してください。
  1. レジストリ エディタを起動します。
  2. 次のレジストリ キーを見つけてクリックします。
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
  3. [編集] メニューの [値の追加] をクリックし、次のレジストリの値を追加します。
    値の名前 : UseCDFileName
    種類 : REG_DWORD
    ベース : 16 進数
    値のデータ : 1
  4. レジストリ エディタを終了します。

Internet Explorer 6

この問題を解決するには、Internet Explorer 6 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
328548? (http://support.microsoft.com/kb/328548/ ) [IE] 最新の Internet Explorer 6 Service Pack を入手する方法
更新プログラム (英語版) の属性は次のとおりです。ただし、これより新しい更新プログラムがリリースされている可能性もあります。
日付         時刻    バージョン        サイズ      ファイル名
------------------------------------------------------
08-Jan-02  11:56  6.0.2713.800  480,256    Urlmon.dll
08-Jan-02  11:56  6.0.2713.800  582,656    Wininet.dll
				

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。 この問題は、Internet Explorer 6 Service Pack 1 で最初に修正されました。

関連情報

類似した問題の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
238588? (http://support.microsoft.com/kb/238588/ ) Internet Explorer で [ファイルのダウンロード] ダイアログ ボックスが 2 つ表示される

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 303750? (http://support.microsoft.com/kb/303750/EN-US/ ) (最終更新日 2005-04-04) を基に作成したものです。

この資料は以下の製品について記述したものです。
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 6.0?を以下の環境でお使いの場合
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
キーワード:?
kbbug kbfix kbenv kbui kbie600sp1fix kbie550presp2fix KB303750
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"