Help and Support

"The page cannot be displayed" error message when you try to view a Web page on a secure Web site

Article ID:303807
Last Review:July 30, 2007
Revision:5.4
This article was previously published under Q303807
On This Page

SYMPTOMS

If you try to browse secure Web sites, you may receive the following message in the browser window:
The page cannot be displayed


Additionally, you may be unable to download files from secure Web sites.

Back to the top

CAUSE

This behavior may occur if any of the following conditions are true:
Your HKey_Current_User registry hive does not have valid registry entries that point to your Application Data folder.

-or-
Your computer is not using 128-bit encryption.

To determine the current level of encryption on your computer, click About Internet Explorer on the Help menu. The level of encryption on your computer is displayed next to the words "Cipher Strength."

A 40-bit cipher strength or 56-bit cipher strength indicates that the Internet Explorer High Encryption Pack or Microsoft Windows 2000 High Encryption Pack has not been installed on your system. A zero-bit cipher strength indicates that a previous installation of the encryption pack may be corrupted.

Back to the top

RESOLUTION

To resolve this issue, use the method appropriate to your situation.

Back to the top

Method 1: Install the Internet Explorer or Windows 2000 High Encryption Pack

Click About Internet Explorer on the Help menu. The level of encryption on your computer is displayed next to the words "Cipher Strength."

If the cipher strength on your computer is not 128 bits, download and install the encryption pack appropriate for your operating system to upgrade your computer to 128-bit encryption.

If you are running Microsoft Windows NT, see the following Microsoft Web site to download the Internet Explorer High Encryption Pack:
http://www.microsoft.com/windows/ie/ie6/downloads/recommended/128bit/default.mspx (http://www.microsoft.com/windows/ie/ie6/downloads/recommended/128bit/default.mspx)
If you are running Microsoft Windows 2000, see the following Microsoft Web site to download the Windows 2000 High Encryption Pack:
http://www.microsoft.com/downloads/details.aspx?FamilyID=c10925a0-ac66-4c44-b5c3-9dcab4da1c63 (http://www.microsoft.com/downloads/details.aspx?FamilyID=c10925a0-ac66-4c44-b5c3-9dcab4da1c63)
To verify that the installation is successful, click About Internet Explorer on the Help menu. The level of encryption on your computer is displayed next to the words "Cipher Strength."

Back to the top

Method 2: Correct the registry path issue

To correct your existing user profile, follow these steps:
1.Use your account to log on.
2.Click Start, click Run, type regedit.exe, and then click OK.
3.Locate and then right-click the following registry subkey:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
4.Modify the Common AppData entry to point to your profile's application data folder. For example, modify the entry to point to C:\Documents and Settings\user1\Application Data.
5.Locate and then right-click the following registry subkey:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
6.Modify the AppData entry to point to the variable path that represents your application data folder. For example, modify the entry to point to %userprofile%\Application Data.
7.Quit Registry Editor.
8.Log off, and then use the same account to log on.
9.Try to open the secure Web site.

Back to the top


APPLIES TO
Windows Internet Explorer 7 for Windows Server 2003
Windows Internet Explorer 7 for Windows XP
Windows Internet Explorer 7 for Windows Server 2003 IA64
Microsoft Internet Explorer 6.0
Microsoft Internet Explorer 5.0

Back to the top

Keywords: 
kberrmsg ocsso kbprb KB303807

Back to the top

Article Translations

 

Other Support Options

  • Contact Microsoft
    Phone Numbers, Support Options and Pricing, Online Help, and more.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.