Works : Message d'erreur : Works ne parvient pas à accéder à un ou plusieurs fichiers nécessaires pour l'exécution du Calendrier

Traductions disponibles Traductions disponibles
Numéro d'article: 303858 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F303858
Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).
Agrandir tout | Réduire tout

Symptômes

Lorsque vous essayez de démarrer le Calendrier de Microsoft Works, le message d'erreur suivant peut s'afficher :
Works ne parvient pas à accéder à un ou plusieurs fichiers nécessaires pour l'exécution du Calendrier. Il est possible que ces fichiers aient été renommés, supprimés ou déplacés. Essayez de réinstaller Works, puis redémarrez le programme.

Cause

Ce problème peut se produire si le fichier Mswkscal.wcd est endommagé.

Résolution

Pour résoudre ce problème, procédez comme suit :
  1. Insérez le CD-ROM Works, puis appuyez sur MAJ pour empêcher le programme d'installation de démarrer.

    Remarque Si le programme d'installation démarre, quittez-le.
  2. Sur le Bureau, double-cliquez sur Poste de travail.
  3. Localisez le fichier Mswkscal.wcd sur le CD-ROM Works.

    L'emplacement par défaut du fichier Mswkscal.wcd sur le CD-ROM Works est :
    lecteur:\MSWorks\Common\CommApp\mswkscal.wcd
    lecteur correspond à la lettre de votre lecteur de CD-ROM.
  4. Sélectionner le fichier Mswkscal.wcd, puis appuyez sur CTRL+C pour le copier dans le Presse-papiers.
  5. Recherchez le fichier Mswkscal.wcd sur votre disque dur.

    Selon le système d'exploitation que vous utilisez, l'emplacement par défaut du fichier Mswkscal.wcd sur le disque dur est l'un des suivants :
    • C:\Windows\All Users\Application Data\Microsoft\Works\mswkscal.wcd
    • C:\Program Files\Common Files\Microsoft Shared\Works Shared\mswkscal.wcd
    Vous pouvez également rechercher le fichier. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer, pointez sur Rechercher, puis cliquez sur Fichiers ou dossiers. Dans Microsoft Windows XP, Microsoft Windows 2000 et Microsoft Windows Millennium Edition (Me), cliquez sur Démarrer, pointez sur Rechercher, puis cliquez sur Fichiers ou dossiers.
    2. Tapez mswkscal.wcd dans la zone Nommé, puis cliquez sur Rechercher maintenant. Dans Windows XP, Windows 2000 et Windows Me, tapez mswkscal.wcd dans la zone Rechercher les fichiers ou les dossiers nommés, puis cliquez sur Rechercher maintenant.
  6. Une fois que vous avez trouvé le fichier Mswkscal.wcd sur votre disque dur, sélectionnez-le, puis appuyez sur CTRL+V pour le remplacer par la version que vous avez copiée à partir du CD-ROM Works.

    Remarque Lorsque vous y êtes invité par la question, « Voulez-vous remplacer le fichier existant », cliquez sur Oui.
  7. Assurez-vous que la nouvelle version de Mswkscal.wcd n'est pas en lecture seule : Utilisez l'Explorateur Windows pour trouver le fichier, cliquez dessus avec le bouton droit, cliquez sur Propriétés, puis désactivez la case à cocher Lecture seule.
Si vous ne pouvez toujours pas démarrer le Calendrier de Works, vous devrez peut-être réinstaller Works. Pour cela, procédez comme suit :

Suppression de Works

  1. Cliquez sur Démarrer, sur Paramètres, puis sur Panneau de configuration.

    Remarque Avec Microsoft Windows XP, cliquez sur Démarrer, puis sur Panneau de configuration.
  2. Cliquez sur Ajout/Suppression, puis supprimez Microsoft Works.

Suppression des dossiers et réinstallation de Works

  1. Sur le Bureau, double-cliquez sur Poste de travail.
  2. Localisez le dossier Works suivant sur votre disque dur :
    Pour Windows 95, 98, Me :
    C:\Windows\All Users\Application Data\Microsoft\Works

    Pour Windows 2000 et XP :
    C:\Documents and Settings\All Users\Application Data\Microsoft\Works
  3. Sélectionnez le dossier et appuyez sur SUPPR.
  4. Insérez le CD-ROM Works dans le lecteur de CD-ROM.
  5. Cliquez sur Démarrer, puis sur Exécuter.
  6. Dans la zone Ouvrir, tapez la ligne de commande suivante :
    lecteur:\setup.exe
    lecteur correspond à la lettre de votre lecteur de CD-ROM.
  7. Suivez les instructions qui s'affichent à l'écran pour réinstaller Works.
Si les étapes précédentes n'ont pas résolu ce problème, exécutez manuellement le fichier Mdac_typ.exe, puis installez Works.

Remarque Dans la mesure où il existe plusieurs versions de Microsoft Windows, les étapes suivantes peuvent varier en fonction de votre ordinateur. Si tel est le cas, reportez-vous à la documentation de votre produit pour effectuer ces opérations.
  1. Insérez le CD-ROM Works ou Works 2001 dans le lecteur de CD-ROM de votre ordinateur.
  2. Cliquez sur Démarrer, pointez sur Rechercher, puis cliquez sur Des fichiers ou des dossiers. Utilisez les étapes par défaut pour les programmes utilisateurs Windows 95 et Windows 98.
  3. Dans la zone Rechercher les fichiers ou les dossiers nommés, tapez mdac_typ.exe.
  4. Dans la zone Rechercher dans, cliquez sur la lettre du lecteur de CD-ROM qui contient le CD-ROM Works.
  5. Cliquez sur Rechercher.
  6. Dans la liste des fichiers trouvés, double-cliquez sur le fichier Mdac_typ.exe.
  7. Suivez les instructions qui s'affichent à l'écran pour installer la mise à jour MDAC.
  8. Redémarrez l'ordinateur lorsque vous y êtes invité.

Plus d'informations

Avec Windows 2000 ou Windows XP, il est possible que vous ne soyez pas en mesure d'installer la version de MDAC incluse dans le CD-ROM Works. Si vous devez mettre à jour MDAC pour résoudre ce problème, vous pouvez télécharger la version la plus récente de MDAC à partir du site Web de Microsoft à l'adresse suivante (en anglais) 
http://msdn.microsoft.com/dataaccess

Propriétés

Numéro d'article: 303858 - Dernière mise à jour: lundi 23 janvier 2006 - Version: 6.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Works 8.0
  • Microsoft Works 7.0 Standard
  • Microsoft Works 6.0 Standard
  • Microsoft Works Suite 2005
  • Microsoft Works Suite 2004 Standard Edition
  • Microsoft Works Suite 2003 Standard
  • Microsoft Works Suite 2002 Standard
  • Microsoft Works Suite 2001 Standard
  • Microsoft Works Suite 2006
Mots-clés : 
kberrmsg kbnofix kbprb KB303858
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com