Sicherungsprogramm schlägt beim Sichern eines umfangreichen Systemdatenträgers fehl

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Artikel-ID: 304101 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
304101 Backup program is unsuccessful when you back up a large system volume
Wichtig: Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Sie sollten eine Sicherungskopie der Registrierung erstellen, bevor Sie die Registrierung bearbeiten. Sie müssen wissen, wie die Registrierung wiederhergestellt werden kann, wenn ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256986 Beschreibung der Microsoft Windows-Registrierung
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
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Problembeschreibung

Wenn Sie versuchen, mit "NTBackup.exe" oder dem Sicherungsprogramm eines Fremdanbieters, das die API "NT Backup" verwendet, ein Backup zu erstellen, wird die Erstellung des Backups möglicherweise nicht erfolgreich abgeschlossen. Dieses Verhalten kann selbst dann zu beobachten sein, wenn Sie das Programm lokal auf dem Server ausführen. Außerdem treten möglicherweise eines oder mehrere der folgenden Symptome auf:
  • Eine oder mehrere der folgenden Fehlermeldungen können im Anwendungsprotokoll protokolliert werden:
    Fehlermeldung 1
    Fehler 1450: Nicht genügend Systemressourcen, um den angeforderten Dienst auszuführen.

    Fehler 1450: / hex 0x5aa ERROR_NO_SYSTEM_RESOURCES

    Betriebssystemfehler 1450 Nicht genügend Systemressourcen, um den angeforderten Dienst auszuführen.

    Schreiben auf "Gerät" fehlgeschlagen, Status = 1450
    Fehlermeldung 2
    Fehler 1130: Für diesen Befehl ist nicht genügend Serverspeicher verfügbar.

    Fehler 1130 / hex 0x46a ERROR_NOT_ENOUGH_SERVER_MEMORY

    Sicherungs- oder Wiederherstellungsoperation wurde fehlerbedingt beendet.
  • Der Serverdienst generiert unter Umständen Meldungen mit den Ereignis-IDs 2020 und 2021.

    Hinweis: Fehlermeldungen mit den Ereignis-IDs 2020 und 2021 treten in der Regel nicht auf.
  • Wenn Sie das Sicherungsprogramm "OmniBack" von Hewlett-Packard (HP) ausführen, kann eine Fehlermeldung etwa folgenden Inhalts angezeigt werden:
    [81:78] C:\Ordner\Dateiname
    57256 Byte bei Offset 436176408(:1) können nicht gelesen werden: (Cannot read 57256 bytes at offset 436176408(:1):) ([1450]
    Nicht genügend Systemressourcen, um den angeforderten Dienst auszuführen.
  • Wenn Sie sich die Registerkarte Systemleistung im Windows Task-Manager ansehen, stellen Sie fest, dass nur sehr wenig nicht ausgelagerter Kernel-Speicher zur Verfügung steht.
Hinweis: Diese Fehlermeldungen können auch aus Gründen angezeigt werden, die nicht in Beziehung zu dem Problem stehen, das in diesem Artikel beschrieben wird. Wenn diese Fehlermeldungen nur beim Sichern eines großen Systemdatenträgers angezeigt werden, sind die zwei wahrscheinlichsten Ursachen jene, die in diesem Artikel beschrieben werden.

Starten Sie den Windows Task-Manager, und klicken Sie dann auf die Registerkarte Systemleistung, um festzustellen, ob dieses Problem auf Ihrem Computer auftritt. Sehen Sie sich den unten rechts unter Kernel-Speicher (KB) angegebenen Wert und dann den Wert für Ausgelagert an. Das hier beschriebene Problem kann in Microsoft Windows 2000 oder Microsoft Windows NT 4.0 auftreten, wenn dieser Wert ca. 160 Megabyte (MB) erreicht. Außerdem kann dieses Problem auch in Microsoft Windows Server 2003 zu beobachten sein, wenn dieser Wert 160 MB übersteigt. Falls Sie den Registrierungsschlüssel für den ausgelagerten Poolspeicher auf einen höheren Wert festgelegt haben, tritt dieses Problem erst dann auf, wenn wesentlich mehr ausgelagerter Poolspeicher verwendet wird (das Problem kann auftreten, wenn die Auslastung des ausgelagerten Poolspeichers ca. 80 Prozent des festgelegten Wertes erreicht). Falls Sie die Einstellung gflags für Auslagerungstags aktiviert haben und das Dienstprogramm "Poolmon" verwenden, sehen Sie eine höhere Auslastung für den Tag MmSt. Dieser Auslagerungstag dient dazu, den Betriebssystemspeicher zuzuordnen, der verwendet wird, um freigegebene Dateien zu verfolgen.

Ursache

Die zwei Ursachen dieses Problems stehen in einer Beziehung zueinander. Die häufigere dieser beiden Ursachen wird zuerst beschrieben:
  • Es sind mehr Dateien geöffnet, als der Cache-Manager verarbeiten kann. Dies hat dazu geführt, dass der Cache-Manager den verfügbaren ausgelagerten Poolspeicher erschöpft hat.
  • Das Sicherungsprogramm hat versucht, eine Datei zu sichern, die zu groß ist, als dass die Sicherungs-API der jeweiligen Version des Betriebssystems darauf zugreifen könnte. Das Ergebnis ist das gleiche (der ausgelagerte Poolspeicher ist erschöpft).

    Hinweis: Das Auftreten des zweiten Problems ist auf einem Microsoft Windows NT 4.0-Computer wahrscheinlicher.
Die Lösung für das Problem variiert in Abhängigkeit davon, ob das Problem unter Windows Server 2003, Microsoft Windows 2000 oder Windows NT 4.0 auftritt.

Lösung

Windows Server 2003 und Windows 2000

Warnung: Durch die falsche Bearbeitung der Registrierung mithilfe des Registrierungs-Editors oder einer anderen Methode können schwerwiegende Probleme verursacht werden. Diese Probleme können eine Neuinstallation des Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungs-Editors herrühren, behoben werden können. Benutzen Sie den Registrierungs-Editor auf eigene Verantwortung.

Sie müssen eventuell zwei Registrierungseinstellungen ändern. Die erste der genannten Registrierungseinstellungen müssen Sie immer ändern. In Abhängigkeit von der Konfiguration Ihres Systems müssen Sie möglicherweise auch die zweite Einstellung ändern.

1. Registrierungseinstellung

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie im Feld Öffnen den Befehl regedit ein, und klicken Sie auf OK.
  2. Klicken Sie auf den folgenden Unterschlüssel in der Registrierung:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
  3. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie anschließend auf DWORD-Wert.
  4. Geben Sie PoolUsageMaximum als Namen des Eintrags ein, und drücken Sie danach die [EINGABETASTE].
  5. Klicken Sie mit der rechten Maustaste auf PoolUsageMaximum, und klicken Sie dann auf Ändern.
  6. Klicken Sie auf Dezimal.
  7. Geben Sie im Feld Wert den Wert 60 ein, und klicken Sie anschließend auf OK.

    Wichtig:
    • Verwenden Sie 60 als Anfangswert. Falls die Sicherung fehlschlägt, verwenden Sie den Wert 40. Funktioniert auch dies nicht, müssen Sie die Konfiguration Ihres Sicherungsprogramms so ändern, dass weniger ausgelagerter Poolspeicher erforderlich ist. Wenn die Sicherung mit diesem Wert erfolgreich ist, sollten Sie möglicherweise den Wert in Schritten von 25 Prozent erhöhen, bis die Sicherung fehlschlägt. Schlägt die Sicherung dann fehl, verwenden Sie die zweite der in diesem Artikel beschriebenen Registrierungseinstellungen.
    • Stellen Sie sicher, dass der Wert für diese Registrierungseinstellung nicht höher ist als 60.
    • Falls Sie die Befehlszeilenoption /3GB verwenden, wählen Sie 40 als Anfangswert. Beachten Sie, dass es sich bei diesem Wert um einen Prozentsatz handelt.
  8. Beenden Sie den Registrierungseditor.
  9. Starten Sie den Computer neu.
Da Sie diese Einstellungen bei Sicherungsvorgängen mit höchstmöglicher Belastung testen sollten, müssen Sie eventuell einen Monat warten, bis ein ganzer Sicherungszyklus abgeschlossen ist, sofern Sie sich nicht sicher sind, welche Sicherung die meisten Ressourcen verbraucht. Aus diesem Grund empfiehlt Microsoft, zunächst niedrige Werte zu testen. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
312362 Der Server kann keinen ausgelagerten Poolspeicher reservieren

2. Registrierungseinstellung

  1. Klicken Sie auf Start und anschließend auf Ausführen. Geben Sie in das Feld Öffnen den Befehl regedit ein, und klicken Sie auf OK.
  2. Klicken Sie auf den folgenden Unterschlüssel in der Registrierung:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
  3. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie anschließend auf DWORD-Wert.
  4. Geben Sie PagedPoolSize als Namen des Eintrags ein, und drücken Sie danach die [EINGABETASTE].
  5. Klicken Sie mit der rechten Maustaste auf PagedPoolSize, und klicken Sie dann auf Ändern.
  6. Klicken Sie auf Hexadezimal.
  7. Geben Sie in das Feld Wert den Wert FFFFFFFF ein, und klicken Sie auf OK.

    Wichtig:
    • Wenn Sie "PagedPoolSize" auf 0xFFFFFFFF (-1) setzen, wird dem Computer der maximale ausgelagerte Poolspeicher an Stelle anderer Ressourcen zugewiesen. Dies ist in der Regel auf einem Domänencontroller oder Terminalserver erforderlich. Standardmäßig gilt für die meisten Windows 2000-Systeme eine Obergrenze von 160 MB für den ausgelagerten Poolspeicher. Ob dies bei Ihnen der Fall ist, können Sie überprüfen, indem Sie die Kernel-Debugger von der öffentlichen Website herunterladen und ein Kernelabbild in dem Debugger öffnen, den Sie verwenden möchten. Verwenden Sie hierzu den Befehl !vm. Als Ergebnis kann beispielsweise eine maximale Größe des ausgelagerten Poolspeichers von 163840 KB angezeigt werden. Bei Verwendung dieses Wertes wird die Anzahl der auf einem System verfügbaren Seitentabelleneinträge (Page Table Entries/PTEs) reduziert und die maximale Größe des ausgelagerten Poolspeichers in Windows 2000 auf 343 MB erhöht. In Windows Server 2003 kann die maximale Größe des ausgelagerten Poolspeichers auf einen noch höheren Wert erweitert werden.

      Hinweis: In Windows Server 2003 liegen die Standard- und Maximalwerte für die Größe des ausgelagerten Poolspeichers wesentlich höher als in Windows 2000. In der Regel liegen die Werte für Windows Server 2003 um mindestens 50 Prozent über denen für Windows 2000. Diese höheren Werte machen es unwahrscheinlicher, dass bei Ihnen die Werte für den ausgelagerten Poolspeicher zu dem Problem beitragen, das in diesem Artikel beschrieben wird. Es ist jedoch immer noch möglich, dass dieses Problem auftritt.
    • Dieser Wert schränkt die Anzahl der verfügbaren Seitentabelleneinträge des Systems ein. Seitentabelleneinträge sind eine weitere nicht gebundene Systemressource, die Ihr System verwendet. Diese Einstellung kann dazu führen, dass Ihr System unerwartet nicht mehr reagiert und beim Starten einen Fehler des Typs 0x3F auf blauem Bildschirm anzeigt. In diesem Fall können Sie eine Wiederherstellung erreichen, indem Sie die Neustartoption Letzte als funktionierend bekannte Konfiguration im Neustartmenü des Systems oder in der Wiederherstellungskonsole verwenden. Verwenden Sie den Systemmonitor, um den Leistungsindikator Freie Seitentabelleneinträge einzusehen. Sie können die Einstellung PagePoolSize hinzufügen, wenn die gemeldeten Werte über 40.000 liegen.
    • Falls Sie die Optionen /3GB und /PAE zusammen ausführen, verwenden Sie diese Einstellung nur nach umfangreichen Tests und nachdem Sie exakt ermittelt haben, wie viele System-Seitentabelleneinträge Sie in Ihrer Umgebung benötigen. In der Regel sehen Sie einen Wert zwischen 10.000 und 20.000 für die freien Seitentabelleneinträge. Orientieren Sie sich bei der Konfiguration des ausgelagerten Poolspeichers an den entsprechenden Artikeln in der Microsoft Knowledge Base, achten Sie jedoch darauf, dass nie weniger als 10.000 freie Seitentabelleneinträge vorhanden sind. Legen Sie hier keinen anderen Wert fest, wenn Sie die Befehlszeilenoption /3GB verwenden. Unterstützt werden nur die Werte 0, 0A000000 und FFFFFFFF.
  8. Beenden Sie den Registrierungseditor.
  9. Starten Sie den Computer neu.
Weitere Informationen zur Vermeidung und Behebung dieses Problems finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256004 Fehlerbehandlung bei Fehlermeldungen "STOP 0x0000003F" und "STOP 0x000000D8" in Windows Server 2003, Windows XP und Windows 2000

Windows NT 4.0

Warnung: Durch die falsche Bearbeitung der Registrierung mithilfe des Registrierungs-Editors oder einer anderen Methode können schwerwiegende Probleme verursacht werden. Diese Probleme können eine Neuinstallation des Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungs-Editors herrühren, behoben werden können. Benutzen Sie den Registrierungs-Editor auf eigene Verantwortung.

Hinweis: Sie müssen Windows NT 4.0 Service Pack 6a verwenden.

Beheben des ersten Problems

  1. Starten Sie den Registrierungseditor (Regedt32.exe).
  2. Klicken Sie auf den folgenden Unterschlüssel in der Registrierung:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory_Management
  3. Klicken Sie im Menü Bearbeiten auf Wert hinzufügen, und fügen Sie den folgenden Registrierungswert hinzu:
    Name: UnusedFileCache
    Typ: REG_DWORD
    Basis: Dezimal
    Wert: 15
    Hinweis: Diese Zahl steht für den Prozentsatz an Poolspeicher, der durch nicht genutzte Segmente belegt werden kann. Bei dem Wert 0 verwendet das System die Standardwerte, die denen für Windows NT 4.0 Service Pack 3 ähneln. Bei Werten zwischen 5 und 40 wird das System den nicht genutzten Datei-Cache auf der Basis der Auslastung des Poolspeichers anpassen. 5 ist der aggressivste Wert (das heißt, dass bei diesem Wert der Cache am wenigsten vergrößert wird) und 40 ist der am wenigsten aggressive Wert (bei diesem Wert kann der Cache am größten werden, bevor eine Anpassung erfolgt).

    Wichtig:
    • Verwenden Sie 15 als Anfangswert. Falls die Sicherung fehlschlägt, verwenden Sie den Wert 5. Falls diese Option nicht funktioniert, müssen Sie Ihr Sicherungsprogramm entweder so konfigurieren, dass weniger ausgelagerter Poolspeicher benötigt wird, oder Sie müssen auf Windows 2000 aktualisieren, wo mehr als die doppelte Menge an ausgelagertem Poolspeicher verfügbar ist (weitere Informationen finden Sie im Abschnitt zu Windows 2000). Wenn die Sicherung mit diesem Wert erfolgreich ist, sollten Sie möglicherweise den Wert in Schritten von etwa 20 Prozent erhöhen, bis die Sicherung fehlschlägt. Schlägt die Sicherung dann fehl, verwenden Sie die zweite der in diesem Artikel beschriebenen Registrierungseinstellungen.
    • Falls Sie die Befehlszeilenoption /3GB verwenden, wählen Sie 5 als Anfangswert.
  4. Beenden Sie den Registrierungseditor.
  5. Starten Sie den Computer neu.
Da Sie diese Einstellungen bei Sicherungsvorgängen mit höchstmöglicher Belastung testen sollten, müssen Sie eventuell einen Monat warten, bis ein ganzer Sicherungszyklus abgeschlossen ist, sofern Sie sich nicht sicher sind, welche Sicherung die meisten Ressourcen verbraucht. Aus diesem Grund empfiehlt Microsoft, zunächst niedrige Werte zu testen. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
171458 Windows NT kann bei Anforderung fehlschlagen, umfangreiche Datei zu öffnen

Beheben des zweiten Problems

Eine mögliche Lösung besteht darin, die Sicherung so einzuschränken, dass jeweils nur eine Datei gesichert wird. In Abhängigkeit von der Größe der zu sichernden Dateien kann dies funktionieren oder nicht. (Zu erwarten ist, dass es bei Dateien funktioniert, die kleiner sind als 180 Gigabyte [GB].) Sie können es auch mit dieser Lösung versuchen, wenn Sie zwar mehrere umfangreiche Dateien sichern möchten, jede dieser Dateien jedoch kleiner ist als 180 GB. In diesem Fall müssen Sie auch die Schritte zur Behebung des ersten Problems ausführen. Für Dateien mit einer Größe von mehr als 180 GB gibt es keine Möglichkeit, das Problem zu umgehen. Sie müssen das System daher auf Windows 2000 aktualisieren. Wenn Sie eine Remotesicherung des Problems als Umgehungsmöglichkeit ausprobieren, wird das gleiche Problem auftreten.
  1. Starten Sie den Registrierungseditor (Regedt32.exe).
  2. Klicken Sie auf den folgenden Unterschlüssel in der Registrierung:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory_Management
  3. Klicken Sie im Menü Bearbeiten auf Wert hinzufügen, und fügen Sie den folgenden Registrierungswert hinzu:
    Name: DisablePagedPoolHint
    Typ: REG_DWORD
    Basis: Dezimal
    Wert: 1
  4. Beenden Sie den Registrierungseditor.
  5. Starten Sie den Computer neu.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Weitere Informationen

Sowohl NTBackupread als auch NTBackupwrite verwenden eine gepufferte E/A. Dies bedeutet, dass Windows NT die E/A zwischenspeichert, die gegen den Strom ausgeführt wird. Außerdem ist dies die einzige API, welche die Metadaten einer Datei sichert. Der Cache wird auf der Basis beschränkter Ressourcen gebildet: Dies gilt besonders für den ausgelagerten und den nicht ausgelagerten Poolspeicher. Aus diesem Grund können eine sehr große Anzahl an Dateien oder sehr umfangreiche Dateien zur Folge haben, dass die Poolressourcen knapp werden.

Mehrere Faktoren können die Verfügbarkeit von ausgelagertem Poolspeicher beeinträchtigen. Das Aktivieren von "Pool Tagging" und das Erstellen von "Poolsnaps" in unterschiedlichen Abständen kann dabei helfen, zu ermitteln, welcher Treiber für die Knappheit des ausgelagerten Poolspeichers verantwortlich ist. Fall die Poolsnaps ergeben, dass der Tag MmSt (prototypische Seitentabelleneinträge des Section-Objekts Mm) der größte Verbraucher ist und einen Wert von mehr als 80 MB aufweist, ist wahrscheinlich eine sehr große Anzahl von Dateien auf dem Server geöffnet.

Die maximale Größe des ausgelagerten Poolspeichers auf einem Computer beträgt 343 MB in Windows 2000, wenn der Schlüssel für den ausgelagerten Poolspeicher auf FFFFFFFF gesetzt ist, oder 164 MB, wenn dieser Schlüssel nicht vorhanden ist. Die maximale Größe des ausgelagerten Poolspeichers in Windows NT beträgt 192 MB. Standardmäßig versucht der Speicher-Manager, den zugewiesenen ausgelagerten Poolspeicher zu verringern, wenn das System 80 Prozent des gesamten ausgelagerten Pools erreicht. Beispiel: 80 Prozent von 343 MB sind 274 MB. Wenn der Speicher-Manager den Poolspeicher nicht schnell genug verringern kann, um mit dem Bedarf Schritt zu halten, kann das im Abschnitt "Problembeschreibung" dieses Artikels beschriebene Ereignis auftreten. Wenn Sie den Speicher-Manager so konfigurieren, dass der Vorgang der Verringerung früher gestartet wird (beispielsweise ab 40 Prozent), kann mit dem Bedarf an ausgelagertem Poolspeicher während unerwarteter Spitzenzeiten Schritt gehalten werden und ein Knappwerden des ausgelagerten Poolspeichers wird vermieden. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
192409 Zu Bericht INSUFFICIENT_RESOURCES kann Geöffnete Dateien Kernel verursachen


Die in diesem Artikel genannten Fremdanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.

Eigenschaften

Artikel-ID: 304101 - Geändert am: Mittwoch, 6. Dezember 2006 - Version: 6.2
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
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kbprb kbfaq KB304101
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