ACC2002: Como vincular uma lista de tabela dinâmica do Microsoft Access com fontes de dados OLAP

Traduções deste artigo Traduções deste artigo
ID do artigo: 304149 - Exibir os produtos aos quais esse artigo se aplica.
Avançadas: Requer especialista de codificação, interoperabilidade e habilidades de multiusuário.

Este artigo se aplica a um banco de dados do Microsoft Access (.mdb) e para um projeto Microsoft Access (.adp).

Expandir tudo | Recolher tudo

Sumário

No Microsoft Access 2002, você pode exibir tabelas, consultas, modos de exibição, funções e formulários no modo de tabela dinâmica. Isso é possível porque o Access 2002 nativamente hospeda o Microsoft Office Web Components. Este artigo mostra como usar o modelo de objeto do Office Web Components para criar um modo de exibição tabela dinâmica em um formulário do Microsoft Access que é conectado a uma fonte de dados OLAP. Método 1 mostra como fazer isso usando a interface do usuário. Método 2 mostra como fazer isso usando o Visual Basic para código de aplicativos.

Mais Informações

Os métodos a seguir demonstram como vincular um controle do Microsoft Office 10.0 de tabela dinâmica a um cubo multidimensional do OLAP. Estes exemplos exigem o provedor OLEDB do MSOLAP no computador do SQL Server com o banco de dados FoodMart ou FoodMart 2000 OLAP. O provedor OLEDB do MSOLAP é instalado quando você instalar componentes de cliente OLAP do Microsoft SQL Server 7.0 ou posterior do CD.

Microsoft fornece exemplos de programação apenas para ilustração, sem garantia expressa ou implícita. Isso inclui, mas não está limitado a, garantias implícitas de comercialização ou adequação para uma finalidade específica. Este artigo presume que você está familiarizados com a linguagem de programação que está sendo demonstrada e com as ferramentas que são usadas para criar e depurar procedimentos. Engenheiros de suporte podem ajudar a explicar a funcionalidade de um determinado procedimento, mas eles não modificarão esses exemplos para fornecer funcionalidades adicionais ou construir procedimentos para atender às suas necessidades. cuidado : se você seguir as etapas neste exemplo, você modificar o banco de dados de exemplo Northwind.mdb. Convém fazer o backup do arquivo Northwind.mdb e seguir essas etapas numa cópia do banco de dados.

Método 1

  1. Abra o banco de dados de exemplo Northwind.mdb.
  2. Crie um novo formulário no modo de design.
  3. No menu Inserir , clique em Controle ActiveX , clique em Microsoft Office 10.0 de tabela dinâmica e, em seguida, clique em OK .
  4. No menu Exibir , clique em Propriedades .
  5. Na folha de propriedades para o controle de tabela dinâmica, clique na guia outras e, em seguida, clique no botão Construir (...) próximo à propriedade personalizada .
  6. Clique em conexão e, em seguida, clique em Editar . Esse procedimento inicia a caixa de diálogo Data Link propriedades .
  7. Na guia provedor , clique em Microsoft OLEDB Provider for OLAP Services e, em seguida, clique em Avançar.
  8. Na caixa Fonte de dados , digite o nome do servidor OLAP.
  9. Digite as informações apropriadas de autenticação.
  10. Clique no nome do armazenamento de dados OLAP na caixa suspensa.
  11. Clique em OK para fechar a caixa de diálogo Data Link Properties .
  12. Na caixa de diálogo Propriedades de tabela dinâmica do Office , clique em vendas na caixa de membro de dados, tabela, modo de exibição ou nome do cubo .
  13. Clique em OK para fechar a caixa de diálogo Propriedades de tabela dinâmica do Office .
  14. Exiba a lista de campo de tabela dinâmica. Arraste os campos que você deseja criar um modo de exibição tabela dinâmica que é baseado no cubo OLAP.

Método 2

  1. Abra o banco de dados de exemplo Northwind.mdb.
  2. Crie um novo formulário no modo de design.
  3. No menu Inserir clique em Controle ActiveX , clique em Microsoft Office 10.0 de tabela dinâmica e, em seguida, clique em OK .
  4. No menu Exibir , clique em Propriedades .
  5. Na folha de propriedades do controle de tabela dinâmica, clique na guia outras e digite tabela dinâmica na propriedade Name .
  6. Salve o formulário como frmPivotTable e fechá-lo.
  7. No menu Inserir , clique em módulo . Isso inicia o Editor do Visual Basic e insere um módulo novo e em branco.
  8. No menu Ferramentas , clique em referências .
  9. Clique em Procurar .
  10. Procure e selecione o seguinte arquivo e em seguida, clique em Abrir . Isso adiciona uma referência à biblioteca do Microsoft Office XP Web Components .
    C:\Program Files\Common Files\Microsoft Shared\Web Components\10\OWC10.DLL
  11. Clique em OK para fechar a caixa de diálogo referências .
  12. Adicione o seguinte código Visual Basic for Applications (VBA) ao novo módulo:
    Sub BindPivotTableToOLAP()
        Dim frm As Access.Form
        DoCmd.OpenForm "frmPivotTable", acFormPivotTable
            
        Set frm = Forms("frmPivotTable")
        
        Dim pTable As OWC10.PivotTable
        Set pTable = frm.PivotTable
        
        If pTable.ConnectionString = "" Then
            strConnect = "Provider=MSOLAP.2;Integrated Security=SSPI;Data Source=<server name>;Initial Catalog=FoodMart 2000"
            pTable.ConnectionString = strConnect
                
           'Set DataMember property to the name of the OLAP
           'cube. In this case, you are using Sales from Foodmart.
            pTable.DataMember = "Sales"
        End If
    End Sub
    					
  13. No menu Exibir , clique em Janela imediata para abrir a janela imediata.
  14. Digite a seguinte linha na janela Verificação imediata e, em seguida, pressione ENTER:
    BindPivotTableToOLAP
  15. No menu arquivo , clique em Fechar e voltar para o Microsoft Access .
  16. Exiba a lista de campo de tabela dinâmica. Arraste os campos que você deseja criar um modo de exibição tabela dinâmica que é baseado no cubo OLAP.

Referências

Para obter mais informações sobre o modelo de objeto de tabela dinâmica , consulte o arquivo de Ajuda "Microsoft Office Web Components Visual Basic Reference", Owcvba10.chm. Este arquivo de Ajuda está localizado na pasta específicos do idioma no seguinte local:
C:\Program Files\Common Files\Microsoft Shared\Web Components\10
Por exemplo, se você estiver usando a versão em inglês do Microsoft Office XP, este arquivo de Ajuda é na pasta 1033:
C:\Program Files\Common Files\Microsoft Shared\Web Components\10\1033

Propriedades

ID do artigo: 304149 - Última revisão: quinta-feira, 23 de junho de 2005 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbmt kbhowto KB304149 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 304149

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com