Article ID: 304228 - Last Review: October 28, 2006 - Revision: 1.6

XADM: Search Causes High Information Store CPU Utilization

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
This article was previously published under Q304228

On This Page

Expand all | Collapse all

SYMPTOMS

The Microsoft Exchange 2000 Information Store (IS) reaches high utilization of the central processing unit (CPU) for an hour or more.

CAUSE

This behavior occurs when you perform an HTTP DAV SEARCH that contains a very large number (such as a million) of unique column names.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. In this update, the maximum number of column names for a SEARCH has been changed to 1024.

The English version of this fix should have the following file attributes or later:

Component:

Collapse this tableExpand this table
File nameVersion
DAVEX.DLL4720.29
EXPROX.DLL4720.29
STORE.EXE4720.29
JCB.DLL4720.29
EXOLEDB.DLL4720.29
EXCDO.DLL4720.29
MDBSZ.DLL4720.29

NOTE: Due to file dependencies, this update requires Microsoft Exchange Server 2000 Service Pack 1.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

MORE INFORMATION

Sample Callstack for Information Store

ChildEBP RetAddr  Args to Child
0fa2f094 5f86b13b 0fa2f0fc 00000000 77e88ab4 EXOLEDB!_chkstk+0x17
0fa2f0b4 5f86adb1 0fa2f0fc 00000000 03df0410 EXOLEDB!ScDispatchRequest+0x277
0fa2feb4 5f8ef643 113f0008 5f9b8183 113f0008 EXOLEDB!CDavServer__ProcessItem+0xa9
0fa2febc 5f9b8183 113f0008 03d65bf4 03df0410 EXOLEDB!	CEpoxyStreamUnpacker__ProcessUnpackedStream+0xa
0fa2fee8 5f8ef5f2 5f86ac13 05f90040 03d65bf0 EXOLEDB!IEpoxyStreamUnpacker__ScUnpackStreamBuffer+0x13a
0fa2ff00 62f26c03 03d65bf4 00000046 01d65b4d EXOLEDB!CDavServer__HrEpoxyReqHandler+0x76
0fa2ff28 62f268fe 00000046 00000001 00000000 EPOXY!CEpoxyQ__DispatchRequest+0x98
00000002 0000012b 00000070 62f2e37c 00000000 EPOXY!CEpoxyQ__IOCPNotification+0x16c
				

APPLIES TO
  • Microsoft Exchange Server 2000 Service Pack 1
Keywords: 
kbautohotfix kbhotfixserver kbbug kbexchange2000presp2fix kbfix kbqfe KB304228
 

Article Translations

 

Related Support Centers