Vytvoření výběrového dotazu v aplikaci Access 2002

Překlady článku Překlady článku
ID článku: 304325 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

V aplikaci Microsoft Access můžete vytvořit dotaz k načtení informace z tabulky nebo z více tabulek. Potom můžete použít dotaz jako na základě formuláře, sestavy nebo datové stránky. Tento článek popisuje vytvoření jednoduchých dotazů v aplikaci Microsoft Access a jak použít řazení a kritéria pro dotazy. Tento článek obsahuje následující oddíly:
  • Co je výběrový dotaz?
  • Vytvoření výběrového dotazu pomocí Průvodce
  • Jak vytvořit výběrový dotaz v návrhovém zobrazení
  • Jak přidat kritéria k dotazu
  • Způsob seskupení záznamů a částek vytvořit a ostatní souhrny
  • Způsob řazení záznamů v dotazu

Co je výběrový dotaz?

Výběrový dotaz je nejběžnějším typem dotazu. Při použití:
  • Načtení dat z jedné nebo více tabulek pomocí kritérií zadané a k zobrazení dat v pořadí, které Chcete.
  • Upravit a aktualizovat záznamy v datovém listu výběrového dotazu (s určitými omezeními).
  • Seskupit záznamy a vypočítat součty, počty, průměry, a dalších typů souhrnů.

Vytvoření výběrového dotazu pomocí Průvodce

Následující pokyny popisují, jak vytvořit dotaz k načtení informace o Zákazníci a objednávky z ukázkové databáze Northwind součástí aplikace Microsoft Access 2002.

Další informace o zobrazení Ukázková databáze Northwind, klepněte na následující článek znalostní báze článek znalostní báze Microsoft Knowledge Base:
276376ACC2002: Kde jsou soubory s ukázkovou databází Northwind?
UPOZORNĚNÍ:Pokud provedete kroky v tomto příkladu, změníte vzorku databáze Northwind.mdb. Chcete zazálohovat soubor Northwind.mdb a na kopii databáze, postupujte takto.

  1. Spusťte aplikaci Microsoft Access 2002.
  2. V Nápověda příkaz Ukázkové databázea klepněte na tlačítko Ukázková databáze Northwind. Zavřít Hlavní přepínací panel formulář, když se objeví.
  3. V Zobrazení příkaz Objekty databázea klepněte na tlačítko Dotazy.
  4. V Vložit nabídky, klepněte na tlačítko Dotaz.
  5. V Nový dotaz Dialogové okno, klepněte na tlačítko Průvodce jednoduchým dotazema klepněte na tlačítko OK.
  6. V Průvodce jednoduchým dotazem Dialogové okno, klepněte Zákazníci tabulku v Tabulky či dotazy seznam. Poklepejte na položku Následující pole přidat, aby Vybraná pole pole: ID zákazníka, Firma, Kontakt, ContactTitle.
  7. Na téže stránce Průvodce jednoduchým dotazem, klepněte Objednávky tabulku v Tabulky či dotazy seznam. Klepněte na tlačítko >> Přidat všechna pole z tabulky objednávky Vybraná pole pole.
  8. Klepněte na tlačítko Dokončit. Průvodce jednoduchým dotazem, sestaví dotaz a zobrazí výsledky v zobrazení datového listu.

Jak vytvořit výběrový dotaz v návrhovém zobrazení

  1. Spusťte aplikaci Microsoft Access 2002.
  2. V Nápověda příkaz Ukázkové databázea klepněte na tlačítko Ukázková databáze Northwind. Zavřít Hlavní přepínací panel formulář, když se objeví.
  3. V Zobrazení příkaz Objekty databázea klepněte na tlačítko Dotazy.
  4. Poklepejte v okně databáze Vytvořit dotaz v návrhovém zobrazení.
  5. V Zobrazit tabulku Dialogové okno, klepněte na tlačítko Zákaznícia klepněte na tlačítko Přidat.
  6. Opakujte krok 5 pro tabulku objednávky.
  7. Klepněte na tlačítko Zavřít Zavřete Zobrazit tabulku Dialogové okno.
  8. V Zákazníci Seznam polí tabulky v horní polovině okna návrhu dotazu Poklepáním přidáte následující pole: ID zákazníka, Firma, Kontakt, ContactTitle.
  9. V Objednávky Seznam polí tabulky v horní polovině okna návrhu dotazu Poklepejte *. Přidání * je ekvivalent výběru všech polí z určité tabulky.
  10. V Soubor nabídky, klepněte na tlačítko Uložit. Typ qryCustomerOrders název dotaz.
  11. V Dotaz nabídky, klepněte na tlačítko Spustit k zobrazení výsledků dotazu.

Jak přidat kritéria k dotazu

Následující kroky upraví dotaz, který jste vytvořili v "Vytvoření dotazu v návrhovém zobrazení vyberte" dříve v tomto článku.
  1. Spusťte aplikaci Microsoft Access 2002.
  2. V Nápověda příkaz Ukázkové databázea klepněte na tlačítko Ukázková databáze Northwind. Zavřít Hlavní přepínací panel formulář, když se objeví.
  3. V Zobrazení příkaz Objekty databázea klepněte na tlačítko Dotazy.
  4. Klepněte qryCustomerOrders dotaz, který je vytvořen v předchozí části a klepněte na tlačítko Návrh Otevřete dotaz v návrhovém zobrazení.
  5. V Objednávky Seznam polí tabulky v horní polovině okna návrhu dotazu Poklepejte ZeměPříjemce pole přidejte do návrhové mřížky dotazu.
  6. V ZeměPříjemce Klepnutím zrušte sloupce v návrhové mřížce dotazu Zobrazit Zaškrtávací políčko. Protože toto pole zahrnuto výběrem * z objednávek, bude tabulka, zrušením zaškrtnutí tohoto políčka předejít pole včetně dvakrát.
  7. Zadejte UK v Kritéria řádek pro ZeměPříjemce pole.
  8. V Soubor nabídky, klepněte na tlačítko Uložit jako. Typ qryUKOrders název dotaz.
  9. V Dotaz nabídky, klepněte na tlačítko Spustit k zobrazení výsledků dotazu. Všimněte si, že dotaz vrátí objednávky, které byly dodány na Spojené království.

Způsob seskupení záznamů a vytvoření částek a ostatní souhrny

Následující pokyny popisují, jak vytvořit souhrnný dotaz, který získat souhrnné informace o objednávkách z ukázkové databáze Northwind.
  1. Spusťte aplikaci Microsoft Access 2002.
  2. V Nápověda příkaz Ukázkové databázea klepněte na tlačítko Ukázková databáze Northwind. Zavřít Hlavní přepínací panel formulář, když se objeví.
  3. V Zobrazení příkaz Objekty databázea klepněte na tlačítko Dotazy.
  4. Poklepejte v okně databáze Vytvořit dotaz v návrhovém zobrazení.
  5. V Zobrazit tabulku Dialogové okno, klepněte na tlačítko Vybrat Objednávkya klepněte na tlačítko Přidat.
  6. Klepněte na tlačítko Zavřít Zavřete Zobrazit tabulku Dialogové okno.
  7. V Objednávky Seznam polí tabulky v horní polovině okna návrhu dotazu Poklepáním přidáte následující pole: ZeměPříjemce, Dopravné.
  8. V Zobrazení nabídky, klepněte na tlačítko Součty. Všimněte si, že řádek s názvem. Celkem je přidán do návrhové mřížky dotazu.
  9. Klepněte Celkem Buňka řádku v Dopravné sloupce, klepněte na šipku, která se zobrazí a klepněte na tlačítko Součet.
  10. V Soubor nabídky, klepněte na tlačítko Uložit. Typ qryFreightByCountry název dotaz.
  11. V Dotaz nabídky, klepněte na tlačítko Spustit k zobrazení výsledků dotazu. Všimněte si, že dotaz vrátí Dopravné celkem pro jednotlivé země v tabulce objednávky.

Způsob řazení záznamů v dotazu

  1. Otevřít qryFreightByCountry dotaz, který jste vytvořili v "seskupení záznamů a vytváření částky a ostatní souhrny"sekce v návrhovém zobrazení.
  2. Klepněte Řazení Buňka řádku v Dopravné sloupce, klepněte na šipku, která se zobrazí a klepněte na tlačítko Sestupně.
  3. V Soubor nabídky, klepněte na tlačítko Uložit jako. Typ qryFreightByCountrySorted pro název dotazu.
  4. V Dotaz nabídky, klepněte na tlačítko Spustit k zobrazení výsledků dotazu. Všimněte si, že dotaz vrátí Dopravné celkem pro jednotlivé země v tabulce objednávky, v sestupném pořadí.



Odkazy

Další informace o vytváření dotazů Nápověda pro Microsoft Access v Nápověda Nabídka Typ Vytvoření výběrového dotazu v Pomocníka Office nebo Průvodci odpověďmi a potom na Hledání Zobrazit témata vrácena.

To je také k dispozici na webu společnosti Microsoft následující informace Webový server:
Vytvořte výběrový nebo křížový dotaz
Pro další informace o vytváření křížových dotazů, klepnutím na následující číslo článku zobrazení článku znalostní báze Microsoft Knowledge Base:
304349Vytvoření křížového dotazu v aplikaci Microsoft Access 2002
Další informace o vytváření Parametrické dotazy, klepněte na následující číslo článku v následujícím článku Microsoft Knowledge Base:
304352Vytvoření parametrického dotazu v aplikaci Microsoft Access 2002
Další informace o tom, jak Převeďte výběrový dotaz na akční dotaz, klepněte na následující číslo článku zobrazení článku znalostní báze Microsoft Knowledge Base:
304354JAK: Převod výběrového dotazu na akční dotaz v aplikaci Access
Další informace o úpravě dotazu vlastnosti, klepněte na následující číslo článku v následujícím článku Znalostní báze Microsoft Knowledge Base:
304356Úprava vlastností dotazu v aplikaci Microsoft Access
Stáhnout ukázkové aplikace Microsoft Access database obsahuje více než 20 Příklady dotazů, včetně technik popsaných v těchto články, naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
207626 "Access 2000 sample: query topics" databáze k dispozici v Centru pro stahování










Vlastnosti

ID článku: 304325 - Poslední aktualizace: 18. května 2011 - Revize: 6.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Access 2002 Standard Edition
Klíčová slova: 
kbquery kbdownload kbhowtomaster kbmt KB304325 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:304325

Dejte nám zpětnou vazbu