Cómo crear una consulta de selección en Access 2002

Seleccione idioma Seleccione idioma
Id. de artículo: 304325 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

En Microsoft Access, puede crear una consulta para recuperar información de una tabla o de varias tablas. A continuación, puede utilizar la consulta como base de un formulario, un informe o una página de acceso de datos. En este artículo se muestra cómo crear consultas sencillas en Microsoft Access y cómo aplicar la ordenación y criterios para las consultas. Este artículo contiene las secciones siguientes:
  • ¿Qué es una consulta de selección?
  • Cómo crear una consulta de selección mediante el Asistente para
  • Cómo crear una consulta SELECT en la vista Diseño
  • Cómo agregar criterios a la consulta
  • Cómo crear sumas, registros agrupados y otros totales
  • Cómo ordenar registros en una consulta

¿Qué es una consulta de selección?

Una consulta de selección es el tipo más común de consulta. Se utiliza para:
  • Recuperar datos de una o varias tablas mediante criterios que especifique y después mostrar los datos en el orden que desee.
  • Modificar y actualizar registros en la hoja de datos de una consulta de selección (con algunas restricciones).
  • Agrupar registros y calcular sumas, recuentos, promedios y otros tipos de totales.

Cómo crear una consulta de selección mediante el Asistente para

Los pasos siguientes muestran cómo crear una consulta para recuperar información acerca de los clientes y pedidos de la base de datos Neptuno incluida con Microsoft Access 2002.

Para obtener información adicional acerca de cómo ver la base de datos Neptuno, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
276376¿ACC2002: Dónde está el archivo de ejemplo Neptuno?
Precaución : Si sigue los pasos descritos en este ejemplo, modificará la base de datos de ejemplo Neptuno.mdb. Quizás desee hacer una copia de seguridad del archivo Neptuno.mdb y realizar estos pasos sobre una copia de la base de datos.

  1. Inicie Microsoft Access 2002.
  2. En el menú Ayuda , elija Bases de datos de ejemplo y, a continuación, haga clic en Base de datos . Cierre el formulario de Panel de control principal cuando aparezca.
  3. En el menú Ver , seleccione Objetos de base de datos y, a continuación, haga clic en consultas .
  4. En el menú Insertar , haga clic en consulta .
  5. En el cuadro de diálogo Nueva consulta , haga clic en Asistente para consultas sencillas y, a continuación, haga clic en Aceptar .
  6. En el cuadro de diálogo Asistente para consultas sencillas , haga clic en la tabla Customers de la lista Tablas y consultas . Haga doble clic en cada uno de los siguientes campos para agregarlos al cuadro Campos seleccionados : CustomerID , CompanyName , ContactName , ContactTitle .
  7. En la misma página del Asistente para consultas simples, haga clic en la tabla pedidos en la lista Tablas y consultas . Haga clic en >> para agregar todos los campos de la tabla Orders al cuadro Campos seleccionados .
  8. Haga clic en Finalizar . El Asistente para consultas sencillas crea la consulta y muestra los resultados en la vista Hoja de datos.

Cómo crear una consulta SELECT en la vista Diseño

  1. Inicie Microsoft Access 2002.
  2. En el menú Ayuda , elija Bases de datos de ejemplo y, a continuación, haga clic en Base de datos . Cierre el formulario de Panel de control principal cuando aparezca.
  3. En el menú Ver , seleccione Objetos de base de datos y, a continuación, haga clic en consultas .
  4. En la ventana base de datos, haga doble clic en Crear consulta en la vista Diseño .
  5. En el cuadro de diálogo Mostrar tabla , haga clic en clientes y a continuación, haga clic en Agregar .
  6. Repita el paso 5 para la tabla Orders.
  7. Haga clic en Cerrar para cerrar el cuadro de diálogo Mostrar tabla .
  8. En la lista campo de tabla de clientes en la mitad superior de la ventana de diseño de consulta, haga doble clic para agregar los siguientes campos: CustomerID , CompanyName , ContactName , ContactTitle .
  9. En la lista campo de tabla de pedidos en la mitad superior de la ventana de diseño de consulta, haga doble clic en el * . Agregar el * equivale a seleccionar todos los campos de una tabla determinada.
  10. En el menú archivo , haga clic en Guardar . Escriba qryCustomerOrders el nombre de la consulta.
  11. En el menú consulta , haga clic en Ejecutar para ver los resultados de la consulta.

Cómo agregar criterios a la consulta

Los pasos siguientes modificará la consulta que creó en la "crear un Seleccionar consulta en vista Diseño" anteriormente en este artículo.
  1. Inicie Microsoft Access 2002.
  2. En el menú Ayuda , elija Bases de datos de ejemplo y, a continuación, haga clic en Base de datos . Cierre el formulario de Panel de control principal cuando aparezca.
  3. En el menú Ver , seleccione Objetos de base de datos y, a continuación, haga clic en consultas .
  4. Haga clic en la consulta qryCustomerOrders que creó en la sección anterior y, a continuación, haga clic en Diseño para abrir la consulta en la vista Diseño.
  5. Haga doble clic en la lista de campos tabla Orders en la parte superior la mitad de la ventana de diseño de consulta, en el PaísDestinatario campo para agregarlo a la cuadrícula de diseño de consulta.
  6. En la columna PaísDeEnvío en la cuadrícula de diseño de la consulta, haga clic en para desactivar la casilla de verificación Mostrar . Debido a este campo está incluido seleccionando el * de la tabla Pedidos, si desactiva esta casilla de verificación evitará incluyendo el campo dos veces.
  7. Escriba Reino Unido en la fila criterios para el campo PaísDestinatario .
  8. En el menú archivo , haga clic en Guardar como . Escriba qryUKOrders el nombre de la consulta.
  9. En el menú consulta , haga clic en Ejecutar para ver los resultados de la consulta. Tenga en cuenta que la consulta devuelve los pedidos enviados al Reino Unido.

Cómo los registros de grupo y crear sumas y otros totales

Los pasos siguientes muestran cómo crear una consulta de totales para recuperar información de resumen sobre pedidos de la base de datos de ejemplo Northwind.
  1. Inicie Microsoft Access 2002.
  2. En el menú Ayuda , elija Bases de datos de ejemplo y, a continuación, haga clic en Base de datos . Cierre el formulario de Panel de control principal cuando aparezca.
  3. En el menú Ver , seleccione Objetos de base de datos y, a continuación, haga clic en consultas .
  4. En la ventana base de datos, haga doble clic en Crear consulta en la vista Diseño .
  5. En el cuadro de diálogo Mostrar tabla , haga clic para seleccionar pedidos y a continuación, haga clic en Agregar .
  6. Haga clic en Cerrar para cerrar el cuadro de diálogo Mostrar tabla .
  7. En la lista campo de tabla de pedidos en la mitad superior de la ventana de diseño de consulta, haga doble clic para agregar los siguientes campos: PaísDestinatario , transporte .
  8. En el menú Ver , haga clic en totales . Tenga en cuenta que una fila denominada total se agrega a la cuadrícula de diseño de consulta.
  9. Haga clic en la celda de fila total bajo la columna de transporte , haga clic en la flecha que aparece y, a continuación, haga clic en suma .
  10. En el menú archivo , haga clic en Guardar . Escriba qryFreightByCountry el nombre de la consulta.
  11. En el menú consulta , haga clic en Ejecutar para ver los resultados de la consulta. Observe que la consulta devuelve el flete total para cada país en la tabla Pedidos.

Cómo ordenar registros en una consulta

  1. Abra la consulta de qryFreightByCountry que creó en la sección "Agrupar registros y crear sumas y otros totales" en la vista Diseño.
  2. Haga clic en la celda de fila de orden bajo la columna transporte , haga clic en la flecha que aparece y, a continuación, haga clic en descendente .
  3. En el menú archivo , haga clic en Guardar como . Escriba qryFreightByCountrySorted el nombre de la consulta.
  4. En el menú consulta , haga clic en Ejecutar para ver los resultados de la consulta. Observe que la consulta devuelve el flete total para cada país en la tabla Pedidos, ordenados en orden descendente.



Referencias

Para obtener más información acerca de cómo crear consultas, haga clic en Ayuda de Microsoft Access en el menú Ayuda , escriba crear una consulta de selección en el Ayudante de Office o el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver los temas devueltos.

Esta información también está disponible en el Web en el siguiente sitio Web de Microsoft:
Create a select or crosstab query
Para obtener información adicional sobre cómo crear consultas de referencias cruzadas, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304349Cómo: Crear una consulta general en Microsoft Access 2002
Para obtener información adicional acerca de cómo crear consultas de parámetro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304352Cómo: Crear una consulta de parámetros en Microsoft Access 2002
Para obtener información adicional acerca de cómo convertir una consulta de selección en una consulta de acción, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304354Cómo: Convertir una consulta SELECT en una consulta de acción en Access
Para obtener información adicional acerca de cómo modificar las propiedades de una consulta, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304356Cómo modificar las propiedades de una consulta en Microsoft Access
Para descargar una base de datos de ejemplo Microsoft Access que contiene más de 20 ejemplos de consulta, incluyendo las técnicas descritas en estos artículos, consulte el artículo siguiente en Microsoft Knowledge Base:
207626La base de "Access 2000 ejemplo: consulta temas" datos disponible en el Centro de descarga










Propiedades

Id. de artículo: 304325 - Última revisión: jueves, 29 de marzo de 2007 - Versión: 4.2
La información de este artículo se refiere a:
  • Microsoft Access 2002 Standard Edition
Palabras clave: 
kbmt kbquery kbdownload kbhowtomaster KB304325 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 304325

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com