COMMENT FAIRE : Création d'une requête Sélection dans Microsoft Access 2002

Traductions disponibles Traductions disponibles
Numéro d'article: 304325 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F304325
Agrandir tout | Réduire tout

Sommaire

Résumé

Microsoft Access vous permet de créer une requête destinée à récupérer des informations à partir d'une ou plusieurs tables. Vous pouvez aussi utiliser cette requête comme base d'un formulaire, d'un état ou d'une page d'accès aux données. Cet article explique comment créer des requêtes simples dans Microsoft Access et comment appliquer un tri et des critères à vos requêtes. Cet article est subdivisé comme suit :
  • Présentation d'une requête Sélection
  • Création d'une requête Sélection à l'aide de l'assistant
  • Création d'une requête Sélection en mode Création
  • Ajout de critères à votre requête
  • Regroupement d'enregistrements et création de sommes et autres totaux
  • Tri des enregistrements dans une requête

Présentation d'une requête Sélection

La requête Sélection correspond au type de requête le plus courant. Vous pouvez recourir à une telle requête pour effectuer les opérations suivantes :
  • récupérer des données contenues dans une ou plusieurs tables en fonction de critères spécifiés par vos soins, puis afficher ces données dans l'ordre de votre choix ;
  • modifier et mettre à jour des enregistrements dans une feuille de données d'une requête Sélection (sous réserve de quelques modifications) ;
  • regrouper des enregistrements et calculer une somme, une moyenne ou effectuer un comptage ou tout autre type d'opération.

Création d'une requête Sélection à l'aide de l'assistant

Les étapes suivantes décrivent comment créer une requête destinée à récupérer des informations sur des clients et des commandes figurant dans la base de données exemple Les Comptoirs, fournie avec Microsoft Access 2002.

Pour plus d'informations sur la base de données exemple Les Comptoirs, cliquez sur le numéro d?article ci-dessous afin d'afficher le document correspondant de la Base de connaissances Microsoft :
276376 Où se trouvent les fichiers d'exemples Northwind (Les Comptoirs) ?
ATTENTION : Si vous suivez les étapes décrites dans cet exemple, vous modifierez la base de données exemple Comptoirs.mdb. Le cas échéant, vous pouvez effectuer une copie de sauvegarde de ce fichier, puis exécuter la procédure sur la copie de la base de données.

  1. Démarrez Microsoft Access 2002.
  2. Dans le menu Aide (?), pointez sur Exemples de base de données, puis cliquez sur Exemple de base de données Les Comptoirs. Fermez le formulaire Menu général qui s'affiche.
  3. Dans le menu Affichage, pointez sur Objets de la base, puis cliquez sur Requêtes.
  4. Dans le menu Insertion, cliquez sur Requête.
  5. Dans la boîte de dialogue Nouvelle requête, cliquez sur Assistant Requête simple, puis cliquez sur OK.
  6. Dans la boîte de dialogue Assistant Requête simple, sélectionnez la table Clients dans la zone de liste Tables/Requêtes. Double-cliquez sur chacun des champs suivants pour les ajouter à la zone Champs sélectionnés : Code client, Société, Contact, Fonction.
  7. Toujours dans cette page de l'Assistant Requête simple, sélectionnez la table Commandes dans la zone de liste Tables/Requêtes. Cliquez sur >> pour ajouter l'ensemble des champs de la table Commandes à la zone Champs sélectionnés.
  8. Cliquez sur Terminer. L'Assistant Requête simple crée la requête et affiche le résultats en mode Feuille de données.

Création d'une requête Sélection en mode Création

  1. Démarrez Microsoft Access 2002.
  2. Dans le menu Aide (?), pointez sur Exemples de base de données, puis cliquez sur Exemple de base de données Les Comptoirs. Fermez le formulaire Menu général qui s'affiche.
  3. Dans le menu Affichage, pointez sur Objets de la base, puis cliquez sur Requêtes.
  4. Dans la fenêtre Base de données, double-cliquez sur Créer une requête en mode Création.
  5. Dans la boîte de dialogue Afficher la table, cliquez sur Clients, puis sur Ajouter.
  6. Répétez l'étape 5 pour la table Commandes.
  7. Cliquez sur Fermer pour fermer la boîte de dialogue Afficher la table.
  8. Dans la liste des champs de la table Clients figurant dans la moitié supérieure de la fenêtre de création d'une requête, double-cliquez sur les champs suivants de manière à les ajouter à la table : Code client, Société, Contact, Fonction.
  9. Dans la liste des champs de la table Commandes affichée dans la moitié supérieure de la fenêtre de création d'une requête, double-cliquez sur *. L'ajout du signe * équivaut à sélectionner l'ensemble des champs d'une table donnée.
  10. Dans le menu Fichier, cliquez sur Enregistrer. Tapez requêteClientsCommandes comme nom pour cette requête.
  11. Dans le menu Requête, cliquez sur Exécuter pour afficher les résultats de la requête.

Ajout de critères à votre requête

Les étapes ci-dessous modifieront la requête que vous avez créée dans la section « Création d'une requête Sélection en mode Création » de cet article.
  1. Démarrez Microsoft Access 2002.
  2. Dans le menu Aide (?), pointez sur Exemples de base de données, puis cliquez sur Exemple de base de données Les Comptoirs. Fermez le formulaire Menu général qui s'affiche.
  3. Dans le menu Affichage, pointez sur Objets de la base, puis cliquez sur Requêtes.
  4. Cliquez sur la requête requêteClientsCommandes créée précédemment, puis cliquez sur Mode Création pour ouvrir la requête en mode Création.
  5. Dans la liste des champs de la table Commandes figurant dans la moitié supérieure de la fenêtre de création d'une requête, double-cliquez sur le champ PaysExpédition pour l'ajouter à la grille de création de la requête.
  6. Dans la colonne PaysExpédition de la grille de création, désactivez la case à cocher Afficher. Dans la mesure où ce champ est déjà inclus par votre sélection de l'option * dans la table Commandes, la désactivation de cette case à cocher permet d'éviter d'inclure ce champ à deux reprises.
  7. Entrez FR dans la ligne Critères sous le champ PaysExpédition.
  8. Dans le menu Fichier, cliquez sur Enregistre sous. Tapez requêteCommandesFR comme nom pour cette requête.
  9. Dans le menu Requête, cliquez sur Exécuter pour afficher les résultats de la requête. Comme vous pouvez le constater, la requête renvoie uniquement les commandes qui ont été expédiées vers la France.

Regroupement d'enregistrements et création de sommes et autres totaux

Les étapes suivantes décrivent comment créer une requête Totaux destinée à récupérer des informations récapitulatives sur des commandes provenant de la base de données exemple Les Comptoirs.
  1. Démarrez Microsoft Access 2002.
  2. Dans le menu Aide (?), pointez sur Exemples de base de données, puis cliquez sur Exemple de base de données Les Comptoirs. Fermez le formulaire Menu général qui s'affiche.
  3. Dans le menu Affichage, pointez sur Objets de la base, puis cliquez sur Requêtes.
  4. Dans la fenêtre Base de données, double-cliquez sur Créer une requête en mode Création.
  5. Dans la boîte de dialogue Afficher la table, sélectionnez Commandes, puis cliquez sur Ajouter.
  6. Cliquez sur Fermer pour fermer la boîte de dialogue Afficher la table.
  7. Dans la liste des champs de la table Commandes figurant dans la moitié supérieure de la fenêtre de création d'une requête, double-cliquez sur les champs suivants de manière à les ajouter à la table : PaysExpédition, Port.
  8. Dans le menu Affichage, cliquez sur Totaux. Notez qu'une ligne baptisée Total est ajoutée à la grille de création de la requête.
  9. Cliquez dans la ligne Total de la colonne Port, puis cliquez sur la flèche qui s'affiche et cliquez ensuite sur Somme.
  10. Dans le menu Fichier, cliquez sur Enregistrer. Tapez requêtePortParPays comme nom pour cette requête.
  11. Dans le menu Requête, cliquez sur Exécuter pour afficher les résultats de la requête. Comme vous pouvez le constater, la requête renvoie le port total correspondant à chaque pays de la table Commandes.

Tri des enregistrements dans une requête

  1. Ouvrez la requête requêtePortParPays créée dans la section « Regroupement d'enregistrements et création de sommes et autres totaux » en mode Création.
  2. Cliquez dans la ligne Tri de la colonne Port, puis cliquez sur la flèche qui s'affiche et cliquez ensuite sur Décroissant.
  3. Dans le menu Fichier, cliquez sur Enregistre sous. Tapez requêtePortParPaysTrié comme nom pour cette requête.
  4. Dans le menu Requête, cliquez sur Exécuter pour afficher les résultats de la requête. Comme vous pouvez le constater, la requête renvoie le port total correspondant à chaque pays de la table Commandes, trié par ordre décroissant.



Références

Pour plus d'informations sur la création de requêtes, cliquez sur Aide sur Microsoft Access dans le menu Aide (?), tapez création d'une requête sélection dans le Compagnon Office ou l'Aide intuitive, puis cliquez sur Rechercher pour afficher les rubriques renvoyées.

Ces informations sont également disponibles sur le site Web de Microsoft accessible en cliquant sur le lien ci-dessous :
Création d'une requête Sélection ou Analyse croisée
Pour plus d'informations sur la création de requêtes Analyse croisée, cliquez sur le numéro d?article ci-dessous afin d'afficher le document correspondant de la Base de connaissances Microsoft :
304349 ACC2002 : Création d'une requête Analyse croisée dans Microsoft Access
Pour plus d'informations sur la création de requêtes avec paramètres, cliquez sur le numéro d?article ci-dessous afin d'afficher le document correspondant de la Base de connaissances Microsoft :
304352 ACC2002 : Création d'une requête avec paramètres dans Microsoft Access
Pour plus d'informations sur la conversion d'une requête Sélection en une requête Action, cliquez sur le numéro d'article ci-dessous afin d'afficher le document correspondant de la Base de connaissances Microsoft :
304354 ACC2002 : Conversion d'une requête Sélection en une requête Action
Pour plus d'informations sur la modification des propriétés d'une requête, cliquez sur le numéro d?article ci-dessous afin d'afficher le document correspondant de la Base de connaissances Microsoft :
304356 ACC2002 : Modification des propriétés d'une requête dans Microsoft Access
Pour télécharger une base de données exemple Microsoft Access qui contient plus de 20 exemples de requêtes, y compris les techniques décrites dans ces articles, consultez l'article suivant dans la Base de connaissances Microsoft :
207626 ACC2002 : Exemples de requêtes Access 2000 disponibles auprès du Centre de téléchargement










Propriétés

Numéro d'article: 304325 - Dernière mise à jour: mercredi 11 août 2004 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Access 2002
Mots-clés : 
kbhowto kbhowtomaster kbdownload kbdta KB304325
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com