Como criar uma consulta de selecção no Access 2002

Traduções de Artigos Traduções de Artigos
Artigo: 304325 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sumário

No Microsoft Access, pode criar uma consulta para obter informações a partir de uma tabela ou de várias tabelas. Em seguida, pode utilizar a consulta como a base de um formulário, relatório ou página de acesso a dados. Este artigo mostra como criar consultas simples no Microsoft Access e como aplicar a ordenação e critérios para as consultas. Este artigo contém as seguintes secções:
  • O que é uma consulta selecção?
  • Como criar uma consulta seleccionar utilizando o Assistente
  • Como criar uma consulta seleccionar na vista de estrutura
  • Como adicionar critérios de consulta
  • Como registos de grupo e criar somas e outros totais
  • Como ordenar registos numa consulta

O que é uma consulta selecção?

Uma consulta selecção é o tipo mais comum de consulta. É utilizado para:
  • Obter dados de uma ou mais tabelas utilizando critérios que especificar e, em seguida para apresentar os dados pela ordem que pretende.
  • Editar e actualizar registos na folha de dados de uma consulta selecção (com algumas restrições).
  • Agrupar registos e calcular somas, contagens, médias e outros tipos de totais.

Como criar uma consulta seleccionar utilizando o Assistente

Os seguintes passos mostram como criar uma consulta para obter informações sobre clientes e encomendas de base de dados de exemplo Adamastor, incluída no Microsoft Access 2002.

Para obter informações adicionais sobre como visualizar a base de dados de exemplo Adamastor, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
276376ACC2002: Onde estão os ficheiros de exemplo Adamastor?
atenção : Se seguir os passos neste exemplo, modificará a base de dados de exemplo Adamastor.mdb. Convém cópia de segurança do ficheiro de base de dados Adamastor.mdb e siga estes passos numa cópia da base de dados.

  1. Inicie o Microsoft Access 2002.
  2. No menu Ajuda , aponte para Bases de dados de exemplo e, em seguida, clique em Base de dados de exemplo Adamastor . Feche o formulário Painel de navegação principal quando aparece.
  3. No menu Ver , aponte para Objectos de base de dados e, em seguida, clique em consultas .
  4. No menu Inserir , clique em consulta .
  5. Na caixa de diálogo Nova consulta , clique em Assistente de consultas simples e, em seguida, clique em OK .
  6. Na caixa de diálogo Assistente de consultas simples , clique na tabela clientes na lista de Tabelas/consultas . Faça duplo clique em cada um dos seguintes campos para os adicionar a caixa Campos seleccionados : CódigoDoCliente NomeDaEmpresa , ContactName , TítuloParaContacto .
  7. Na mesma página do Assistente de consultas simples, clique na tabela encomendas na lista de Tabelas/consultas . Clique em >> para adicionar todos os campos da tabela Encomendas à caixa de Campos seleccionados .
  8. Clique em Concluir . Assistente de consultas simples constrói a consulta e apresenta os resultados na vista de folha de dados.

Como criar uma consulta seleccionar na vista de estrutura

  1. Inicie o Microsoft Access 2002.
  2. No menu Ajuda , aponte para Bases de dados de exemplo e, em seguida, clique em Base de dados de exemplo Adamastor . Feche o formulário Painel de navegação principal quando aparece.
  3. No menu Ver , aponte para Objectos de base de dados e, em seguida, clique em consultas .
  4. Na janela Base de dados, faça duplo clique Criar consulta na vista de estrutura .
  5. Na caixa de diálogo Mostrar tabela , clique em clientes e, em seguida, clique em Adicionar .
  6. Repita o passo 5 para a tabela Encomendas.
  7. Clique em Fechar para fechar a caixa de diálogo Mostrar tabela .
  8. Na lista clientes tabela campo na parte superior da janela de estrutura da consulta, faça duplo clique para adicionar os seguintes campos: CódigoDoCliente NomeDaEmpresa , ContactName , TítuloParaContacto .
  9. Na lista encomendas tabela campo na parte superior da janela de estrutura da consulta, faça duplo clique no * . Adicionar o * é o equivalente de seleccionar todos os campos de uma tabela específica.
  10. No menu ficheiro , clique em Guardar . Escreva qryCustomerOrders para o nome da consulta.
  11. No menu consulta , clique em Executar para ver os resultados da consulta.

Como adicionar critérios de consulta

Os seguintes passos irão modificar a consulta que criou no "Criar um Seleccionar consulta na vista de estrutura" neste artigo.
  1. Inicie o Microsoft Access 2002.
  2. No menu Ajuda , aponte para Bases de dados de exemplo e, em seguida, clique em Base de dados de exemplo Adamastor . Feche o formulário Painel de navegação principal quando aparece.
  3. No menu Ver , aponte para Objectos de base de dados e, em seguida, clique em consultas .
  4. Clique na consulta qryCustomerOrders que criou na secção anterior e, em seguida, clique em estrutura para abrir a consulta na vista de estrutura.
  5. Na lista de campo de tabela encomendas na parte superior metade da janela de estrutura da consulta, faça duplo clique o campo PaísDoDestino para adicionar este à grelha de estrutura da consulta.
  6. Na coluna PaísDoDestino na grelha de estrutura da consulta, clique para desmarcar a caixa de verificação Mostrar . Dado que este campo está incluído, seleccionando o * da tabela Encomendas, se desmarcar esta caixa de verificação irá Evite incluir o campo duas vezes.
  7. Introduza o Reino Unido na linha critérios para o campo PaísDoDestino .
  8. No menu ficheiro , clique em Guardar como . Escreva qryUKOrders para o nome da consulta.
  9. No menu consulta , clique em Executar para ver os resultados da consulta. Tenha em atenção que a consulta devolve as encomendas que foram enviadas para o Reino Unido.

Como registos de grupo e criar somas e outros totais

Os seguintes passos mostram como criar uma consulta de totais para obter informações resumidas sobre encomendas da base de dados de exemplo Adamastor.
  1. Inicie o Microsoft Access 2002.
  2. No menu Ajuda , aponte para Bases de dados de exemplo e, em seguida, clique em Base de dados de exemplo Adamastor . Feche o formulário Painel de navegação principal quando aparece.
  3. No menu Ver , aponte para Objectos de base de dados e, em seguida, clique em consultas .
  4. Na janela Base de dados, clique duas vezes Criar consulta na vista de estrutura .
  5. Na caixa de diálogo Mostrar tabela , clique para seleccionar encomendas e, em seguida, clique em Adicionar .
  6. Clique em Fechar para fechar a caixa de diálogo Mostrar tabela .
  7. Na lista encomendas tabela campo na parte superior da janela de estrutura da consulta, faça duplo clique para adicionar os seguintes campos: PaísDoDestino , Frete .
  8. No menu Ver , clique em totais . Repare que uma linha com o nome total é adicionada à grelha de estrutura da consulta.
  9. Clique na célula linha total na coluna de transporte , clique na seta que aparece e, em seguida, clique em Soma .
  10. No menu ficheiro , clique em Guardar . Escreva qryFreightByCountry para o nome da consulta.
  11. No menu consulta , clique em Executar para ver os resultados da consulta. Tenha em atenção que a consulta devolve o frete total para cada país na tabela Encomendas.

Como ordenar registos numa consulta

  1. Abra a consulta qryFreightByCountry que criou na secção "Agrupar registos e criar somas e outros totais" na vista de estrutura.
  2. Clique na célula Ordenar linha na coluna de transporte , clique na seta que aparece e, em seguida, clique em Descendente .
  3. No menu ficheiro , clique em Guardar como . Escreva qryFreightByCountrySorted para o nome da consulta.
  4. No menu consulta , clique em Executar para ver os resultados da consulta. Tenha em atenção que a consulta devolve o frete total para cada país na tabela Encomendas, ordenada por ordem descendente.



Referências

Para mais informações sobre como criar consultas, clique em Ajuda do Microsoft Access no menu de Ajuda escreva criar uma consulta selecção no Assistente do Office ou no Assistente de respostas e, em seguida, clique em Procurar para visualizar os tópicos devolvidos.

Estas informações também estão disponíveis na World Wide Web no seguinte Web site da Microsoft:
Create a select or crosstab query
Para obter informações adicionais sobre como criar consultas de referência cruzada, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
304349COMO: Criar uma consulta tabela de referência cruzada no Microsoft Access 2002
Para obter informações adicionais sobre como criar consultas parametrizadas, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
304352COMO: Criar uma consulta parametrizada no Microsoft Access 2002
Para obter informações adicionais sobre como converter uma consulta de selecção para uma consulta de acção, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
304354COMO: Converter uma consulta selecção para uma consulta de acção no Access
Para obter informações adicionais sobre como modificar as propriedades da consulta, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
304356Como modificar propriedades de consulta no Microsoft Access
Para transferir uma base de dados de Microsoft Access de exemplo que contém mais de 20 exemplos de consulta, incluindo as técnicas descritas nestes artigos, consulte o seguinte artigo na base de dados de conhecimento da Microsoft:
207626A base de dados "Access 2000 exemplo: consulta tópicos" que disponíveis no Centro de transferências










Propriedades

Artigo: 304325 - Última revisão: 29 de março de 2007 - Revisão: 4.2
A informação contida neste artigo aplica-se a:
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbmt kbquery kbdownload kbhowtomaster KB304325 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 304325

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com