Como criar uma consulta seleção no Access 2002

Traduções deste artigo Traduções deste artigo
ID do artigo: 304325 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi publicado anteriormente em BR304325
Expandir tudo | Recolher tudo

Neste artigo

Sumário

No Microsoft Access, é possível criar uma consulta para recuperar informações de uma ou várias tabelas. É possível também usar a consulta como base de um formulário, relatório ou página de acesso a dados. Este artigo mostra como criar consultas simples no Microsoft Access e como aplicar classificação e critérios nas consultas. Este artigo contém das seguintes seções:
  • O que é uma Consulta seleção?
  • Como criar uma Consulta seleção usando o Assistente
  • Como criar uma Consulta seleção no Modo Design
  • Como adicionar critérios à consulta
  • Como agrupar registros e criar somas e outros totais
  • Como classificar registros em uma consulta

O que é uma Consulta seleção?

Uma consulta seleção é o tipo mais comum de consulta. É usada para:
  • Recuperar dados de uma ou mais tabelas usando critérios especificados pelo usuário e exibi-los na ordem desejada.
  • Editar e atualizar registros na planilha de dados de uma consulta seleção (com algumas restrições).
  • Agrupar registros e calcular somas, contas, médias entre outros tipos de totais.

Como criar uma Consulta seleção usando o Assistente

As etapas a seguir mostram como criar uma consulta para recuperar informações sobre clientes e pedidos do banco de dados de exemplo da Northwind incluído no Microsoft Access 2002.

Para obter informações adicionais sobre o modo de exibição do banco de dados de exemplo da Northwind, clique no seguinte número para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
276376 ACC2002: onde estão localizados os arquivos de exemplo da Northwind?
CUIDADO: Se executar as etapas a seguir neste exemplo, você modificará o banco de dados de exemplo Northwind.mdb. Pode convir fazer backup do arquivo Northwind.mdb e executar as seguintes etapas em uma cópia do banco de dados.

  1. Inicie o Microsoft Access 2002.
  2. No menu Ajuda, aponte para Bancos de dados de exemplo e clique em Banco de dados de exemplo da Northwind. Feche o formulário Menu de Controle Principal quando for exibido.
  3. No menu Exibir, aponte para Objetos de banco de dados e clique em Consultas.
  4. No menu Inserir, clique em Consulta.
  5. Na caixa de diálogo Nova consulta, clique em Assistente de consulta simples e em OK.
  6. Na caixa de diálogo Assistente de consulta simples, clique na tabela Clientes da lista Tabelas/consultas. Clique duas vezes em cada um dos seguintes campos para adicioná-los à caixa Campos selecionados: CódigoDoCliente, NomeDaEmpresa, NomeDoContato e CargoDoContato.
  7. Na mesma página do Assistente de consulta simples, clique na tabela Pedidos da lista Tabelas/consultas. Clique em >> para adicionar todos os campos da tabela Pedidos à caixa Campos selecionados.
  8. Clique em Concluir. O Assistente de consulta simples constrói a consulta e exibe os resultados no Modo folha de dados.

Como criar uma Consulta seleção no Modo Design

  1. Inicie o Microsoft Access 2002.
  2. No menu Ajuda, aponte para Bancos de dados de exemplo e clique em Banco de dados de exemplo da Northwind. Feche o formulário Menu de Controle Principal quando for exibido.
  3. No menu Exibir, aponte para Objetos de banco de dados e clique em Consultas.
  4. Na janela Banco de dados, clique duas vezes em Criar consulta no Modo Design.
  5. Na caixa de diálogo Mostrar tabela, clique em Clientes e em Adicionar.
  6. Repita a etapa 5 para a tabela Pedidos.
  7. Clique em Fechar para fechar a caixa de diálogo Mostrar tabela.
  8. Na lista de campos da tabela Clientes na metade superior da janela de design da consulta, clique duas vezes para adicionar os seguintes campos: CódigoDoCliente, NomeDaEmpresa, NomeDoContato e CargoContato.
  9. Na lista de campos da tabela Pedidos na metade superior da janela de design da consulta, clique duas vezes em *. A adição do * é equivalente a seleção de todos os campos de uma determinada tabela.
  10. No menu Arquivo, clique em Salvar. Digite qryCustomerOrders como nome da consulta.
  11. No menu Consulta, clique em Executar para exibir os resultados da consulta.

Como adicionar critérios à consulta

As seguintes etapas modificarão a consulta criada na seção "Como criar uma Consulta seleção no Modo Design" anteriormente neste artigo.
  1. Inicie o Microsoft Access 2002.
  2. No menu Ajuda, aponte para Bancos de dados de exemplo e clique em Banco de dados de exemplo da Northwind. Feche o formulário Menu de Controle Principal quando for exibido.
  3. No menu Exibir, aponte para Objetos de banco de dados e clique em Consultas.
  4. Clique na consulta qryCustomerOrders criada na seção anterior, e em Design para abrir a consulta no Modo Design.
  5. Na lista de campos da tabela Pedidos, na metade superior da janela de design da consulta, clique duas vezes no campo PaísEnvio para adicioná-lo à grade de design da consulta.
  6. Na coluna PaísDeDestino na grade de design da consulta, desmarque a caixa de seleção Mostrar. Como esse campo é incluído ao selecionar * da tabela Pedidos, desmarque esta caixa de seleção para que o campo não seja incluído duas vezes.
  7. Insira UK na linha Critérios do campo PaísDeDestino.
  8. No menu Arquivo, clique em Salvar como. Digite qryUKOrders como nome da consulta.
  9. No menu Consulta, clique em Executar para exibir os resultados da consulta. Observe que a consulta retorna aqueles pedidos que foram enviados para o Reino Unidos (UK).

Como agrupar registros e criar somas e outros totais

As seguintes etapas mostram como criar uma consulta de totais para recuperar informações de resumo sobre pedidos no banco de dados de exemplo Northwind.
  1. Inicie o Microsoft Access 2002.
  2. No menu Ajuda, aponte para Bancos de dados de exemplo e clique em Banco de dados de exemplo da Northwind. Feche o formulário Menu de Controle Principal quando for exibido.
  3. No menu Exibir, aponte para Objetos de banco de dados e clique em Consultas.
  4. Na janela Banco de dados, clique duas vezes em Criar consulta no Modo Design.
  5. Na caixa de diálogo Mostrar tabela, clique em Pedidos e em Adicionar.
  6. Clique em Fechar para fechar a caixa de diálogo Mostrar tabela.
  7. Na lista de campos da tabela Pedidos na metade superior da janela de design da consulta, clique duas vezes para adicionar os seguintes campos: PaísDeDestino, Frete.
  8. No menu Exibir, clique em Totais. Observe que uma linha chamada Total é adicionada à grade de design da consulta.
  9. Clique na linha Total abaixo na coluna Frete, clique na seta que é exibida e em Soma.
  10. No menu Arquivo, clique em Salvar. Digite qryFreightByCountry como nome da consulta.
  11. No menu Consulta, clique em Executar para exibir os resultados da consulta. Atente para o fato de que a consulta retorna o frete total para cada país da tabela Pedidos.

Como classificar registros em uma consulta

  1. Abra a consulta qryFreightByCountry criada na seção "Como agrupar registros e criar somas e outros totais" no Modo Design.
  2. Clique na linha Classificar na coluna Frete, clique na seta que é exibida e em Decrescente.
  3. No menu Arquivo, clique em Salvar como. Digite qryFreightByCountrySorted como nome da consulta.
  4. No menu Consulta, clique em Executar para exibir os resultados da consulta. Observe que a consulta retorna o frete total para cada país da tabela Pedidos, classificados em ordem decrescente.



Referências

Para obter mais informações sobre como criar consultas, clique em Ajuda do Microsoft Access no menu Ajuda, digite criar uma consulta seleção no Assistente do Office ou no Assistente de respostas e clique em Pesquisar para exibir os tópicos retornados.

Essas informações também estão disponíveis no seguinte site da Microsoft:
Criar uma consulta seleção ou uma consulta de tabela de referência cruzada
Para obter informações adicionais sobre como criar consultas de tabela de referência cruzada, clique no seguinte número para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
304349 COMO: criar uma consulta de tabela de referência cruzada no Microsoft Access 2002
Para obter mais informações sobre como criar consultas parâmetro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
304352 COMO: criar uma consulta parâmetro no Microsoft Access 2002
Para obter informações adicionais sobre como converter uma consulta seleção em uma consulta ação, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
304354 COMO: converter uma consulta seleção em uma consulta ação no Access
Para obter informações adicionais sobre como modificar propriedades da consulta, clique no seguinte número para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
304356 Como modificar propriedades da consulta no Microsoft Access
Para baixar um banco de dados de exemplo do Microsoft Access com mais de 20 exemples de consultas, incluindo as técnicas descritas nestes artigos, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
207626 O banco de dados "Amostra do Access 2000: tópicos de consultas" disponível no Centro de Download










Propriedades

ID do artigo: 304325 - Última revisão: quinta-feira, 22 de março de 2007 - Revisão: 4.1
A informação contida neste artigo aplica-se a:
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbquery kbdownload kbhowtomaster KB304325

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com