Access 2002'de bir seçme sorgusu oluşturma

Makale çevirileri Makale çevirileri
Makale numarası: 304325 - Bu makalenin geçerli olduğu ürünleri görün.
Hepsini aç | Hepsini kapa

Bu Sayfada

Özet

Microsoft Access'te, bir tablodan veya birden çok tablodan bilgi almak için bir sorgu oluşturabilirsiniz. Daha sonra sorgu, form, rapor veya veri erişim sayfası temeli olarak kullanabilirsiniz. Bu makalede, Microsoft Access, sıralama, uygulama ve sorgularınızı ölçütlere basit bir sorgu oluşturmak gösterilmiştir. Bu makale aşağıdaki bölümleri içerir:
  • Bir seçme sorgusu nedir?
  • Sihirbazı kullanarak bir seçme sorgusu oluşturma
  • Tasarım görünümünde bir seçme sorgusu oluşturma
  • Bilgisayarınızı bir sorgu için ölçüt ekleme
  • Kayıtları Gruplandır ve Create toplamlarını ve diğer araçlar
  • Sorguda kayıtları Sırala nasıl

Bir seçme sorgusu nedir?

Seçme sorgusu en yaygın sorgu türüdür. Için kullanın:
  • Belirttiğiniz ölçütleri kullanarak, bir veya daha fazla tablodan veri almak ve verileri istediğiniz sırayla görüntülemek için.
  • Düzenleme ve veri sayfasını seçme sorgusu (bazı kısıtlamalarla) kayıtlarında güncelleştirme.
  • Kayıtları gruplandırmak ve toplamların, sayıları, ortalamaları ve diğer toplam türlerini hesaplamak.

Sihirbazı kullanarak bir seçme sorgusu oluşturma

Aşağıdaki adımlar, Microsoft Access 2002 ile bulunan Northwind örnek veritabanındaki, müşteriler ve siparişler hakkında bilgi almak için sorgu oluşturma konusunda gösterir.

Northwind örnek veritabanındaki görüntüleme hakkında ek bilgi için Microsoft Knowledge Base'deki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
276376ACC2002:, Northwind örnek dosyaları nerede?
DIKKAT: Bu örnekteki adımları, Northwind.mdb adlı örnek veritabanını değiştirme. Northwind.mdb dosyasını yedekleyin ve bu adımları veritabanının bir kopyasında isteyebilirsiniz.

  1. Microsoft Access 2002'yi başlatın.
  2. Yardım menüsünden, Örnek veritabanı ' nın üzerine gelin ve Northwind örnek veritabanı</a1>'ı tıklatın. Görüntülendiğinde, Ana geçiş panosu formu kapatın.
  3. Görünüm) menüsünde, Veritabanı nesnelerini gelin ve ardından sorgular ' ı tıklatın.
  4. Ekle menüsünden Query ' ı tıklatın.
  5. Yeni form iletişim kutusunda, Basit Sorgu Sihirbazı ' nı tıklatın ve sonra Tamam ' ı tıklatın.
  6. Basit Sorgu Sihirbazı iletişim kutusunda <a0>Tablolar/Sorgular</a0> listesinde <a2>Müşteriler</a2> tablosunu tıklatın. Her biri aşağıdaki alanlar için <a1>Seçili alanlar</a1> kutusunu eklemek için çift tıklatın: MüşteriNoŞirketAdı, KişiAdı, KişiÜnvanı.
  7. Basit Sorgu Sihirbazı'nı aynı sayfada, siparişler tablosu <a0>Tablolar/Sorgular</a0> listesinde tıklatın. >>'ı tıklatın. Siparişler tablosundan tüm alanlar için <a1>Seçili alanlar</a1> kutusunu eklemek için.
  8. Son ' u tıklatın. Basit Sorgu Sihirbazı, sorgu oluşturur ve sonuçları veri sayfası görünümünde görüntüler.

Tasarım görünümünde bir seçme sorgusu oluşturma

  1. Microsoft Access 2002'yi başlatın.
  2. Yardım menüsünden, Örnek veritabanı ' nın üzerine gelin ve Northwind örnek veritabanı</a1>'ı tıklatın. Görüntülendiğinde, Ana geçiş panosu formu kapatın.
  3. Görünüm) menüsünde, Veritabanı nesnelerini gelin ve ardından sorgular ' ı tıklatın.
  4. Veritabanı penceresinde, Tasarım görünümünde sorgu oluştur'ni çift tıklatın.
  5. Tablo Göster iletişim kutusunda, Müşteriler ' i tıklatın ve sonra Ekle ' yi tıklatın.
  6. Adım 5, Siparişler tablosu için yineleyin.
  7. <a0>Tablo Göster</a0> iletişim kutusunu kapatmak için Kapat ' ı tıklatın.
  8. Sorgu Tasarım penceresinin üst yarısında Müşteriler tablosundaki alan listesinde, aşağıdaki alanları eklemek için çift tıklatın: MüşteriNoŞirketAdı, KişiAdı, KişiÜnvanı.
  9. Sorgu Tasarım penceresinin üst yarısında siparişler tablosundaki alan listesinde çift *. Ekleme * belirli bir tablodan tüm alanları seçme eşdeğerdir.
  10. Dosya menüsünde Kaydet ' i tıklatın. QryCustomerOrders sorgu adını yazın.
  11. Sorgu) menüsünde, sorgunun sonuçlarını görüntülemek için Çalıştır ' ı tıklatın.

Bilgisayarınızı bir sorgu için ölçüt ekleme

Aşağıdaki adımlar, "Creating bir Seç Query içinde Tasarım görünümünde" Bu makalede daha önce oluşturduğunuz sorguyu değiştirir.
  1. Microsoft Access 2002'yi başlatın.
  2. Yardım menüsünden, Örnek veritabanı ' nın üzerine gelin ve Northwind örnek veritabanı</a1>'ı tıklatın. Görüntülendiğinde, Ana geçiş panosu formu kapatın.
  3. Görünüm) menüsünde, Veritabanı nesnelerini gelin ve ardından sorgular ' ı tıklatın.
  4. Önceki bölümde oluşturduğunuz qryCustomerOrders sorgu'ı tıklatın ve sonra sorguyu Tasarım görünümünde açmak için Tasarım ' ı tıklatın.
  5. Siparişler tablosu alan listesinde üst yarısı sorgu Tasarım penceresinde, sorgu tasarım kılavuzuna eklenecek Sevk Ülkesi alanı çift tıklatın.
  6. Sorgu tasarım kılavuzundaki ShipCountry sütununda Göster onay kutusunu temizlemek için tıklatın. Bu alanı seçerek yer olmadığından * Siparişler tablosundan, bu onay kutusu temizlenirse alanı dahil olmak üzere iki kez önlemek.
  7. INGILTERE ' de <a2>ölçüt</a2> satırında Sevk Ülkesi alanı için girin.
  8. Dosya menüsünden farklı Kaydet ' i tıklatın. QryUKOrders sorgu adını yazın.
  9. Sorgu) menüsünde, sorgunun sonuçlarını görüntülemek için Çalıştır ' ı tıklatın. INGILTERE için sevk edilen siparişler bu sorguyu döndüren unutmayın.

Kayıtları Gruplandır nasıl ve toplamların ve diğer toplam oluştur

Aşağıdaki adımlarda Northwind örnek veritabanındaki Siparişler hakkında özet bilgi almak için bir toplam sorgusu oluşturmak göstermektedir.
  1. Microsoft Access 2002'yi başlatın.
  2. Yardım menüsünden, Örnek veritabanı ' nın üzerine gelin ve Northwind örnek veritabanı</a1>'ı tıklatın. Görüntülendiğinde, Ana geçiş panosu formu kapatın.
  3. Görünüm) menüsünde, Veritabanı nesnelerini gelin ve ardından sorgular ' ı tıklatın.
  4. Veritabanı penceresinde, Tasarım görünümünde sorgu oluştur'ni çift tıklatın.
  5. Tablo Göster iletişim kutusunda, siparişler ' i tıklatıp seçin ve Ekle ' yi tıklatın.
  6. <a0>Tablo Göster</a0> iletişim kutusunu kapatmak için Kapat ' ı tıklatın.
  7. Sorgu Tasarım penceresinin üst yarısında siparişler tablosundaki alan listesinde, aşağıdaki alanları eklemek için çift tıklatın: ShipCountry, Navlun.
  8. Görünüm menüsünde Toplamlar ' ı tıklatın. Sorgu tasarım kılavuzuna bir satırın Toplam adlı bir not eklendi.
  9. Nakliye sütununda Toplam satır hücreyi tıklatın, görüntülenen oku tıklatın ve Sum</a1>'ı tıklatın.
  10. Dosya menüsünde Kaydet ' i tıklatın. QryFreightByCountry sorgu adını yazın.
  11. Sorgu) menüsünde, sorgunun sonuçlarını görüntülemek için Çalıştır ' ı tıklatın. Sorgu, Orders tablosundaki her ülke için bir toplam Navlun döndürür unutmayın.

Sorguda kayıtları Sırala nasıl

  1. Tasarım görünümündeki "Gruplandırma kayıtları ve oluşturma toplamlarını ve diğer toplamlar" bölümünde oluşturduğunuz qryFreightByCountry sorgusunu açın.
  2. Nakliye</a0> sütununun altındaki <a1>Sort</a1> satır hücresindeki'ı tıklatın, görüntülenen oku tıklatın ve Azalan</a1>'ı tıklatın.
  3. Dosya menüsünden farklı Kaydet ' i tıklatın. QryFreightByCountrySorted sorgu adını yazın.
  4. Sorgu) menüsünde, sorgunun sonuçlarını görüntülemek için Çalıştır ' ı tıklatın. Her ülke için bir toplam Navlun sorgu azalan şekilde sıralanmış Siparişler tablosunda sayı unutmayın.



Referanslar

Sorgu oluşturma hakkında daha fazla bilgi için Yardım menüsünden Microsoft Access Yardımı ' nı tıklatın, bir seçme sorgusu oluşturmak için Office Yardımcısı'na veya Yanıt Sihirbazı'nı yazın ve sonra döndürülen konuları görüntülemek için Ara ' yı tıklatın.

Bu bilgiler ayrıca aşağıdaki Microsoft Web sitesini World Wide Web'de kullanılabilir:
Create a select or crosstab query
Çapraz sorgu oluşturma hakkında ek bilgi için Microsoft Knowledge Base'deki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
304349NASıL YAPıLıR: Microsoft Access 2002'de bir çapraz sorgu oluşturma
Parametre sorgularını oluşturma hakkında ek bilgi için Microsoft Knowledge Base'deki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
304352NASıL YAPıLıR: Microsoft Access 2002'de bir parametre sorgusu oluşturma
Eylem sorgusu için bir seçme sorgusu dönüştürme hakkında ek bilgi için Microsoft Knowledge Base'deki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
304354NASıL YAPıLıR:, Access'te bir eylem sorgusu için bir seçme sorgusu Dönüştür
Sorgu özelliklerini değiştirme hakkında daha fazla bilgi için Microsoft Knowledge Base'deki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
304356Microsoft Access'te, sorgu özellikleri değiştirme
Bu makaleler, açıklanan teknikleri de dahil olmak üzere, 20'den sorgu örnekleri içeren örnek bir Microsoft Access veritabanı'nı karşıdan yüklemek için Microsoft Knowledge Base'de aşağıdaki makaleye bakın:
207626"Access 2000 örnek: Sorgu konuları" veritabanında kullanılabilir Yükleme Merkezi










Özellikler

Makale numarası: 304325 - Last Review: 29 Mart 2007 Perşembe - Gözden geçirme: 4.2
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Access 2002 Standard Edition
Anahtar Kelimeler: 
kbmt kbquery kbdownload kbhowtomaster KB304325 KbMttr
Machine-translated Article
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:304325

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com