Cómo crear una consulta de referencias cruzadas en Access 2002

Seleccione idioma Seleccione idioma
Id. de artículo: 304349 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Resumen

Mediante consultas de referencias cruzadas, puede crear vistas de resumen de los datos para facilitar el análisis. En este artículo se muestra cómo crear una consulta de referencias cruzadas en Microsoft Access con y sin utilizar a un asistente.

Precaución : Si sigue los pasos descritos en este ejemplo, modificará la base de datos de ejemplo Neptuno.mdb. Quizás desee hacer una copia de seguridad del archivo Neptuno.mdb y realizar estos pasos sobre una copia de la base de datos.

Crear una consulta general mediante el Asistente para consultas de referencias cruzadas

  1. Inicie Microsoft Access.
  2. En el menú Ayuda , haga clic en Bases de datos de ejemplo y, a continuación, haga clic en Base de datos . Haga clic en Aceptar en la pantalla de apertura y cierre el formulario de Panel de control principal cuando aparezca.
  3. En el menú Insertar , haga clic en consulta .
  4. En el cuadro de diálogo Nueva consulta , haga clic en Asistente para consultas de referencias cruzadas y, a continuación, haga clic en Aceptar .
  5. En la primera página del Asistente para consultas general, haga clic en pedidos de la lista de tablas y, a continuación, haga clic en siguiente .
  6. Haga doble clic en EmployeeID de la lista de Campos disponibles para agregarlo a la lista de Campos seleccionados y, a continuación, haga clic en siguiente . Esto crea una consulta con un registro por empleado.
  7. Haga clic en FechaPedido en la lista de campos y, a continuación, haga clic en siguiente .
  8. Haga clic en año para el intervalo de fecha y, a continuación, haga clic en siguiente . Esto crea una consulta con una columna por año para las fechas de pedido.
  9. Haga clic en IdPedido de la lista de campos, haga clic en número en la lista de funciones y, a continuación, haga clic en siguiente .
  10. Haga clic en Finalizar en la última página del asistente. Tenga en cuenta que se crea una consulta que muestra un recuento de pedidos por empleado por año.

Crear una consulta de referencias cruzadas sin utilizar un asistente

  1. Inicie Microsoft Access.
  2. En el menú Ayuda , haga clic en Bases de datos de ejemplo y, a continuación, haga clic en Base de datos . Haga clic en Aceptar en la pantalla de apertura y cierre el formulario de Panel de control principal cuando aparezca.
  3. En el menú Ver , seleccione Objetos de base de datos y, a continuación, haga clic en consultas .
  4. En el menú Insertar , haga clic en consulta .
  5. En el cuadro de diálogo Nueva consulta , haga clic en Vista Diseño y, a continuación, haga clic en Aceptar .
  6. En el cuadro de diálogo Mostrar tabla , haga clic en la tabla pedidos , haga clic en Agregar y, a continuación, haga clic en Cerrar .
  7. En la lista de campos de la tabla Orders en la mitad superior de la cuadrícula de diseño de consulta, haga doble clic en los siguientes campos para agregarlos a la cuadrícula de diseño de consulta: PaísDestinatario , CiudadDestinatario , FormaEnvío y transporte .
  8. En el menú consulta , haga clic en Consulta de referencias cruzadas . Tenga en cuenta que se agrega una fila a la cuadrícula de diseño denominada General .
  9. Haga clic en la celda de fila Tab ref cruz en la columna PaísDeEnvío , haga clic en la flecha que aparece y a continuación, en Encabezado de fila .
  10. Haga clic en la celda de fila Tab ref cruz en la columna CiudadDestinatario , haga clic en la flecha que aparece y, a continuación, en Encabezado de fila .
  11. Haga clic en la celda de fila Tab ref cruz en la columna EnviarPor , haga clic en la flecha que aparece y a continuación, en Encabezado de columna .
  12. Haga clic en la celda de fila Tab ref cruz en la columna transporte , haga clic en la flecha que aparece y, a continuación, haga clic en valor . Observe que sólo un campo se puede establecer a valor .
  13. Haga clic en la celda de fila total bajo la columna de transporte , haga clic en la flecha que aparece y, a continuación, haga clic en suma .
  14. En el menú consulta , haga clic en Ejecutar para ver los resultados de la consulta de referencias cruzadas.



Referencias

Para obtener más información acerca de cómo crear consultas, haga clic en Ayuda de Microsoft Access en el menú Ayuda , escriba crear una consulta de referencias cruzadas en el Ayudante de Office o el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver los temas devueltos.

Para obtener información adicional sobre cómo crear consultas de referencias cruzadas con varios campos de valor, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304458Cómo crear una consulta de tablas de referencias cruzadas con campos con varios valores
Para obtener información adicional sobre la creación de consultas seleccione, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304325Cómo crear una consulta de selección en Access 2002
Para obtener información adicional acerca de cómo crear consultas de parámetro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304352Cómo: Crear una consulta de parámetros en Microsoft Access 2002
Para obtener información adicional acerca de cómo convertir una consulta de selección en una consulta de acción, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304354Cómo: Convertir una consulta SELECT en una consulta de acción en Access
Para obtener información adicional acerca de cómo modificar las propiedades de una consulta, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304356Cómo modificar las propiedades de una consulta en Microsoft Access

Propiedades

Id. de artículo: 304349 - Última revisión: jueves, 12 de agosto de 2004 - Versión: 4.0
La información de este artículo se refiere a:
  • Microsoft Access 2002 Standard Edition
Palabras clave: 
kbmt kbquery kbhowtomaster KB304349 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 304349

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com