Como criar uma consulta de referência cruzada no Access 2002

Traduções de Artigos Traduções de Artigos
Artigo: 304349 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sumário

Ao utilizar consultas cruzadas, pode criar vistas sumário dos dados para uma análise mais fácil. Este artigo mostra como criar uma consulta de referência cruzada no Microsoft Access com e sem utilizar um assistente.

atenção : Se seguir os passos neste exemplo, modificará a base de dados de exemplo Adamastor.mdb. Convém cópia de segurança do ficheiro de base de dados Adamastor.mdb e siga estes passos numa cópia da base de dados.

Criar uma consulta tabela de referência cruzada utilizando o Assistente de consultas de referência cruzada

  1. Inicie o Microsoft Access.
  2. No menu Ajuda , clique em Bases de dados de exemplo e, em seguida, clique em Base de dados de exemplo Adamastor . Clique em OK para o ecrã inicial de abertura e, em seguida, feche o formulário de Painel de navegação principal quando é apresentado.
  3. No menu Inserir , clique em consulta .
  4. Na caixa de diálogo Nova consulta , clique em Assistente de consultas tabela de referência cruzada e, em seguida, clique em OK .
  5. No primeira página do Assistente de consultas tabela de referência cruzada, clique em encomendas da lista de tabelas e, em seguida, clique em seguinte .
  6. Faça duplo clique CódigoDoEmpregado da lista de Campos disponíveis para o adicionar à lista de Campos seleccionados e, em seguida, clique em seguinte . Isto cria uma consulta com um registo por empregado.
  7. Clique em DataDaEncomenda na lista de campos e, em seguida, clique em seguinte .
  8. Clique em ano para o intervalo de datas e, em seguida, clique em seguinte . Isto cria uma consulta com uma coluna por ano para datas de encomenda.
  9. Clique em CódigoDaEncomenda da lista de campos, clique em Contar na lista de funções e, em seguida, clique em seguinte .
  10. Clique em Concluir na última página do assistente. Tenha em atenção que é criada uma consulta que apresenta uma contagem de encomendas por empregado por ano.

Criar uma consulta tabela de referência cruzada sem utilizar um assistente

  1. Inicie o Microsoft Access.
  2. No menu Ajuda , clique em Bases de dados de exemplo e, em seguida, clique em Base de dados de exemplo Adamastor . Clique em OK para o ecrã inicial de abertura e, em seguida, feche o formulário de Painel de navegação principal quando é apresentado.
  3. No menu Ver , aponte para Objectos de base de dados e, em seguida, clique em consultas .
  4. No menu Inserir , clique em consulta .
  5. Na caixa de diálogo Nova consulta , clique em Vista de estrutura e, em seguida, clique em OK .
  6. Na caixa de diálogo Mostrar tabela , clique na tabela encomendas , clique em Adicionar e, em seguida, clique em Fechar .
  7. Na lista de campo da tabela Encomendas na parte superior da grelha de estrutura da consulta, faça duplo clique sobre os seguintes campos para os adicionar à grelha de estrutura da consulta: PaísDoDestino , CidadeDoDestino , EnviarPor e Frete .
  8. No menu consulta , clique em Consultas de referência cruzada . Repare que uma linha é adicionada à grelha de estrutura da consulta denominada tabela de referência cruzada .
  9. Clique na célula tabela de referência cruzada linha na coluna PaísDoDestino , clique na seta que aparece e, em seguida, clique em Título da linha .
  10. Clique na célula tabela de referência cruzada linha na coluna CidadeDoDestino , clique na seta que aparece e, em seguida, clique em Título da linha .
  11. Clique na célula tabela de referência cruzada linha na coluna EnviarPor , clique na seta que aparece e, em seguida, clique em Cabeçalho da coluna .
  12. Clique na célula tabela de referência cruzada linha na coluna de transporte , clique na seta que aparece e, em seguida, clique em valor . Tenha em atenção que apenas um campo pode ser definido como valor .
  13. Clique na célula linha total na coluna de transporte , clique na seta que aparece e, em seguida, clique em Soma .
  14. No menu consulta , clique em Executar para ver os resultados da consulta tabela de referência cruzada.



Referências

Para mais informações sobre como criar consultas, clique em Ajuda do Microsoft Access no menu de Ajuda escreva criar uma consulta tabela de referência cruzada no Assistente do Office ou no Assistente de respostas e, em seguida, clique em Procurar para visualizar os tópicos devolvidos.

Para obter informações adicionais sobre como criar consultas de referência cruzada com vários campos de valor, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
304458Como criar uma consulta de referência cruzada com vários campos de valor
Para obter informações adicionais sobre como criar consultas de selecção, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
304325Como criar uma consulta de selecção no Access 2002
Para obter informações adicionais sobre como criar consultas parametrizadas, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
304352COMO: Criar uma consulta parametrizada no Microsoft Access 2002
Para obter informações adicionais sobre como converter uma consulta de selecção para uma consulta de acção, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
304354COMO: Converter uma consulta selecção para uma consulta de acção no Access
Para obter informações adicionais sobre como modificar as propriedades da consulta, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
304356Como modificar propriedades de consulta no Microsoft Access

Propriedades

Artigo: 304349 - Última revisão: 12 de agosto de 2004 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbmt kbquery kbhowtomaster KB304349 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 304349

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com