Como criar uma consulta de tabela de referência cruzada no Access 2002

Traduções deste artigo Traduções deste artigo
ID do artigo: 304349 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sumário

Usando consultas de tabela de referência cruzada, você pode criar modos de exibição Resumo dos seus dados para facilitar a análise. Este artigo mostra como criar uma consulta de tabela de referência cruzada no Microsoft Access com e sem utilizar um assistente.

cuidado : se você seguir as etapas neste exemplo, você modificar o banco de dados de exemplo Northwind.mdb. Convém fazer o backup do arquivo Northwind.mdb e seguir essas etapas numa cópia do banco de dados.

Criando uma consulta de referência cruzada usando o Assistente de consulta de tabela de referência cruzada

  1. Inicie o Microsoft Access.
  2. No menu Ajuda , clique em Bancos de dados de exemplo e, em seguida, clique em Dados de exemplo Northwind . Clique em OK para a tela de abertura e feche o formulário Menu de controle principal quando ela aparecer.
  3. No menu Inserir , clique em consulta .
  4. Na caixa de diálogo Nova consulta , clique em Assistente de consulta tabela de referência cruzada e em seguida, clique em OK .
  5. Na primeira página do Assistente de consulta tabela de referência cruzada, clique em pedidos na lista de tabelas e clique em Avançar .
  6. Clique duas vezes CódigoDoFuncionário da lista de Campos disponíveis adicioná-lo à lista de Campos selecionados e em seguida, clique em Avançar . Isso cria uma consulta com um registro por funcionário.
  7. Clique em DataDoPedido na lista de campos e, em seguida, clique em Avançar .
  8. Clique em ano para o intervalo de datas e, em seguida, clique em Avançar . Isso cria uma consulta com uma coluna por ano para datas de ordem.
  9. Clique em NúmeroDoPedido da lista de campos, clique em Contar na lista de funções e em seguida, clique em Avançar .
  10. Clique em Concluir na última página do assistente. Observe que é criada uma consulta que exibe uma contagem de pedidos por funcionário por ano.

Criando uma consulta tabela de referência cruzada sem usar um Assistente

  1. Inicie o Microsoft Access.
  2. No menu Ajuda , clique em Bancos de dados de exemplo e, em seguida, clique em Dados de exemplo Northwind . Clique em OK para a tela de abertura e feche o formulário Menu de controle principal quando ela aparecer.
  3. No menu Exibir , aponte para Objetos de banco de dados e, em seguida, clique em consultas .
  4. No menu Inserir , clique em consulta .
  5. Na caixa de diálogo Nova consulta , clique em Modo de design e, em seguida, clique em OK .
  6. Na caixa de diálogo Mostrar tabela , clique na tabela pedidos , clique em Adicionar e, em seguida, clique em Fechar .
  7. Na lista de campo da tabela Pedidos na metade superior da grade de design da consulta, clique duas vezes os seguintes campos para adicioná-los à grade de design da consulta: PaísDeDestino , CidadeDeDestino , ShipVia e Freight .
  8. No menu consulta , clique em Consulta de tabela de referência cruzada . Observe que uma linha é adicionada à grade de design da consulta chamado de referência cruzada .
  9. Clique na célula da linha referência cruzada sob a coluna PaísDeDestino , clique na seta que aparece e , em seguida, clique em linha .
  10. Clique na célula da linha referência cruzada sob a coluna CidadeDeDestino , clique na seta que aparece e , em seguida, clique em linha .
  11. Clique na célula da linha referência cruzada sob a coluna via , clique na seta que aparece e , em seguida, clique em coluna .
  12. Clique na célula da linha referência cruzada sob a coluna Frete , clique na seta que aparece e, em seguida, clique em valor . Observe que apenas um campo pode ser definido como valor .
  13. Clique na célula da linha total , sob a coluna Frete , clique na seta que aparece e, em seguida, clique em soma .
  14. No menu consulta , clique em Executar para exibir os resultados da consulta de tabela de referência cruzada.



Referências

Para obter mais informações sobre como criar consultas, clique em Ajuda do Microsoft Access no menu Ajuda , digite criar uma consulta de tabela de referência cruzada no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir os tópicos retornados.

Para obter informações adicionais sobre como criar consultas de tabela de referência cruzada com vários campos de valor, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
304458Como criar uma consulta de tabela de referência cruzada com vários campos de valor
Para obter informações adicionais sobre como criar consultas seleção, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
304325Como criar uma consulta seleção no Access 2002
Para obter informações adicionais sobre como criar consultas parâmetro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
304352COMO: Criar uma consulta parâmetro no Microsoft Access 2002
Para obter informações adicionais sobre como converter uma consulta seleção para uma consulta ação, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
304354COMO: Converter uma consulta seleção em uma consulta ação no Access
Para obter informações adicionais sobre como modificar propriedades de consulta, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
304356Como modificar propriedades de consulta no Microsoft Access

Propriedades

ID do artigo: 304349 - Última revisão: quinta-feira, 12 de agosto de 2004 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbmt kbquery kbhowtomaster KB304349 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 304349

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com