Cómo convertir una consulta de selección a una consulta de acción en Access 2002

Seleccione idioma Seleccione idioma
Id. de artículo: 304354 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Resumen

Las consultas de acción se utilizan cuando desea realizar tareas tales como insertar, actualizar o eliminar registros. Puede convertir una consulta de selección existente en una consulta de acción cambiando su tipo de consulta. En este artículo describe los diferentes tipos de consultas de acción y muestra cómo cambiar una consulta de selección a una consulta de acción.

Una consulta de acción es una consulta que realiza cambios a o mueve muchos registros en una sola operación. Hay cuatro tipos de consultas de acción: eliminar, actualizar, anexar y creación de tabla.

Consulta de eliminación

Una consulta de eliminación elimina un grupo de registros de una o más tablas. Por ejemplo, puede utilizar una consulta de eliminación para quitar productos que están suspendidos o que no hay pedidos.

Puede utilizar una consulta de eliminación para eliminar registros de una sola tabla, de varias tablas en una relación uno a uno o de varias tablas en una relación uno a varios, si están habilitadas eliminaciones en cascada. Por ejemplo, puede utilizar una consulta de eliminación para eliminar a todos los clientes de Irlanda y todos sus pedidos. Sin embargo, si necesita incluir la tabla "varios" junto con la tabla "uno" para agregar criterios, deberá ejecutar la consulta dos veces, porque una consulta no puede eliminar registros de la tabla principal y las tablas relacionadas al mismo tiempo.

Para obtener información adicional acerca de las relaciones y diseñar bases de datos, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
289533Dónde encontrar información acerca de cómo diseñar una base de datos en Microsoft Access
Consideraciones importantes al utilizar una consulta de eliminación
  • Una vez eliminar registros mediante una consulta de eliminación, no puede deshacer la operación. Por lo tanto, debe ofrece una vista previa del que la consulta seleccionada para eliminación antes de ejecuta la consulta de datos. Puede hacerlo haciendo clic en hoja de datos en el menú Ver .
  • Debe mantener copias de seguridad de los datos en todo momento. Si elimina registros incorrectos, las puede recuperar de las copias de seguridad.
  • En algunos casos, al ejecutar una consulta de eliminación puede eliminar registros en tablas relacionadas, incluso si no están incluidas en la consulta. Esto puede suceder cuando la consulta contiene sólo la tabla que está en el lado "uno" de una relación uno a varios y ha habilitado la eliminación en cascada para esa relación. Al eliminar registros de la tabla "uno", también eliminará los registros de la tabla "varios".

    Por ejemplo, considere una relación entre una tabla Customers y Orders con eliminaciones en cascada habilitado. Eliminar un registro de la tabla Customers eliminaría los pedidos relacionados de la tabla Pedidos.
  • Cuando una consulta de eliminación contiene más de una tabla, como una consulta que elimine registros duplicados de una de las tablas, se debe establecer la propiedad RegistrosÚnicos querys en .

Consulta de actualización

Una consulta de actualización realiza cambios globales a un grupo de registros de uno o más tablas. Por ejemplo, puede aumentar los precios un 10 por ciento de todos los productos lácteos o puede aumentar los salarios en un 5 por ciento para las personas dentro de una determinada categoría de trabajo. Con una consulta de actualización, puede cambiar datos en tablas existentes.

Consulta de datos anexados

Una consulta de datos anexados agrega un grupo de registros de una o varias tablas al final de una o más tablas. Por ejemplo, supongamos que consigue nuevos clientes y una base de datos que contiene una tabla de información en los clientes. Para evitar escribir toda esta información, desea anexarla a la tabla clientes. Anexar las consultas también son útiles para:
  • Anexar campos basados en criterios. Por ejemplo, quizás desee anexar sólo los nombres y direcciones de clientes con pedidos pendientes.
  • Anexar registros cuando algunos de los campos de una tabla no existen en la otra tabla. Por ejemplo, en la base de datos de ejemplo Neptuno, la tabla clientes tiene 11 campos. Suponga que desea anexar registros de otra tabla que tiene campos que coinciden con 9 de los 11 campos de la tabla Customers. Una consulta de datos anexados se anexar los datos de los campos coincidentes y omitir el resto.

Consulta de creación de tabla

Una consulta de creación de tabla crea una nueva tabla de todo o parte de los datos de uno o más tablas. Las consultas de creación de tabla son útiles para:
  • Crear una tabla para exportar a otras bases de datos de Microsoft Access. Por ejemplo, es posible que desee crear una tabla que contiene varios campos de la tabla empleados y, a continuación, exportar esa tabla a una base de datos utilizada por el departamento de personal.
  • Hacer una copia copia de seguridad de una tabla automáticamente mediante una macro o código.
  • Crear una tabla histórica que contenga registros antiguos. Por ejemplo, podría crear una tabla que almacena todos los pedidos antiguos antes de eliminar de la tabla Pedidos actual.

Convertir una consulta SELECT en una consulta de acción

  1. Inicie Microsoft Access 2002.
  2. En el menú Ayuda , haga clic en Bases de datos de ejemplo y, a continuación, haga clic en Base de datos .
  3. En el menú Ver , haga clic en Objetos de base de datos y, a continuación, haga clic en consultas .
  4. Haga clic en la consulta facturas y, a continuación, haga clic en Diseño .
  5. En el menú consulta , haga clic en Actualizar consulta para cambiar esta consulta de selección a una consulta de actualización.
  6. En la columna PrecioUnidad de la tabla Order Details en la cuadrícula de diseño de consulta, escriba la siguiente expresión en la fila Actualizar A . Esta expresión aumentará el precio de pedidos realizados en un 10 por ciento.
    [detalles de pedidos]. [PrecioUnidad] * 1.10
  7. En la columna PaísDestinatario , escriba USA en la fila criterios .
  8. En el menú consulta , haga clic en Ejecutar para actualizar el precio de venta para pedidos enviados a los Estados Unidos en un 10 por ciento.
  9. Cierre la consulta facturas sin guardarlo.

Cambios en la cuadrícula de diseño de consulta al cambiar el tipo de consulta

Después de cambiar el tipo de consulta de una consulta de selección en una consulta de acción, la cuadrícula de diseño de consulta se cambie como sigue.
  • consulta de actualización
    Se agrega una fila en la cuadrícula en la parte inferior de la pantalla titulada "Actualización A". Escriba una expresión de esta fila para actualizar un grupo de registros basándose en la expresión.
  • consulta de datos anexados
    Se le pide el nombre de la tabla para anexar registros a y verá una fila titulada "Anexar A." Éste es el nombre del campo en la tabla que está anexando registros a. Microsoft Access rellena automáticamente los nombres de campo que coincidan con entre dos tablas.
  • consulta de eliminación
    Se agrega una fila a la cuadrícula de diseño en la parte inferior titulada "Eliminar". Para eliminar un grupo de registros basándose en criterios, cambie la fila Eliminar a dónde y especifique la expresión que debe utilizar la consulta como criterios en la fila criterios .
  • consulta de creación de tabla
    Para crear se le pedirá el nombre de una tabla nueva. También puede crear esta tabla en una base de datos diferente. Se creará la tabla con los nombres de campo y tipos de datos de la tabla existente.



Referencias

Para obtener información adicional sobre cómo establecer la propiedad registros únicos en una consulta de eliminación, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
240098ACC2000: "no se puede eliminar desde tablas especificadas" mensaje de error en la consulta de eliminación

Para obtener más información acerca de cómo crear consultas de acción, haga clic en Ayuda de Microsoft Access en el menú Ayuda , escriba crear una consulta de acción en el Ayudante de Office o el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver los temas devueltos.
Para obtener información adicional sobre la creación de consultas seleccione, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304325Cómo crear una consulta de selección en Access 2002
Para obtener información adicional acerca de cómo crear consultas de parámetro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304352Cómo: Crear una consulta de parámetros en Microsoft Access 2002
Para obtener información adicional sobre cómo crear consultas de referencias cruzadas, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304349Cómo crear una consulta de referencias cruzadas en Access 2002


Propiedades

Id. de artículo: 304354 - Última revisión: miércoles, 25 de agosto de 2004 - Versión: 3.3
La información de este artículo se refiere a:
  • Microsoft Access 2002 Standard Edition
Palabras clave: 
kbmt kbquery kbhowtomaster KB304354 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 304354

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com