Como converter uma consulta de selecção para uma consulta de acção no Access 2002

Traduções de Artigos Traduções de Artigos
Artigo: 304354 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sumário

Consultas de acção são utilizadas quando pretende efectuar tarefas tais como inserir, actualizar ou eliminar registos. Pode converter uma consulta de selecção existente para uma consulta de acção, alterando o tipo de consulta. Este artigo descreve os diferentes tipos de consultas de acção e mostra como alterar uma consulta de selecção para uma consulta de acção.

Uma consulta de acção é uma consulta que efectua alterações ou move vários registos numa só operação. Existem quatro tipos de consultas de acção: eliminação, actualizar, acrescentar e criar tabela.

Eliminar consulta

Uma consulta eliminação elimina um grupo de registos de uma ou mais tabelas. Por exemplo, pode utilizar uma consulta de eliminação para remover produtos que são descontinuados ou para a qual existem sem encomendas.

Pode utilizar uma consulta de eliminação para eliminar registos de uma única tabela, de várias tabelas numa relação um-para-um, ou de várias tabelas numa relação um-para-muitos, se eliminações em cascata estiverem activadas. Por exemplo, pode utilizar uma consulta de eliminação para eliminar todos os clientes da Irlanda e todas as respectivas encomendas. No entanto, se tiver de incluir a tabela "muitos" juntamente com a tabela "um" para adicionar critérios, tem de executar a consulta duas vezes, uma vez que uma consulta não é possível eliminar registos da tabela principal e as tabelas relacionadas ao mesmo tempo.

Para obter informações adicionais sobre as relações e estruturar bases de dados, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
289533Onde encontrar informações acerca de como estruturar uma base de dados do Microsoft Access
Considerações importantes quando utilizar uma consulta eliminação
  • Depois de eliminar registos utilizando uma consulta de eliminação, não pode anular a operação. Pré-por este motivo, deverá visualizar os dados que a consulta seleccionada para eliminação antes de executa a consulta. É possível fazê-lo clicando em folha de dados no menu Ver .
  • Deve manter cópias de segurança dos dados em todos os momentos. Se eliminar os registos errados, poderá recuperá-los de cópias de segurança.
  • Em alguns casos, executar uma consulta eliminação pode eliminar registos em tabelas relacionadas, mesmo não são incluídos na consulta. Isto pode acontecer quando a consulta contém apenas a tabela no lado "um" da relação um-para-muitos e tiver activado eliminações em cascata para essa relação. Eliminar registos da tabela "um", também irá eliminar registos da tabela "muitos".

    Por exemplo, considere uma relação entre uma tabela clientes e encomendas com eliminações em cascata activado. Eliminar um registo da tabela clientes irá eliminar as encomendas relacionadas na tabela Encomendas.
  • Quando uma consulta eliminação contiver mais do que uma tabela, tal como uma consulta que elimina uma das tabelas, registos duplicados querys propriedade RegistosExclusivos tem de ser definida para Sim .

Actualizar consulta

Uma consulta actualização efectua alterações globais a um grupo de registos numa ou mais tabelas. Por exemplo, pode aumentar os preços em 10 por cento de todos os lacticínios ou aumentar salários em 5 por cento para as pessoas dentro de determinadas categorias de tarefa. Com uma consulta de actualização, pode alterar dados em tabelas existentes.

Consulta ' Acrescentar '

Uma consulta Acrescentar adiciona um grupo de registos de uma ou mais tabelas para o fim de uma ou mais tabelas. Por exemplo, suponha que adquire alguns clientes novos e uma base de dados que contém uma tabela de informações sobre esses clientes. Para evitar escrever todas estas informações, que pretende acrescentar à tabela clientes. Acrescentar consultas também são úteis para:
  • Acrescentar campos baseados nos critérios. Por exemplo, poderá acrescentar apenas os nomes e endereços dos clientes com encomendas pendentes.
  • Acrescentar registos quando alguns dos campos numa tabela não existem na outra tabela. Por exemplo, na base de dados de exemplo Adamastor, a tabela clientes tem 11 campos. Suponha que pretende acrescentar registos de outra tabela que contém campos que correspondem a 9 dos 11 campos na tabela clientes. Uma consulta de acréscimo irá acrescentar os dados nos campos correspondentes e ignorar os outros.

Consulta criar tabela

Uma consulta criar tabela cria uma nova tabela de tudo ou parte dos dados existentes numa ou mais tabelas. Consultas criar tabela são úteis para:
  • Criar uma tabela para exportar para outras bases de dados do Microsoft Access. Por exemplo, poderá pretender criar uma tabela que contém vários campos da tabela Empregados e, em seguida, exportar essa tabela para uma base de dados utilizado pelo seu departamento pessoal.
  • Efectuar automaticamente uma cópia de segurança de uma tabela utilizando uma macro ou código.
  • Criar uma tabela do histórico que contenha registos antigos. Por exemplo, pode criar uma tabela que armazena todas as encomendas antigas antes de os eliminar da tabela Encomendas actual.

Converter uma consulta selecção para uma consulta de acção

  1. Inicie o Microsoft Access 2002.
  2. No menu Ajuda , clique em Bases de dados de exemplo e, em seguida, clique em Base de dados de exemplo Adamastor .
  3. No menu Ver , clique em Objectos de base de dados e, em seguida, clique em consultas .
  4. Faça clique sobre a consulta facturas e, em seguida, clique em estrutura .
  5. No menu de consulta , clique em Actualizar consulta para alterar esta consulta de selecção para uma consulta de actualização.
  6. Na coluna PreçoUnitário da tabela Detalhes da encomenda na grelha de estrutura da consulta, escreva a expressão seguinte na linha Actualizar para . Esta expressão aumentará o preço de encomendas em 10 por cento.
    [Detalhes da encomenda]. [PreçoUnitário] * 1.10
  7. Na coluna PaísDoDestino , escreva USA na linha critérios .
  8. No menu consulta , clique em Executar para actualizar o preço de encomendas enviadas para os EUA 10 por cento.
  9. Feche a consulta facturas sem guardá-lo.

Alterações a grelha de estrutura da consulta quando alterar o tipo de consulta

Depois de alterar o tipo de consulta de uma consulta selecção para uma consulta de acção, grelha de estrutura da consulta será alterada da seguinte forma.
  • consulta de actualização
    É adicionada uma linha da grelha na parte inferior do ecrã com o título "Actualização para". Introduza uma expressão nesta linha para actualizar um grupo de registos com base na expressão.
  • consulta acrescentar
    Será solicitado o nome de tabela para acrescentar registos a, e deverá ver uma linha com o título "Anexar A". Este é o nome do campo na tabela que esteja a acrescentar registos. O Microsoft Access preenche automaticamente nomes de campos que sejam correspondentes nas duas tabelas.
  • Eliminar consulta
    É adicionada uma linha à grelha de estrutura da consulta, na parte inferior com o título 'Eliminar'. Para eliminar um grupo de registos com base em critérios, altere a linha Eliminar para onde e introduzir a expressão de consulta deve utilizar como critérios na linha critérios .
  • consulta criar tabela
    Lhe for pedido o nome de uma nova tabela para criar. Também pode criar esta tabela numa base de dados diferente. A tabela será criada com os nomes de campo e tipos de dados da tabela existente.



Referências

Para obter informações adicionais sobre como definir a propriedade RegistosExclusivos numa consulta eliminação, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
240098ACC2000: "pode não elimina de tabelas especificadas" mensagem de erro na consulta eliminação

Para mais informações sobre como criar consultas de acção, clique em Ajuda do Microsoft Access no menu de Ajuda escreva criar uma consulta de acção no Assistente do Office ou no Assistente de respostas e, em seguida, clique em Procurar para visualizar os tópicos devolvidos.
Para obter informações adicionais sobre como criar consultas de selecção, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
304325Como criar uma consulta de selecção no Access 2002
Para obter informações adicionais sobre como criar consultas parametrizadas, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
304352COMO: Criar uma consulta parametrizada no Microsoft Access 2002
Para obter informações adicionais sobre como criar consultas de referência cruzada, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
304349Como criar uma consulta de referência cruzada no Access 2002


Propriedades

Artigo: 304354 - Última revisão: 25 de agosto de 2004 - Revisão: 3.3
A informação contida neste artigo aplica-se a:
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbmt kbquery kbhowtomaster KB304354 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 304354

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com