Como converter uma consulta seleção para uma consulta ação no Access 2002

Traduções deste artigo Traduções deste artigo
ID do artigo: 304354 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sumário

As consultas ação são usadas quando você deseja realizar tarefas como inserir, atualizar ou excluir registros. Você pode converter uma consulta seleção existente em uma consulta ação, alterando seu tipo de consulta. Este artigo descreve os diferentes tipos de consultas ação e mostra como alterar uma consulta seleção para uma consulta ação.

Uma consulta ação é uma consulta que faz alterações em ou move muitos registros em apenas uma operação. Há quatro tipos de consultas de ação: exclusão, atualização, acréscimo e criar tabela.

Consulta exclusão

Uma consulta exclusão exclui um grupo de registros de uma ou mais tabelas. Por exemplo, você pode usar uma consulta exclusão para remover produtos que estão descontinuados ou para os quais não houver ordens.

Você pode usar uma consulta exclusão para excluir registros de uma única tabela, de várias tabelas em um relacionamento um-para-um, ou de várias tabelas em um relacionamento um-para-muitos, se estiverem ativadas exclusões em cascata. Por exemplo, você pode usar uma consulta exclusão para excluir todos os clientes da Irlanda e todos os seus pedidos. No entanto, se você precisar incluir a tabela "muitos" junto com a tabela "um" para adicionar critérios, você deve executar a consulta duas vezes, porque uma consulta não pode excluir registros da tabela primária e as tabelas relacionadas ao mesmo tempo.

Para informações adicionais sobre as relações e criar bancos de dados, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
289533Onde encontrar informações sobre como criar um banco de dados no Microsoft Access
Considerações importantes ao usar uma consulta exclusão
  • Depois de você excluir registros utilizando uma consulta exclusão, você não poderá desfazer a operação. Portanto, você deve visualizar os dados que a consulta selecionada para exclusão antes de executa a consulta. Você pode fazer isso clicando em folha de dados no menu Exibir .
  • Você deve manter cópias de backup de seus dados em todos os horários. Se você excluir os registros errados, será possível recuperá-los com base nas suas cópias de backup.
  • Em alguns casos, a execução de uma consulta excluir pode excluir registros em tabelas relacionadas, mesmo que não são incluídas na consulta. Isso pode acontecer quando sua consulta contém somente a tabela que está no lado "um" de um relacionamento um-para-muitos, e você tiver ativado exclusões em cascata para esse relacionamento. Quando você exclui registros da tabela "um", você também irá excluir registros da tabela "muitos".

    Por exemplo, considere uma relação entre uma tabela Customers e Orders com exclusões em cascata habilitada. Excluir um registro da tabela Customers excluirá os pedidos relacionados na tabela Pedidos.
  • Quando uma consulta exclusão contiver mais de uma tabela, como uma consulta que exclui registros duplicados de uma das tabelas, a propriedade UniqueRecords querys deve ser definida como Sim .

Consulta atualização

Uma consulta atualização faz alterações globais em um grupo de registros em uma ou mais tabelas. Por exemplo, você pode elevar os preços em 10 por cento de todos os laticínios, ou pode elevar os salários em 5 por cento das pessoas de uma determinada categoria de trabalho. Com uma consulta atualização, você pode alterar dados em tabelas existentes.

Consulta acréscimo

Uma consulta acréscimo adiciona um grupo de registros de um ou mais tabelas ao final de um ou mais tabelas. Por exemplo, suponha que você adquire alguns clientes novos e um banco de dados contendo uma tabela de informações sobre esses clientes. Para evitar digitar todas essas informações, você gostaria de acrescentá-la à sua tabela clientes. Acrescentar as consultas também são úteis para:
  • Acrescentar campos com base em critérios. Por exemplo, talvez queira acrescentar apenas os nomes e endereços de clientes com pedidos pendentes.
  • Acrescentar registros quando alguns dos campos em uma tabela não existem na outra tabela. Por exemplo, no banco de dados de exemplo Northwind, a tabela clientes tem 11 campos. Vamos supor que você queira acrescentar registros de outra tabela que possui campos que correspondam a 9 dos campos da tabela Customers 11. Uma consulta acréscimo irá acrescentar os dados nos campos coincidentes e ignorar os outros.

Consulta criar tabela

Uma consulta criar tabela cria uma nova tabela de todos ou parte dos dados em um ou mais tabelas. Consultas criar tabela são úteis para:
  • Criando uma tabela para exportar para outros bancos de dados. Por exemplo, você pode deseja criar uma tabela que contém vários campos de sua tabela Funcionários e exportar essa tabela para um banco de dados usado pelo seu departamento pessoal.
  • Fazer uma cópia backup de uma tabela automaticamente usando uma macro ou código.
  • Criar uma tabela de histórico que contém registros antigos. Por exemplo, você poderia criar uma tabela que armazenasse todos os seus pedidos antigos antes de excluí-los de sua tabela Pedidos atual.

Converter uma consulta seleção para uma consulta ação

  1. Inicie o Microsoft Access 2002.
  2. No menu Ajuda , clique em Bancos de dados de exemplo e, em seguida, clique em Dados de exemplo Northwind .
  3. No menu Exibir , clique em Objetos de banco de dados e, em seguida, clique em consultas .
  4. Clique na consulta faturas e, em seguida, clique em Design .
  5. No menu consulta , clique em Atualizar consulta para alterar essa consulta seleção para uma consulta atualização.
  6. Na coluna PreçoUnitário para a tabela Detalhes do pedido na grade de design da consulta, digite a expressão a seguir na linha Atualizar para . Essa expressão aumentará o preço unitário de pedidos feitos em 10 por cento.
    [detalhes do pedido]. [PreçoUnitário] * 1.10
  7. Na coluna PaísDeDestino , digite EUA na linha critério .
  8. No menu consulta , clique em Executar para atualizar o preço unitário para pedidos enviados para os EUA em 10 por cento.
  9. Feche a consulta Faturas sem salvá-lo.

Alterações para a grade de design de consulta ao alterar o tipo de consulta

Depois de alterar o tipo de consulta de uma consulta seleção para uma consulta ação, grade de design da consulta será alterado como a seguir.
  • consulta atualização
    Uma linha é adicionada na grade na parte inferior da tela intitulada "Atualização para". Insira uma expressão nesta linha para atualizar um grupo de registros com base na expressão.
  • consulta acréscimo
    Solicitado o nome de tabela para acrescentar registros a, e você verá uma linha intitulada "Acrescentar A". Este é o nome do campo na tabela que você está anexando registros a. Microsoft Access preencherá automaticamente nomes de campo que correspondem entre as duas tabelas.
  • Excluir consulta
    Uma linha é adicionada à grade de design da consulta na parte inferior intitulado "Excluir". Para excluir um grupo de registros com base em critérios, altere a linha Excluir para onde e insira a expressão que a consulta deve utilizar como critério na linha critério .
  • consulta criar tabela
    Você será solicitado o nome de uma nova tabela para criar. Você também pode criar essa tabela em um banco de dados diferente. A tabela será criada com os nomes de campo e tipos de dados da tabela existente.



Referências

Para obter informações adicionais sobre como definir a propriedade UniqueRecords em uma consulta exclusão, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
240098ACC2000: "pode não excluir de tabelas especificadas" mensagem de erro na consulta excluir

Para obter mais informações sobre como criar consultas ação, clique em Ajuda do Microsoft Access no menu Ajuda , digite criar uma consulta ação no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir os tópicos retornados.
Para obter informações adicionais sobre como criar consultas seleção, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
304325Como criar uma consulta seleção no Access 2002
Para obter informações adicionais sobre como criar consultas parâmetro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
304352COMO: Criar uma consulta parâmetro no Microsoft Access 2002
Para obter informações adicionais sobre como criar consultas de tabela de referência cruzada, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
304349Como criar uma consulta de tabela de referência cruzada no Access 2002


Propriedades

ID do artigo: 304354 - Última revisão: quarta-feira, 25 de agosto de 2004 - Revisão: 3.3
A informação contida neste artigo aplica-se a:
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbmt kbquery kbhowtomaster KB304354 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 304354

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com