ACC97: Cómo crear una consulta general en Microsoft Access

Seleccione idioma Seleccione idioma
Id. de artículo: 304446 - Ver los productos a los que se aplica este artículo
Principiante: Requiere conocimientos de la interfaz de usuario en equipos de usuario único.

Este artículo se aplica únicamente a las bases de datos de Microsoft Access (.mdb).

Expandir todo | Contraer todo

Resumen

Mediante consultas de referencias cruzadas, puede crear vistas de resumen de los datos para facilitar el análisis. En este artículo se muestra cómo crear una consulta de referencias cruzadas en Microsoft Access con y sin utilizar a un asistente.

Más información

Precaución : Si sigue los pasos descritos en este ejemplo, modifique el proyecto de Access de ejemplo NorthwindCS.adp. Quizás desee hacer una copia de seguridad del archivo NorthwindCS.adp y realizar estos pasos sobre una copia del proyecto.

Crear una consulta general mediante el Asistente para consultas de referencias cruzadas

  1. Inicie Microsoft Access y, a continuación, abra la base de datos de ejemplo Neptuno.mdb.
  2. En el menú Ver , seleccione Objetos de base de datos y, a continuación, haga clic en consultas .
  3. En el menú Insertar , haga clic en consulta .
  4. En el cuadro de diálogo Nueva consulta , haga clic en Asistente para consultas de referencias cruzadas y, a continuación, haga clic en Aceptar .
  5. En la primera página del Asistente para consultas general, haga clic en pedidos en la lista de tablas y, a continuación, haga clic en siguiente .
  6. Haga doble clic en EmployeeID en la lista de Campos disponibles para agregarlo a la lista de Campos seleccionados y, a continuación, haga clic en siguiente . Esto creará una consulta con un registro por empleado.
  7. Haga clic en FechaPedido en la lista de campos y, a continuación, haga clic en siguiente .
  8. Haga clic en año para el intervalo de fecha y, a continuación, haga clic en siguiente . Esto creará una consulta con una columna por año para las fechas de pedido.
  9. Haga clic en OrderID en la lista de campos, haga clic en número en la lista de funciones y, a continuación, haga clic en siguiente .
  10. Haga clic en Finalizar en la última página del asistente.

    Tenga en cuenta que se crea una consulta que muestra un recuento de pedidos por empleado por año.

Crear una consulta de referencias cruzadas sin utilizar un asistente

  1. Inicie Microsoft Access y, a continuación, abra la base de datos de ejemplo Neptuno.mdb.
  2. En el menú Ver , seleccione Objetos de base de datos y, a continuación, haga clic en consultas .
  3. En el menú Insertar , haga clic en consulta .
  4. En el cuadro de diálogo Nueva consulta , haga clic en Vista Diseño y, a continuación, haga clic en Aceptar .
  5. En el cuadro de diálogo Mostrar tabla , haga clic en la tabla pedidos , haga clic en Agregar y, a continuación, haga clic en Cerrar .
  6. En la lista de campos de la tabla Orders, haga doble clic en cada uno de los siguientes campos para agregar los campos a la cuadrícula de diseño de consulta: PaísDestinatario , CiudadDestinatario , FormaEnvío y transporte .
  7. En el menú consulta , haga clic en Consulta de referencias cruzadas . Tenga en cuenta que se agrega una fila denominada General a la cuadrícula de diseño de consulta.
  8. Haga clic en la celda de fila Tab ref cruz en la columna PaísDeEnvío en la cuadrícula de diseño de consulta, haga clic en la flecha que aparece y, a continuación, haga clic en Encabezado de fila
  9. Haga clic en la celda de fila Tab ref cruz en la columna CiudadDestinatario en la cuadrícula de diseño de consulta, haga clic en la flecha que aparece y, a continuación, en Encabezado de fila .
  10. Haga clic en la celda de fila Tab ref cruz en la columna FormaEnvío de la cuadrícula de diseño de consulta, haga clic en la flecha que aparece y, a continuación, en Encabezado de columna .
  11. Haga clic en la celda de fila Tab ref cruz en la columna transporte en la cuadrícula de diseño de consulta, haga clic en la flecha que aparece y, a continuación, haga clic en valor . Observe que sólo un campo se puede establecer a valor .
  12. Haga clic en la celda de fila total bajo la columna de transporte de la cuadrícula de diseño de consulta, haga clic en la flecha que aparece y, a continuación, haga clic en suma .
  13. En el menú consulta , haga clic en Ejecutar para ver los resultados de la consulta de referencias cruzadas.

    Observe que la consulta devuelve el flete total por país y ciudad para cada transportista.

Referencias

Para obtener más información acerca de cómo crear consultas, haga clic en Ayuda de Microsoft Access en el menú Ayuda , escriba crear una consulta en el Ayudante de Office o el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver los temas devueltos.

Para obtener información adicional sobre cómo crear consultas de referencias cruzadas con varios campos de valor, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
109939ACC: Crear una consulta de referencias cruzadas con varios campos de valor
Para obtener información adicional sobre la creación de consultas seleccione, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304444ACC97: Cómo crear una consulta SELECT en Microsoft Access
Para obtener información adicional acerca de cómo crear consultas de parámetro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304447ACC97: Cómo crear una consulta de parámetros en Microsoft Access
Para obtener información adicional acerca de cómo convertir una consulta de selección en una consulta de acción, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304448ACC97: Cómo convertir una consulta SELECT en una consulta de acción
Para obtener información adicional acerca de cómo modificar las propiedades de una consulta, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304451ACC97: Cómo modificar propiedades de consulta en Microsoft Access
También puede ver consultas para la mayoría de las técnicas descritas en estos artículos en el archivo de ejemplo QrySmp97.exe desde el siguiente artículo:

182568ACC97: Microsoft Access 97 consultas de ejemplo disponible en el Centro de descarga

Propiedades

Id. de artículo: 304446 - Última revisión: miércoles, 31 de enero de 2007 - Versión: 3.1
La información de este artículo se refiere a:
  • Microsoft Access 97 Standard Edition
Palabras clave: 
kbmt kbhowto KB304446 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 304446
Renuncia a responsabilidad de los contenidos de la KB sobre productos a los que ya no se ofrece asistencia alguna
El presente artículo se escribió para productos para los que Microsoft ya no ofrece soporte técnico. Por tanto, el presente artículo se ofrece "tal cual" y no será actualizado.

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com