ACC97: Como criar uma tabela na base de dados do Access

Traduções de Artigos Traduções de Artigos
Artigo: 304450 - Ver produtos para os quais este artigo se aplica.
Para obter uma versão de Microsoft Access 2000 deste artigo, consulte 304262.

Principiante: Requer conhecimentos da interface do utilizador em computadores individuais.

Este artigo aplica-se apenas a uma base de dados do Microsoft Access (.mdb).

Expandir tudo | Reduzir tudo

Sumário

Na interface de utilizador do Microsoft Access, pode criar uma tabela numa base de dados utilizando qualquer um dos seguintes três métodos:
  • Pode criar uma tabela utilizando o Assistente de tabelas.
  • Pode criar uma tabela introduzindo dados numa folha de dados.
  • Pode criar uma tabela na vista de estrutura.
Este artigo mostra como utilizar cada um destes métodos.

Mais Informação

Criar uma tabela utilizando o Assistente de tabelas

  1. Crie uma nova base de dados em branco.
  2. No separador ' tabelas ', clique em Novo .
  3. Faça duplo clique em Assistente de tabelas .
  4. Siga as instruções nas caixas de diálogo Assistente de tabelas.
Se pretender modificar a tabela que cria o Assistente de tabelas, abra a tabela na vista de estrutura quando tiver terminado de utilizando o Assistente de tabelas.

Criar uma tabela por introduzir dados de uma folha de dados

No Microsoft Access, também pode criar uma tabela apenas introduzindo dados em colunas (campos) numa folha de dados. Se introduzir dados que são consistentes em cada coluna (por exemplo, nomes apenas de uma coluna) ou apenas os números de outra coluna, o Access vai atribuir automaticamente um tipo de dados para os campos. Para criar uma tabela introduzindo apenas os dados numa folha de dados, siga estes passos:
  1. Crie uma nova base de dados em branco.
  2. No separador ' tabelas ', clique em Novo .
  3. Na caixa de diálogo Nova tabela , faça duplo clique Vista de folha de dados . É apresentada uma folha de dados em branco com nomes de coluna predefinidos campo1, campo2 etc..
  4. Mudar o nome de cada coluna que pretende utilizar. Para tal, faça duplo clique no nome da coluna, escreva um nome para a coluna e, em seguida, prima ENTER.

    Pode inserir colunas adicionais em qualquer altura. Para o fazer, clique na coluna à direita do local onde pretende inserir uma nova coluna e, em seguida, no menu Inserir , clique em coluna . Mudar o nome da coluna conforme descrito anteriormente.
  5. Introduza os dados na folha de dados. Introduza cada tipo de dados na respectiva coluna. Por exemplo, se estiver a introduzir nomes, introduza o nome na respectiva coluna e o último nome numa coluna separada. Se estiver a introduzir datas, horas ou números, introduza-os num formato consistente. Se introduzir dados de uma forma consistente, o Microsoft Access pode criar um tipo de dados apropriado e apresentar o formato para a coluna. Por exemplo, para uma coluna na qual introduz apenas nomes, Access vai atribuir o tipo de dados de texto; para uma coluna na qual introduz apenas números, o Access atribuirá um tipo de dados número. As colunas que deixar em branco serão eliminadas quando guardar a folha de dados.
  6. Quando tiver adicionado dados todas as colunas que pretende utilizar, clique em Guardar no menu ficheiro .
  7. O Microsoft Access pergunta se pretende criar uma chave primária. Se não tiver introduzido dados que pode ser utilizado para identificar exclusivamente cada linha na tabela, como números de parte ou números de ID, recomenda-se que clique em Sim . Se tiver introduzido dados que identificam exclusivamente cada linha, clique em ' Não ' e, em seguida, especifique o campo que contém os dados como chave primária na vista de estrutura depois da tabela foi guardada. Para definir um campo como chave primária após a tabela tenha sido guardada, siga estes passos:
    1. Abra a tabela criada Access a partir de dados que introduziu na folha de dados na vista de estrutura.
    2. Seleccione o campo ou campos que pretende definir como chave primária.

      Para seleccionar um campo, clique no selector de linha para o campo desejado.

      Para seleccionar vários campos, mantenha premida a tecla CTRL e, em seguida, clique em selector de linha para cada campo.
    3. No menu Editar , clique em Chave primária .

      Se pretender que a ordem dos campos de uma chave primária de múltiplos campos seja diferente dos campos na tabela, clique em índices na barra de ferramentas para visualizar a janela Índices e, em seguida, ordene novamente os nomes dos campos para o índice chamado ChavePrimária.
    Como mencionado anteriormente, o Microsoft Access vai atribuir tipos de dados a cada campo (coluna) baseado no tipo de dados que introduziu. Se pretender personalizar ainda mais--a definição de um campo por exemplo, para alterar um tipo de dados Access atribui automaticamente ou para definir uma regra de validação, abra a tabela na vista de estrutura.

Criar uma tabela na vista de estrutura

Se pretender criar a estrutura da tabela básica e definem todos os nomes de campos e tipos de dados, pode criar a tabela na vista de estrutura. Para o fazer, siga estes passos:
  1. Crie uma nova base de dados em branco.
  2. No separador ' tabelas ', clique em Novo .
  3. Na caixa de diálogo Nova tabela , faça duplo clique Vista de estrutura .
  4. Em < Nome da Tabela >: tabela diálogo caixa, definir cada um dos campos que pretende incluir no índice. Para o fazer, siga estes passos:
    1. Clique na coluna Nome do campo e, em seguida, escreva um nome exclusivo para o campo.
    2. Na coluna Tipo de dados , aceitar o tipo de dados de texto que o Access atribui ou clique na coluna Tipo de dados predefinido, clique na seta e seleccione o tipo de dados que pretende.
    3. Na coluna Descrição , escreva uma descrição das informações que este campo irá conter. Esta descrição é apresentada na barra de estado quando está a adicionar dados ao campo e é incluído na definição de objecto da tabela. A descrição é opcional.
    4. Depois de adicionar alguns campos, poderá ter de inserir um campo entre dois outros campos. Para o fazer, clique na linha abaixo daquela onde pretende adicionar o novo campo e, em seguida, no menu Inserir , clique em linhas . Isto cria uma linha em branco na qual pode adicionar um novo campo.

      Para adicionar um campo no fim da tabela, clique na primeira linha em branco.
  5. Depois de ter adicionado todos os campos, defina um campo de chave primária antes de guardar a tabela. Uma chave primária é um ou mais campos cujo valor ou valores identificam exclusivamente cada registo numa tabela. Para definir uma chave primária, siga estes passos:
    1. Seleccione o campo ou campos que pretende definir como chave primária.

      Para seleccionar um campo, clique no selector de linha para o campo desejado.

      Para seleccionar vários campos, mantenha premida a tecla CTRL e, em seguida, clique em selector de linha para cada campo.
    2. No menu Editar , clique em Chave primária .
  6. Se pretender que a ordem dos campos de uma chave primária de múltiplos campos seja diferente dos campos na tabela, clique em índices na barra de ferramentas para visualizar a caixa de diálogo Índices e, em seguida, ordene novamente os nomes de campo para o índice chamado ChavePrimária.

    Não é necessário definir uma chave primária, mas normalmente é uma boa ideia. Se não definir uma chave primária, o Microsoft Access pergunta-lhe se deseja o Access crie uma quando guardar a tabela.
  7. Quando estiver pronto para guardar a tabela, no menu ficheiro , clique em Guardar e, em seguida, escreva um nome exclusivo para a tabela.

Referências

Para mais informações sobre como criar tabelas numa base de dados do Access, clique em Ajuda do Microsoft Access no menu de Ajuda escreva criar tabelas no Assistente do Office ou no Assistente de respostas e, em seguida, clique em Procurar para visualizar os tópicos devolvidos.


Para obter informações adicionais trabalhar com tipos de dados e propriedades de campo numa tabela do Access, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
304445ACC97: Explicação dos tipos de dados e propriedades do campo numa base de dados do Microsoft Access

Propriedades

Artigo: 304450 - Última revisão: 31 de janeiro de 2007 - Revisão: 3.1
A informação contida neste artigo aplica-se a:
  • Microsoft Access 97 Standard Edition
Palavras-chave: 
kbmt kbhowto KB304450 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 304450
Exclusão de Responsabilidade para Conteúdo sem Suporte na KB
Este artigo foi escrito sobre produtos para os quais a Microsoft já não fornece suporte. Por conseguinte, este artigo é oferecido "tal como está" e deixará de ser actualizado.

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com